Page 1 of 8 123 ... LastLast
Results 1 to 10 of 71

Thread: Black / blank / no login screen

  1. #1

    Exclamation Black / blank / no login screen

    LEAP 41.1
    KDE
    NVIDIA card

    Computer working was working fine. There was a large batch of updates - about 29 or so - that YaST automatically installed this AM. Later this afternoon, I tried to start Steam but it would immediately quit. Restarted computer. Now it boots to a black screen and goes no futher.

    I can drop to CLI using ALT+F2 and login but cannot start GUI.

    Solution?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,497
    Blog Entries
    15

    Default Re: Black / blank / no login screen

    Quote Originally Posted by SUSEtoad View Post
    LEAP 41.1
    KDE
    NVIDIA card

    Computer working was working fine. There was a large batch of updates - about 29 or so - that YaST automatically installed this AM. Later this afternoon, I tried to start Steam but it would immediately quit. Restarted computer. Now it boots to a black screen and goes no futher.

    I can drop to CLI using ALT+F2 and login but cannot start GUI.

    Solution?
    Hi
    Did your kernel get updated and are you running the nvidia proprietary driver? If so, then you need to upgrade the nvidia rpms for the new kernel, or if built from the run file then re-run that.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Black / blank / no login screen

    Yes: NVIDIA proprietary driver

    Was there a kernel update released today?

  4. #4

    Default Re: Black / blank / no login screen

    Zypper reports, "The highest available version is already installed" for all NVIDIA packages.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,497
    Blog Entries
    15

    Default Re: Black / blank / no login screen

    Quote Originally Posted by SUSEtoad View Post
    Yes: NVIDIA proprietary driver

    Was there a kernel update released today?
    Hi
    No, but I updated mine a week or so ago;
    Code:
    # 2016-07-22 20:50:00 kernel-default-4.1.27-27.1.x86_64.rpm installed ok
    When did you last update your system aside from today?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Black / blank / no login screen

    I update daily as YaST automatically notifies of patches.

  7. #7

    Default Re: Black / blank / no login screen

    uname -r reports "4.1.27-27-default"

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,497
    Blog Entries
    15

    Default Re: Black / blank / no login screen

    Quote Originally Posted by SUSEtoad View Post
    uname -r reports "4.1.27-27-default"
    Hi
    OK, so looks like something else. Have a look at the install history;
    Code:
    tail -n 50 /var/log/zypp/history
    See any possible culprits in the output?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Black / blank / no login screen

    "Did not refresh the bootloader. You might need to refresh it manually"

    Looks suspicious.

  10. #10

    Default Re: Black / blank / no login screen

    update-bootloader --refresh

    No improvement.

    Suspecting this is a driver issue because my 2nd display does not wake from sleep.

Page 1 of 8 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •