Results 1 to 7 of 7

Thread: firefox 47 won't work anymore (update)

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    371

    Default firefox 47 won't work anymore (update)

    Do you think it is better to let down firefox and switch to another browser since version 46 I got too many issues :{

    For now I got:
    Code:
    XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so:
    /usr/lib64/firefox/libssl3.so: version `NSS_3.23' not found (required by /usr/lib64/firefox/libxul.so)
    Couldn't load XPCOM.
    And since 46.0 update I can't play videos as firefox crashes instantly if activated.

    This is the log from zypper
    Code:
    2016-06-11 15:28:30|install|findutils|4.5.14-2.7.1|x86_64||download.opensuse.org-update|d9bc8e000ac577a174b6ec80fa73409284d761a196a59ab30d68f8
    2016-06-11 15:28:30|install|libfreebl3|3.23-34.1|x86_64||download.opensuse.org-update|ebee3919e0516df5a6b67bcb79c08ae3e9cc11141b2afbb34aca4371
    2016-06-11 15:28:30|install|mozilla-nss-certs|3.23-34.1|x86_64||download.opensuse.org-update|b0207d7c5c8b5dfd5f9444dd47f49b87ae0cc961cf02db70f
    2016-06-11 15:28:30|install|mozilla-nss-certs-32bit|3.23-34.1|x86_64||download.opensuse.org-update|546e6455de624ec9a3a007fae7ac9d600508cfb2e61
    2016-06-11 15:28:31|install|libsoftokn3|3.23-34.1|x86_64||download.opensuse.org-update|e8d8d00a8a33563847fad98ff7846772cd46a23cedc1f35e5432cfc
    2016-06-11 15:28:31|install|libfreebl3-32bit|3.23-34.1|x86_64||download.opensuse.org-update|fce0c489da916be7e960a4efb09bc481adb014bb4a431e9dce
    2016-06-11 15:28:31|install|mozilla-nss|3.23-34.1|x86_64||download.opensuse.org-update|2cf0e269515df1894f39c3f5f567e61b2f78a0c421f5cc4192b5bda
    2016-06-11 15:28:31|install|libsoftokn3-32bit|3.23-34.1|x86_64||download.opensuse.org-update|ad67c36c9c18f746df356974f82cfee0e42f365fa10f75328
    2016-06-11 15:28:31|install|mozilla-nss-tools|3.23-34.1|x86_64||download.opensuse.org-update|6b80c29be4d3561e60627084e32537549fdb044502383ac40
    2016-06-11 15:28:36|install|MozillaFirefox|47.0-71.1|x86_64||download.opensuse.org-update|eeeff4454e42ebe664dbc903f528f6056903dc2ab97ae578725d
    2016-06-11 15:28:36|install|mozilla-nss-32bit|3.23-34.1|x86_64||download.opensuse.org-update|a78475c12e2d98649d2852972d41f269fce0141a4319babc1
    2016-06-11 15:28:39|install|MozillaFirefox-translations-common|47.0-71.1|x86_64||download.opensuse.org-update|f8fba2631337ab09f2054f2202641ee5

  2. #2

    Default Re: firefox 47 won't work anymore (update)

    Quote Originally Posted by soundlord View Post
    Do you think it is better to let down firefox and switch to another browser since version 46 I got too many issues :{
    It works fine here (on 13.2 as well).

    For now I got:
    Code:
    XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so:
    /usr/lib64/firefox/libssl3.so: version `NSS_3.23' not found (required by /usr/lib64/firefox/libxul.so)
    Couldn't load XPCOM.
    I don't even have /usr/lib64/firefox/libssl3.so on my system.
    From which package is it?
    Code:
    rpm -qi /usr/lib64/firefox/libssl3.so
    It seems to be incompatible to the rest of your Firefox packages. Some left-over from some older custom installation?
    Firefox should actually use /usr/lib64/libssl3.so, which is part of mozilla-nss (and is version 3.23).

    And since 46.0 update I can't play videos as firefox crashes instantly if activated.
    Might be related, or might be a problem with your multimedia setup.
    Did you do a full switch to Packman? Firefox uses ffmpeg.
    Last edited by wolfi323; 11-Jun-2016 at 07:17.

  3. #3
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    371

    Default Re: firefox 47 won't work anymore (update)


  4. #4
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    371

    Default Re: firefox 47 won't work anymore (update)

    Backed to 45.0 and it is back working...

  5. #5

    Default Re: firefox 47 won't work anymore (update)

    Quote Originally Posted by soundlord View Post
    So rpmfind doesn't know it. But that's irrelevant.
    Where did you install it from?

    Again, run "rpm -qf /usr/lib64/firefox/libssl3.so" and post the output.

    The official openSUSE packages only contain /usr/lib64/libssl3.so, and your /usr/lib64/firefox/libssl3.so is obviously an incompatible version.

  6. #6

    Default Re: firefox 47 won't work anymore (update)

    Quote Originally Posted by soundlord View Post
    Backed to 45.0 and it is back working...
    Yeah, Firefox 45 is probably satisfied with that outdated /usr/lib64/firefox/libssl3.so .
    But that doesn't solve your problem, it only hides it.

  7. #7

    Default Re: firefox 47 won't work anymore (update)

    Quote Originally Posted by wolfi323 View Post
    Yeah, Firefox 45 is probably satisfied with that outdated /usr/lib64/firefox/libssl3.so .
    But that doesn't solve your problem, it only hides it.
    I ran into this exact same issue. I even upgraded my 13.2 to Leap 42.1 to see if that fixed it (ok, to be honest I did that in order to fix something else). Anyway, for me it was some old libraries left by various upgrades that caused the issue. I fixed it as follows:
    linux:~ # mv /usr/lib64/firefox/ /usr/lib64/firefox.org

    Then reinstall any mozilla package you have installed. In YaST, go to Software Management and search for mozilla. Upgrade any package it finds that you've already installed. For me that was:
    • MozillaFirefox
    • MozillaFirefox-branding-openSUSE
    • ca-certificates-mozilla
    • mozilla-kde4-integration
    • mozilla-nspr
    • mozilla-nspr-devel
    • mozilla-nss
    • mozilla-nss-certs
    • mozilla-nss-devel


    I know that's too much (you'll probably get away with just MozillaFirefox and the nspr / nss packages) but better safe than sorry.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •