Results 1 to 10 of 10

Thread: 13.2 nvidia driver update breaks booting, then repo not accessible

  1. #1
    -G-@gospamyourself.com NNTP User

    Default 13.2 nvidia driver update breaks booting, then repo not accessible

    Hi, I am on 13.2 (64bit)
    Today my machine would not boot.
    I suspected that it might have been the nvidia driver when I remembered
    seeing an update in a laptop yesterday.

    Booted into recovery mode and uninstalled the nvidia driver. The machine
    then booted fine (phew!) and is now using nouveau driver.

    But the odd thing is that I cannot access the nvidia repository anymore:

    Cannot access installation media:
    http://download.nvidia.con/opensuse/13.2

    If I look into the details I get:

    File
    './repodata/b7a10a7c28d0e11f47a80e696bc50e0718fd729b10ec6cd12630fb7d3767d7e9-
    primary.xml.gz' not found on medium
    'http://download.nvidia.com/opensuse/13.2/'

    I can access via a browser:
    ftp://download.nvidia.com/opensuse/13.2/

    but in the /repodata folder there is no file starting b7a10....

    Is there anything that I could do or should I just wait?
    Thanks in advance

    G.

  2. #2
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    450

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    Quote Originally Posted by -G-@gospamyourself.com View Post
    Cannot access installation media:
    http://download.nvidia.con/opensuse/13.2
    G.
    Check your URL! change .con to .com.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  3. #3
    -G-@gospamyourself.com NNTP User

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    kerijan2003 wrote:

    >
    >
    > -G-@gospamyourself.com;2781596 Wrote:
    >>
    >> Cannot access installation media:
    >> http://download.nvidia.con/opensuse/13.2
    >> G.

    >
    > Check your URL! change .con to .com.


    Oh, sorry that is just my sloppy typing! :-(
    Thanks for spotting this, but URL is correct in Yast and still no luck!


  4. #4
    Join Date
    Feb 2016
    Location
    Germany
    Posts
    43

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    Quote Originally Posted by -G-@gospamyourself.com View Post
    Hi, I am on 13.2 (64bit)
    Today my machine would not boot.
    I suspected that it might have been the nvidia driver when I remembered
    seeing an update in a laptop yesterday.

    Booted into recovery mode and uninstalled the nvidia driver. The machine
    then booted fine (phew!) and is now using nouveau driver.

    But the odd thing is that I cannot access the nvidia repository anymore:

    Cannot access installation media:
    http://download.nvidia.con/opensuse/13.2

    If I look into the details I get:

    File
    './repodata/b7a10a7c28d0e11f47a80e696bc50e0718fd729b10ec6cd12630fb7d3767d7e9-
    primary.xml.gz' not found on medium
    'http://download.nvidia.com/opensuse/13.2/'

    I can access via a browser:
    ftp://download.nvidia.com/opensuse/13.2/

    but in the /repodata folder there is no file starting b7a10....

    Is there anything that I could do or should I just wait?
    Thanks in advance

    G.

    Hi there,

    Looks like you're not alone, just in my case it's 42.1. My nvidia driver was updated yesterday evening to 367.18, then suddenly, this morning plasma crashes right after booting up, every time. I've removed the updates from yesterday and I was able to start plasma again. Now I've tried to install the same update from yesterday just to make sure it wasn't some glitch in the upgrade but the rpm that I have installed yesterday are no longer available on the nvidia page:

    Code:
    2016-06-09 19:05:33|install|nvidia-gfxG04-kmp-default|367.18_k4.1.12_1-25.1|x86_64|root@linux|download.nvidia.com-leap|0f76eda8d7d4f3bccf210947af1fe672d01158a3c4cce88fcd162bdb208baea0|
    2016-06-09 19:05:35|install|nvidia-glG04|367.18-25.1|x86_64|root@linux|download.nvidia.com-leap|4e1c67eac58ca2fa5ecd20a353c2794e2bb23057b71eb31b26ae88a4524b5fcf|
    2016-06-09 19:05:36|install|nvidia-computeG04|367.18-25.1|x86_64|root@linux|download.nvidia.com-leap|e0fb4772d6da3b3d635fa380f4d472d34445a12860fecd72558980fbca8fe807|
    2016-06-09 19:06:14|install|x11-video-nvidiaG04|367.18-25.1|x86_64|root@linux|download.nvidia.com-leap|d48a8d4727671d1bc027dca5ecf8e508662bcd5de7c3b56d0d788fe6056a24fe|
    Code:
    Retrieving package nvidia-gfxG04-kmp-default-367.18_k4.1.12_1-25.1.x86_64                                                                  (1/5),   5,8 MiB ( 65,8 MiB unpacked)
    Retrieving: nvidia-gfxG04-kmp-default-367.18_k4.1.12_1-25.1.x86_64.rpm ..................................................................................................[error]
    File './x86_64/nvidia-gfxG04-kmp-default-367.18_k4.1.12_1-25.1.x86_64.rpm' not found on medium 'http://download.nvidia.com/opensuse/leap/42.1'
    And indeed the pakage is no longer available on http://http.download.nvidia.com/open...p/42.1/x86_64/

    Now the strange thing is that I've tried to install my previous nvidia drivers but they create the same error, so it's probably not driver related more something that was broken during the upgrade. Going to try next to remove all and reinstall as explain here:

    https://en.opensuse.org/SDB:NVIDIA_drivers

    Regards,
    Damir

  5. #5
    Join Date
    Feb 2016
    Location
    Germany
    Posts
    43

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    Looks like they have got too the root of the issue here:

    https://forums.opensuse.org/showthre...-NVIDIA-driver

  6. #6
    -G-@gospamyourself.com NNTP User

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    dporobic wrote:
    > Looks like you're not alone, just in my case it's 42.1. My nvidia driver
    > was updated yesterday evening to 367.18, then suddenly, this morning
    > plasma crashes right after booting up, every time. I've removed the
    > updates from yesterday and I was able to start plasma again. Now I've
    > tried to install the same update from yesterday just to make sure it
    > wasn't some glitch in the upgrade but the rpm that I have installed
    > yesterday are no longer available on the nvidia page:


    Thanks for the follow up.
    Just in case it is useful to others...
    I downloaded the drivers manually:

    nvidia-computeG04-361.42-21.1.x86_64.rpm
    nvidia-gfxG04-kmp-desktop-361.42_k3.16.6_2-21.1.x86_64.rpm
    nvidia-glG04-361.42-21.1.x86_64.rpm
    x11-video-nvidiaG04-361.42-21.1.x86_64.rpm

    and I got it working again.

    > And indeed the pakage is no longer available on
    > http://http.download.nvidia.com/open...p/42.1/x86_64/


    Actually I can see the rpms for leap42 here:
    http://http.download.nvidia.com/open...p/42.1/x86_64/

    Thanks again!

    -G-

  7. #7
    Join Date
    Feb 2016
    Location
    Germany
    Posts
    43

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    Quote Originally Posted by -G-@gospamyourself.com View Post
    dporobic wrote:

    > And indeed the pakage is no longer available on
    > http://http.download.nvidia.com/open...p/42.1/x86_64/


    Actually I can see the rpms for leap42 here:
    http://http.download.nvidia.com/open...p/42.1/x86_64/

    -G-
    Actually I was talking about the 367.18 rpms, those are not longer there, looks like they have been removed.

    I still haven't fixed my problem, even after reverting back to 361 my plasma still crashes every time I boot:

    Code:
    QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
    Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -
    1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1
    , profile  0)  
    Application::crashHandler() called with signal 6; recent crashes: 2
    
    Still looking into this issue.

    Glad that at least for you it's working

    Regards,
    Damir

  8. #8
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    My Plasma also crashes from time to time, but it pops up again with Leap 42.1. It happened after I upgraded to 367.18.
    I was surprised, but happy they put the latest driver in their Long Lived Branch.

    Any words out when they will update the version in LLB? The Short Lived Branch is still the previous stable 364.19
    http://www.nvidia.com/object/unix.html

    I was considering to downgrade the nvidia drivers to 361.48 and see if my plasma desktop stabilizes.

    Looks like they yanked the 367.18 from the repository because it wasn't built against the right kernel.
    Installing nvidia-gfxG04-kmp-default (367.18_k4.1.12_1-25.1) updates an old kernel version
    The latest kernel update on Leap 42.1 is 4.1.21-14 and nvidia-gfxG04-kmp-default 361.48 is built against kernel 4.1.12_1-21.1.
    So I am a bit unsure if there is any point in downgrade since it too isn't built against the right kernel.
    It was the Linux kernel 4.1.12 which originally came with Leap 42.1, but it has since been updated to 4.1.21.

  9. #9
    Join Date
    Feb 2016
    Location
    Germany
    Posts
    43

    Default Re: 13.2 nvidia driver update breaks booting, then repo not accessible

    Quote Originally Posted by DJViking View Post
    My Plasma also crashes from time to time, but it pops up again with Leap 42.1. It happened after I upgraded to 367.18.
    I was surprised, but happy they put the latest driver in their Long Lived Branch.

    Any words out when they will update the version in LLB? The Short Lived Branch is still the previous stable 364.19
    http://www.nvidia.com/object/unix.html

    I was considering to downgrade the nvidia drivers to 361.48 and see if my plasma desktop stabilizes.

    Looks like they yanked the 367.18 from the repository because it wasn't built against the right kernel.
    Installing nvidia-gfxG04-kmp-default (367.18_k4.1.12_1-25.1) updates an old kernel version
    The latest kernel update on Leap 42.1 is 4.1.21-14 and nvidia-gfxG04-kmp-default 361.48 is built against kernel 4.1.12_1-21.1.
    So I am a bit unsure if there is any point in downgrade since it too isn't built against the right kernel.
    It was the Linux kernel 4.1.12 which originally came with Leap 42.1, but it has since been updated to 4.1.21.
    Hi DJViking,

    I had the situation were I've upgraded to 367.18, realized that my system is not working anymore and failed back to 361.48 and now everything is working fine. I'm using leap 42.1.
    Code:
    dporobic@linux:~> sudo zypper info kernel-defaultLoading repository data...
    Reading installed packages...
    
    
    
    
    Information for package kernel-default:
    ---------------------------------------
    Repository: openSUSE-Leap-42.1-Update
    Name: kernel-default
    Version: 4.1.21-14.2
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 223,5 MiB
    Summary: The Standard Kernel
    Description: 
      The standard kernel for both uniprocessor and multiprocessor systems.
      
      
      Source Timestamp: 2016-04-17 09:27:45 +0200
      GIT Revision: fc187c1a65ba6147000c3f2d9175df61b88d3552
      GIT Branch: openSUSE-42.1
    
    
    Information for package nvidia-gfxG04-kmp-default:
    --------------------------------------------------
    Repository: @System
    Name: nvidia-gfxG04-kmp-default
    Version: 361.42_k4.1.12_1-21.1
    Arch: x86_64
    Vendor: obs://build.suse.de/home:sndirsch:drivers
    Installed: Yes
    Status: up-to-date
    Installed Size: 59,3 MiB
    Summary: NVIDIA graphics driver kernel module for GeForce 400 series and newer
    Description: 
      NVIDIA graphics driver kernel module for GeForce 400 series and newer
    Hope this helps somehow.

    Regards,
    Damir

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,023

    Default AW: 13.2 nvidia driver update breaks booting, then repo not accessible


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •