Results 1 to 7 of 7

Thread: Kapman [game] always freezes after Level 1

  1. #1

    Default Kapman [game] always freezes after Level 1

    I just did a fresh install of Tumbleweed to a Virtualbox machine. I am relatively new to Linux and completely new to OpenSUSE and Tumbleweed.

    I then installed Kapman game from repositories. This automatically installed a number of KDE package dependencies. Although everything appears to work well, as soon as I clear Level 1 of the game, the interface freezes. The sound of the game continues as normal, but the display is frozen. I can move the mouse pointer, but clicking on any items [also outside the game, on the desktop] does not have any effect as they are either frozen or non-responsive because the machine is too busy.

    So my questions are:

    1) Is there a way to unfreeze my virtual machine without resorting to a forced reboot through virtual box? I believe there are hot key combinations that should give me control, but not sure what they are. I also think xKill is installed, but I'm not sure if there is a pre-assigned key combination for that. I can't open a terminal once this happens because the menu and everything else is frozen.

    2) What steps should I take to identify and hopefully resolve the freezing issue? I chose some non-standard options during my installation of Tumbleweed, and I'm not sure if that could cause a problem. My feeling is that this is probably a graphic driver issue. I believe the Virtualbox Guest Additions are installed automatically when one runs inside Virtualbox, and so I think that graphic driver must be in use.

    Thanks for any help.

  2. #2

    Default Re: Kapman [game] always freezes after Level 1

    Quote Originally Posted by Oxonsi View Post
    1) Is there a way to unfreeze my virtual machine without resorting to a forced reboot through virtual box? I believe there are hot key combinations that should give me control, but not sure what they are.
    You could switch to text mode via Hostkey+F1 and use kill or killall there to force quit kapman.

    I also think xKill is installed, but I'm not sure if there is a pre-assigned key combination for that. I can't open a terminal once this happens because the menu and everything else is frozen.
    I don't know whether there is a key combo in XFCE for xkill, but if *everything* is frozen, that probably won't work any more either.

    2) What steps should I take to identify and hopefully resolve the freezing issue?
    The first step would probably be to run it in a terminal window and have a look at the output.

    I chose some non-standard options during my installation of Tumbleweed, and I'm not sure if that could cause a problem. My feeling is that this is probably a graphic driver issue.
    I somehow doubt that if you can play the first level without problems...

    But: after finishing a level, a notification is shown (which normally plays a notification sound as well).
    Maybe that's what causes the freeze...

    As you are not using Plasma5, you might not have any phonon backend installed. Shouldn't cause a freeze, but who knows.
    So I would suggest to install phonon4qt5-backend-gstreamer, maybe it will help...

    I believe the Virtualbox Guest Additions are installed automatically when one runs inside Virtualbox, and so I think that graphic driver must be in use.
    Right, the guest additions are included in openSUSE and should be installed by default.

    And just for the record: I just started kapman here and don't get any freezes. Though I had to play a few times until I was able to reach the next level...

  3. #3

    Default Re: Kapman [game] always freezes after Level 1

    Thanks for your reply.

    When I try to run Kapman in the terminal, I get the following output. Not sure how to rectify this.

    Code:
    QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
    "Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"
    I selected the LXDE desktop, which I think uses Openbox window manager.

    Other non-standard options I chose were XFS file system and the Deadline IO scheduler.

    I also doubt these options are related to the Kapman freeze...

    Yes, I had been playing some Kapman in another distro, so I can usually clear the first level

  4. #4

    Default Re: Kapman [game] always freezes after Level 1

    Quote Originally Posted by Oxonsi View Post
    When I try to run Kapman in the terminal, I get the following output. Not sure how to rectify this.

    Code:
    QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
    "Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"
    This looks like you tried to run it as root.

    Just open an xterm (or whatever other terminal application you have installed) and run kapman, do *not* use su or sudo.

    And did you check that phonon4qt5-backend-gstreamer is installed?
    As I wrote, if you finish a level, a notification dialog will be displayed which also results in a notification sound by knotify. Having no Phonon backend installed might cause problems.

  5. #5

    Default Re: Kapman [game] always freezes after Level 1

    phonon4qt5-backend-gstreamer is showing as installed version 4.9.0-1.1.

    I am able to execute Kapman from the terminal as non-root user. I get the following output as the game starts. At the end of the first level, it freezes with no further output to the terminal.

    I do hear the notification sound and if I press the movement keys, I can hear Kapman moving in the next level. So it appears only the desktop display is frozen.

    What next steps can I try?

    Thanks!

    Code:
    games.ui: KStandardGameAction::create(  1 = game_new , KActionCollection(0x2739f50, name = "KXMLGUIClient-KActionCollection")  )
    games.ui: KStandardGameAction::create(  8 = game_highscores , KActionCollection(0x2739f50, name = "KXMLGUIClient-KActionCollection")  )
    games.ui: KStandardGameAction::create(  11 = game_quit , KActionCollection(0x2739f50, name = "KXMLGUIClient-KActionCollection")  )
    games.lib: Attempting to load .desktop at "/usr/share/kapman/themes/mummies_crypt.desktop"

  6. #6

    Default Re: Kapman [game] always freezes after Level 1

    Quote Originally Posted by Oxonsi View Post
    phonon4qt5-backend-gstreamer is showing as installed version 4.9.0-1.1.
    Hm, then maybe try with phonon4qt5-backend-vlc too.
    If you have both installed, the latter should be used.

    What next steps can I try?
    Well, as you run inside VirtualBox, I would recommend trying to disable 3D acceleration for the guest.
    This has caused strange problems in the past.

    What desktop are you actually using?
    Maybe disabling compositing would help.

    Code:
    games.ui: KStandardGameAction::create(  1 = game_new , KActionCollection(0x2739f50, name = "KXMLGUIClient-KActionCollection")  )
    games.ui: KStandardGameAction::create(  8 = game_highscores , KActionCollection(0x2739f50, name = "KXMLGUIClient-KActionCollection")  )
    games.ui: KStandardGameAction::create(  11 = game_quit , KActionCollection(0x2739f50, name = "KXMLGUIClient-KActionCollection")  )
    games.lib: Attempting to load .desktop at "/usr/share/kapman/themes/mummies_crypt.desktop"
    Nothing wrong there...

  7. #7

    Default Re: Kapman [game] always freezes after Level 1

    Thanks for your reply.

    In the meantime, I switched from Virtualbox to VMWare Player, and I am having better results under VMWare. There still seems to be some "lag" in the screen updating after clearing a level in Kapman. However it is not completely "frozen" as it was under Virtualbox.

    I will follow suggestions to see if I can further improve the display performance. I'm guessing it is related to the virtual display drivers.

    Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •