Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: howto remove swap (/dev/sdb2 ) from system boot

  1. #11
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Also if installing the same version use upgrade option (yes even the same version) and it will use exiting partitioning and preserve home.

    You can also take control and assign any partitioning you want.

  2. #12

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Quote Originally Posted by nrickert View Post
    When you get to the partitioning section, click "Create partitioning"
    On the next screen, select "custom partitioning".

    You should see a list of current partitions. You can right-click on any partition, and select "edit" to change how it will be used. You might need to tell it to not mount swap partitions if you don't want to use them. And you will need to have at least a partition for "/", which should be set to be formatted and mounted. On a UEFI box, you will also need the EFI partition to be mounted at "/boot/efi".
    The installer do not allow UEFI if are another partitions on disk. You can define the old /boot/efi as new /boot/efi but the installer configure the grub to not use them and a RED LETTER say the system will not boot. I need restart the installation 4 o5 times because differents issues related with dvd reader.


    Quote Originally Posted by gogalthorp View Post
    Also if installing the same version use upgrade option (yes even the same version) and it will use exiting partitioning and preserve home.

    You can also take control and assign any partitioning you want.
    This time i dont use update, in older installer the update does not allow format the partitions.

    i hope this comments are helpfull to the developers, i do with the best collaboration spirit.

    Best Regards

  3. #13
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Quote Originally Posted by schlabs View Post
    The installer do not allow UEFI if are another partitions on disk.
    That's not my experience. But perhaps that happens if your system is already using legacy MBR partitioning. In that case, the installer wants to switch to GPT partitioning, and having other partitions could present a problem with that.

    My preferred way if installing is to partition first, before starting the install. I use either "fdisk" or "gdisk" to partition the way that I want. Then, when I boot the installer, it is a matter of selecting which existing partitions to use.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #14
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Still you can go to expert mode and set the partitions as you wish.

    If you boot the installer in legacy mode no you can not do an EFI install it defaults to MBR install. Must boot installer in EFI mode then it will use the existing efi boot

  5. #15

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Quote Originally Posted by nrickert View Post
    That's not my experience. But perhaps that happens if your system is already using legacy MBR partitioning. In that case, the installer wants to switch to GPT partitioning, and having other partitions could present a problem with that.

    My preferred way if installing is to partition first, before starting the install. I use either "fdisk" or "gdisk" to partition the way that I want. Then, when I boot the installer, it is a matter of selecting which existing partitions to use.
    I agree with you about first partitioning all, and that the installer use my predefined partitions, i do on this way since mi first suse 6.4 install.

    Is a dedicated server, on a low consumption motherboard biostar n3050nh with 2 disk of 3TB. The old server was BIOS/mbr based with two 3Tb disk and was problematic.

    First install with empty disk suggest UEFI, (install aborted or incomplete). Second install sugest shrink the data partition and use GPT, i cant find to switch to UEFI.

    I think that is like say gogalthorp, i have not enough skill to configure grub2 manually to force installer to use UEFI was my first install in UEFI systems.


    Thanks for share your experience

  6. #16
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Quote Originally Posted by schlabs View Post
    Second install sugest shrink the data partition and use GPT, i cant find to switch to UEFI.
    It depends on how you boot the installer. In order to install for UEFI, you must boot the install media in UEFI mode. Exactly how to do that depends on the BIOS. If there is a setting to prefer UEFI or to boot UEFI only, then use that when booting the installer.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #17

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Quote Originally Posted by nrickert View Post
    It depends on how you boot the installer. In order to install for UEFI, you must boot the install media in UEFI mode. Exactly how to do that depends on the BIOS. If there is a setting to prefer UEFI or to boot UEFI only, then use that when booting the installer.
    I dont know how choose the type of boot, i simply put the opensuse DVD and turn on the computer.

  8. #18
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Quote Originally Posted by schlabs View Post
    I dont know how choose the type of boot, i simply put the opensuse DVD and turn on the computer.
    On one of my computers, I can hit F12 during boot. It gives me several boot options. One of the options is to boot the installer with UEFI and another is to boot with legacy MBR booting.

    On my other UEFI computer, I only get one option to boot the installer. If I have set the BIOS to prefer EFI booting, then that's the choice I get. If I have left it at the default of preferring legacy booting, then it only offers to boot the installer in legacy mode.

    It all depends on the BIOS.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #19

    Default Re: howto remove swap (/dev/sdb2 ) from system boot

    Quote Originally Posted by nrickert View Post
    On one of my computers, I can hit F12 during boot. It gives me several boot options. One of the options is to boot the installer with UEFI and another is to boot with legacy MBR booting.

    On my other UEFI computer, I only get one option to boot the installer. If I have set the BIOS to prefer EFI booting, then that's the choice I get. If I have left it at the default of preferring legacy booting, then it only offers to boot the installer in legacy mode.

    It all depends on the BIOS.
    Ok, as the problem was installing my server i cant play with this. But i think that the installer must allow choose anyway.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •