Results 1 to 7 of 7

Thread: KDE Plasma Screen Doesn't Lock with any command

  1. #1

    Unhappy KDE Plasma Screen Doesn't Lock with any command

    Hello good SUSE Samaritans
    I'm using KDE Plasma 5. My computer wasn't booting properly a few weeks ago, and I used a CD to do an upgrade instead of a complete reinstall. Ever since I've been unable to lock my screen, suspend my session, or put the computer into hibernate mode.
    I've tried the various shortcuts, right clicking on the screen and doing a "Lock Screen", from the Application Launcher menu, or running the following command.

    Code:
     qdbus org.freedesktop.ScreenSaver /ScreenSaver Lock
    I've also noticed that Plasmashell has started crashing quite frequently recently (1-2 times every day), and I'd never experienced any sort of crashes previously.
    I've been unable to find anything similar to my issue, on the forum. Sorry if this is a known issue, or if there's a solved case which I was unable to uncover, making this a duplicate post.

    You'll find below a print out of my OS version in
    Code:
    /etc/os-release
    NAME="openSUSE Leap"
    VERSION="42.1"
    VERSION_ID="42.1"
    PRETTY_NAME="openSUSE Leap 42.1 (x86_64)"
    ID=opensuse
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:opensuse:42.1"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://opensuse.org/"
    ID_LIKE="suse"

    I work in an office, so this is a very important issue for me,
    Thanks in advance

  2. #2

    Default Re: KDE Plasma Screen Doesn't Lock with any command

    Quote Originally Posted by develtrev View Post
    Hello good SUSE Samaritans
    I'm using KDE Plasma 5. My computer wasn't booting properly a few weeks ago, and I used a CD to do an upgrade instead of a complete reinstall. Ever since I've been unable to lock my screen, suspend my session, or put the computer into hibernate mode.
    Sounds like a permission problem to me.

    What display manager are you using?
    Try switching to sddm or xdm as a test.

    Could also cause crashes because user processes might not be able to access the graphics card directly because of insufficient privileges.

    Also make sure that all packages are fully uptodate by running "sudo zypper patch"

    And please also post your repo list, to rule out an incompatible package mix:
    Code:
    zypper lr -d

  3. #3

    Default Re: KDE Plasma Screen Doesn't Lock with any command

    Thanks for your response,
    The following is the repository printout.
    I'll try switching to sddm,
    Code:
    # zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Nothing to do.
    Code:
    #zypper lr -d
    
    
    #  | Alias                             | Name                                                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                           | Service
    ---+-----------------------------------+------------------------------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------+--------
     1 | Apache                            | Apache HTTPD (openSUSE_Leap_42.1)                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Apache/openSUSE_Leap_42.1/          |
     2 | Emulators_Wine                    | Wine (openSUSE_Leap_42.1)                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Leap_42.1/ |
     3 | Google-Chrome                     | Google-Chrome                                              | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                           |
     4 | SuSE                              | SuSE (Leap_42.1)                                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.videolan.org/SuSE/Leap_42.1/                                  |
     5 | download.opensuse.org-42.1-test   | Untested Updates                                           | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/update/leap/42.1-test/                           |
     6 | download.opensuse.org-non-oss     | Main Repository (NON-OSS)                                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/             |
     7 | download.opensuse.org-non-oss_1   | Update Repository (Non-Oss)                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                        |
     8 | download.opensuse.org-oss         | Main Repository (OSS)                                      | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                 |
     9 | download.opensuse.org-oss_1       | Main Repository (Sources)                                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/          |
    10 | download.opensuse.org-oss_2       | Main Update Repository                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss                             |
    11 | http-ftp.uni-erlangen.de-1a0ca650 | Packman Repository                                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Leap_42.1        |
    12 | openSUSE-42.1-0                   | openSUSE-42.1-0                                            | Yes     | (r ) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_DVD+_-RW_SH-216DB_S10Q6YBF400RSV  |
    13 | packman                           | packman                                                    | No      | ----      | Yes     |   99     | NONE   | http://ftp.gwdg.de/pub/linux/misc/packman/suse/Factory/                       |
    14 | repo-debug                        | openSUSE-Leap-42.1-Debug                                   | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/           |
    15 | repo-debug-non-oss                | openSUSE-Leap-42.1-Debug-Non-Oss                           | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/       |
    16 | repo-debug-update                 | openSUSE-Leap-42.1-Update-Debug                            | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                       |
    17 | repo-debug-update-non-oss         | openSUSE-Leap-42.1-Update-Debug-Non-Oss                    | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                  |
    18 | repo-source                       | openSUSE-Leap-42.1-Source-Non-Oss                          | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.1/repo/non-oss/      |
    19 | repo-update                       | openSUSE-Leap-42.1-Update                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                            |
    20 | science                           | Software for Scientists and Engineers (openSUSE_Leap_42.1) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_Leap_42.1/         |
    Also I understand that in the Configure Desktop/System Settings > Display and Monitor should have a Screen Saver option, but there's nothing in my menu.

  4. #4

    Default Re: KDE Plasma Screen Doesn't Lock with any command

    Quote Originally Posted by develtrev View Post
    Thanks for your response,
    The following is the repository printout.
    Looks basically ok, I see Packman for Factory in there but it is deactivated and shouldn't cause such a problem.

    One note though: you shouldn't really use VideoLAN and Packman, they are incompatible and having both may break multimedia support.
    I would recommend to remove VideoLAN, as everything (and more) is available from Packman anyway.
    But again, definitely unrelated to the problems you describe.

    I'll try switching to sddm,
    Yes, please.
    Some people did have permission problems with kdm (though I cannot reproduce that here).
    In case you didn't know, you can set the display manager in /etc/sysconfig/displaymanager (of course the one you set must be installed too, otherwise xdm will be used as fallback).

    [QUOTE]
    Code:
    # zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Nothing to do.
    Ok, then the problem should not be caused by an incomplete update or similar.

    Also I understand that in the Configure Desktop/System Settings > Display and Monitor should have a Screen Saver option, but there's nothing in my menu.
    No, that was only the case in earlier versions.
    You can configure the screenlocker in Configure Desktop->Workspace Behavior->Screen Locker. Screen Saver support has been dropped.

  5. #5

    Default Re: KDE Plasma Screen Doesn't Lock with any command

    Thanks for the pointers
    Yes, please.
    Some people did have permission problems with kdm (though I cannot reproduce that here).
    In case you didn't know, you can set the display manager in /etc/sysconfig/displaymanager (of course the one you set must be installed too, otherwise xdm will be used as fallback).
    I tried switching to kdm (it was already on sddm) and it didn't make any difference. I also tried installing the gnome destop, and switching to that, and that didn't make any difference ether.

    No, that was only the case in earlier versions.
    You can configure the screenlocker in Configure Desktop->Workspace Behavior->Screen Locker. Screen Saver support has been dropped.
    [/QUOTE]

    Turns out I don't have screenlocker. I'm assuming you meant Configure Desktop > Desktop Behavior > Screen Locker under which I couldn't find anything called Screen Locker. Below is a screenshot of the options for Workspace and also the other options available under Desktop Behavior.


  6. #6

    Default Re: KDE Plasma Screen Doesn't Lock with any command

    Quote Originally Posted by develtrev View Post
    I tried switching to kdm (it was already on sddm) and it didn't make any difference.
    Yeah, that shouldn't make any difference.
    But some people had permission problems with kdm (which could also affect the screen locker), and switching to sddm fixed it for them.
    That's why I suggested to try that.

    I also tried installing the gnome destop, and switching to that, and that didn't make any difference ether.
    I suppose you mean gdm?
    Running the GNOME desktop won't help you with the KDE screen locker obviously...



    Turns out I don't have screenlocker. I'm assuming you meant Configure Desktop > Desktop Behavior > Screen Locker under which I couldn't find anything called Screen Locker.
    Yes, that's what I meant. I'm running in german here...

    But it should be there:

    If not, there must be something wrong with your installation.
    Do you have the package kscreenlocker installed? This also contains the systemsettings module.
    If not it's obvious that the screen locker doesn't start...

    Try to force a reinstallation in any case:
    Code:
    sudo zypper in -f kscreenlocker

  7. #7

    Default Re: KDE Plasma Screen Doesn't Lock with any command

    I suppose you mean gdm?
    Running the GNOME desktop won't help you with the KDE screen locker obviously...
    What I meant was that I thought it was a problem specific to KDE and that I figured gdm would not have problems like this. But when I switched to the GNOME desktop, I had the same problems


    Try to force a reinstallation in any case:
    Code:
    sudo zypper in -f kscreenlocker
    Danke schön . The installation fixed it right away. Thank you very much.
    You're a God and I shall pray to you from now on

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •