Hello,

I've encountered my first frustration with Leap (using Xfce) after installing it on my new workstation: the intolerable 10-second delay imposed by XScreenSaver (version 5.33) after an incorrect password is entered while trying to unlock the desktop. Nothing I've tried has had any effect on changing the delay. I suffered exactly the same situation when trying openSUSE back in 2012 on a laptop with completely different hardware, but I've never seen this when using XScreenSaver on Debian.

Adding the "nodelay" option to pam_unix.so using pam-config eliminated the password delay from elsewhere in the system (e.g. sudo authentication), yet left XScreenSaver unaffected. Certain online forums point to pam_faildelay.so, but 'pam-config --list-modules' claims that module isn't even available on my system. The only source I could find on this exact issue (http://unix.stackexchange.com/questi...-opensuse-12-2) implicates /sbin/unix2_chkpwd, yet offers no solution. I've found nothing in YaST or the Xfce configs that appears to relevant.

Since FAIL_DELAY is set to the default of 3 seconds in my /etc/login.defs (which is indeed being used by su authentication) and nothing is set to 10 seconds in my ~/.xscreensaver config (which doesn't even seem to support any options regarding password delay, according to the documentation), I have no idea where this timeout is coming from, whether it be from PAM, Xfce, XScreenSaver or elsewhere. XScreenSaver is the only application I know of with this problem. The only hint I got from running XScreenSaver with verbose output was "non-PAM password auth."

I'm aware I can try gnome-screensaver or other alternatives, but I've spent so much time on this issue that I'm compelled to learn why it's happening. Thanks for any suggestions!