Results 1 to 3 of 3

Thread: Tumbleweed packages older than LEAP 42.1

  1. #1

    Default Tumbleweed packages older than LEAP 42.1

    Hello!

    I want to do an online upgrade from LEAP 42.1 to Tumbleweed.
    I did the steps in: https://en.opensuse.org/openSUSE:Tumbleweed_upgrade

    At the last step 'zypper dup' says that about 300 packages need to be downgraded.

    Example:
    Tumbleweed: alsa-oss-1.0.28-3.5
    LEAP 42.1: alsa-oss-1.0.28-5.2

    Is that normal? I thought that Tumbleweed is more recent than LEAP.

  2. #2

    Default Re : Tumbleweed packages older than LEAP 42.1

    Hello, welcome,

    The numbers after the "-" represent the package release number and are not relevant when comparing packages from different repositories. They describe the number of package rebuilds inside a given repository.

    The relevant part here is the first one, the version number (1.0.28). For alsa-oss, there is no source difference – just compare this with this – but binary result may be different because the software used to build the package may be different. That's why zypper dup forces the change to Tumbleweed packages.

    Regards,

    Antoine

  3. #3

    Default Re: Tumbleweed packages older than LEAP 42.1

    Hello!

    Thank you for the detailed answer.

    I'm going to upgrade.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •