Results 1 to 4 of 4

Thread: KMail is forcing to input Subject!

  1. #1
    -G- NNTP User

    Default KMail is forcing to input Subject!

    Hi at work I have opensuse 13.2 and noticed recently (maybe this has been so
    for some time and I never noticed?) that KMail would not send a message with
    an empty subject field.

    If I try to send it, the cursor jumps to the Subject: box and until I write
    something there, the message cannot be sent.

    Is this normal? I do remember being able to send messages without a subject
    (which would then appear as "No subject", although I agree that it is not
    great practice).
    Now I do remember that there used to be a dialogue asking if you want to
    specify a subject or send as is, maybe I set something inadvertently?
    If so how is that reset?

    Thanks!

    G


  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: KMail is forcing to input Subject!

    <rant starts>And so it should! How can I judge which emails to read if all their subjects are empty?<rant ends>

    Sorry, but IMHO this is matter of common courtesy to others.

  3. #3
    -G-@gospamyourself.com NNTP User

    Default Re: KMail is forcing to input Subject!

    john hudson wrote:
    > <rant starts>And so it should! How can I judge which emails to read if
    > all their subjects are empty?<rant ends>
    >
    > Sorry, but IMHO this is matter of common courtesy to others.


    Thank you for taking the time to answer, sadly the answer does not help in
    resolving it.

    Back to the issue, in the composer, with the current setting that is forcing
    the Subject to be filled, if the subject happens to be 'not shown', (e.g.
    when un-ticking View>Subject), emails cannot be sent and I think this would
    be quite a difficult issue to resolve unless one knows exactly what is going
    on.

    It appears that this setting is _not_ stored in in
    ~/.kde4/share/config/kmail2rc because if I delete this file and restart
    kmail2 it still insists on filling the subject.

    Most odd, at home I have Leap and it does not require the subject filling.
    Thanks for any clues.

    -G-


  4. #4
    -G-@gospamyourself.com NNTP User

    Default Re: KMail is forcing to input Subject!

    -G- wrote:

    > Hi at work I have opensuse 13.2 and noticed recently (maybe this has been
    > so for some time and I never noticed?) that KMail would not send a message
    > with an empty subject field.
    >
    > If I try to send it, the cursor jumps to the Subject: box and until I
    > write something there, the message cannot be sent.
    >
    > Is this normal? I do remember being able to send messages without a
    > subject (which would then appear as "No subject", although I agree that it
    > is not great practice).
    > Now I do remember that there used to be a dialogue asking if you want to
    > specify a subject or send as is, maybe I set something inadvertently?
    > If so how is that reset?
    >


    Just for the record, I found a solution to this query.
    A setting (not a Kmail one, but a Kontact one) is stored in the
    ..kde4/share/config/kontactrc file under the section

    [Notification Messages]
    no_subject_specified=true



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •