Results 1 to 4 of 4

Thread: Software updater QML error

  1. #1

    Default Software updater QML error

    Hello,

    My software updater plasmoid does not load anymore. Instead, it shows the following error:

    Error loading QML file: file:///opt/kf5/share/plasma/plasmoids/org.packagekit.updater/ui/main.qml:19.1: module "QtQuick" version 1.1 is not installed

    To my knowledge, I did not change anything on purpose on my Qt installation. How can I fix this? How could it possibly happen?

    Regards,
    Quentin

  2. #2

    Default Re: Software updater QML error

    Quote Originally Posted by queden View Post
    My software updater plasmoid does not load anymore. Instead, it shows the following error:

    Error loading QML file: file:///opt/kf5/share/plasma/plasmoids/org.packagekit.updater/ui/main.qml:19.1: module "QtQuick" version 1.1 is not installed

    To my knowledge, I did not change anything on purpose on my Qt installation. How can I fix this? How could it possibly happen?
    You installed apper5 from my repo (home:wolfi323:branches:KDE:Frameworks5).

    Uninstall it again, it doesn't work as it hasn't been ported to Plasma5 yet (the update applet at least, the application itself has been ported to KF5 and should work fine, but that won't offer you anything over the stable KDE4 version either).
    Or disable the applet in the "System Tray Settings".

    The standard updater in Leap 42.1 is plasma5-pk-updates, install that if it isn't there.
    Last edited by wolfi323; 29-May-2016 at 08:07.

  3. #3

    Default Re: Software updater QML error

    Thanks a lot for the explanation.

    I just wish I there would be a way again to simply install RPMs on double-clicking on the file...

  4. #4

    Default Re: Software updater QML error

    Quote Originally Posted by queden View Post
    I just wish I there would be a way again to simply install RPMs on double-clicking on the file...
    I don't think this works with Apper5 anyway, you could install the KDE4 apper (still included in Leap 42.1) though.

    Or see here for how to make .rpm files "open" in YaST or zypper:
    https://forums.opensuse.org/showthread.php/510586-Installing-third-party-RPM-s-in-Leap?p=2776671#post2776671

    PS: I changed my apper5 package meanwhile to not enable the (broken) system tray updater applet by default.
    The application itself should work fine, I'm just not sure if installing .rpm files works at the moment with the KF5 port.
    Last edited by wolfi323; 04-Jun-2016 at 02:41.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •