Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Pulseaudio not working

  1. #1

    Default Pulseaudio not working

    When I install and try to start up Pulseaudio, I receive this error message:

    http://pasteboard.co/XT5YSbf.png

    Why is that?

    Specs

    OpenSUSE Leap 42.1
    Logitech G35 USB headset
    AMD FX-8350
    MSI R9 280x
    ASUS M5A97 R 2.0

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,158

    Default Re: Pulseaudio not working

    How did you install (isn't it installed by default)?

    How did you try to start it?
    Henk van Velden

  3. #3

    Default Re: Pulseaudio not working

    Quote Originally Posted by hcvv View Post
    How did you install (isn't it installed by default)?

    How did you try to start it?
    Installed it by opening Yast 2 and searching for "pulseaudio" in the local repositories.

  4. #4

    Default Re: Pulseaudio not working

    And also opened it by selecting it from the "start menu".

    Edit: I installed the package "pavucontrol". Is there anything more that's needed to get it to work?

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Pulseaudio not working

    PA is installed by default in most cases at least. You need to explain why your system is different?

    Does audio work in Yast -sound?

    Be sure the PA usage is selected there

  6. #6

    Default Re: Pulseaudio not working

    Well, to be honest I don't know. I only remember that I used YaST to install it, without even considering the possibility of it already being there.

    I installed OpenSUSE with LXDE only if that has anything to do with it.

  7. #7

    Default Re: Pulseaudio not working

    And also, when I go to "sound" in Yast, click "other" and then "PulseAudio configuration" i recieve the following error:



    "PulseAudio is not installed or cannot be configured."

  8. #8

    Default Re: Pulseaudio not working

    Anyone

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: Pulseaudio not working

    The error you reported in your opening post refers to a mis-configured client.conf, so you should investigate that first. It's located in the /etc/pulse/ directory. Post the configuration here if needed.

    Review this troubleshooting guide for PA
    https://www.freedesktop.org/wiki/Sof...oubleshooting/

    Any errors reported here?
    Code:
    journalctl -b |grep pulse
    I'm assuming the daemon won't be running, but you can check anyway...
    Code:
    ps aux|grep pulse
    If it isn't running, try launching in a terminal as regular user
    Code:
    pulseaudio -vvv
    If it is running, then you need to kill it first, but openSUSE has client.conf configured to respawn it automatically so that needs to be turned disabled first. The following option in client.conf will take care of that
    Code:
    autospawn = no
    then kill PA with
    Code:
    pulseaudio -k
    Capture what is reported by the daemon when relaunched as that might yield more information about what is wrong.
    Last edited by deano_ferrari; 17-May-2016 at 19:04.

  10. #10

    Default Re: Pulseaudio not working

    Quote Originally Posted by deano_ferrari View Post
    *
    http://pasteboard.co/112ChkRq.png

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •