Results 1 to 4 of 4

Thread: OpenMPI with mpi-selector

  1. #1

    Default OpenMPI with mpi-selector

    Hello, I have experienced a problem after installing the OpenMPI packages ( openmpi and openmpi-devel, version 1.10.2 ). After the installation I tried to execute mpicc to see if it was working.
    The first problem was that the openmpi binaries were not in the PATH. I looked over the internet and found out that I had to use the tool "mpi-selector", so I went and try it ( version 1.03 ). After setting the default MPI implementation with "mpi-selector --set openmpi-1.10.2" and after restarting the computer I expected that all environmental variables were correctly set (path, man pages, lib...). That did not happen.
    I then manually exported the variables and it worked. I would like to know if this is a known bug with the mpi-selector tool, if not it needs to be reported, or if I used the tool incorrectly.
    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,371
    Blog Entries
    2

    Default Re: OpenMPI with mpi-selector

    Hello,
    First, I guess I'd wonder where you obtained your openmpi.

    Then,
    I'd point out that openmpi v1.6 packages are available for TW, there is even a 1.8 version version if were running on LEAP.
    https://software.opensuse.org/package/openmpi

    Although you don't seem to be asking about 2.x packages, I don't seem to see any available.

    If you do decide to re-build using more current packages, it would be nice if you posted your results here in these Forums so others know about this important technology (Scaling out application code to run across extremely large high performance clusters).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: OpenMPI with mpi-selector

    I am running openSuse Tumbleweed, and the packege I just got it from the OSS main repository with the Software Managment tool.
    I tried getting the package from your link but it seems the object is not found (Error 404).

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,371
    Blog Entries
    2

    Default Re: OpenMPI with mpi-selector

    Quote Originally Posted by martyns View Post
    I am running openSuse Tumbleweed, and the packege I just got it from the OSS main repository with the Software Managment tool.
    I tried getting the package from your link but it seems the object is not found (Error 404).
    Looking at the OBS notes for the openmpi package,
    https://build.opensuse.org/package/s...ackage=openmpi
    It looks like although the version has remained at 1.10, patches have been applied even as recently as one month ago from upstream 1.8.

    So, I guess the one package you have available to you is as up to date as can be expected.

    Those links should be cleaned up. Clicking through a number of OBS links (which is where the software.opensuse.org links point to), it looks like there is quite a bit of stuff that is based on the pre-merge when TW and Factory became one. I don't know if this is something that is often seen and can be cleaned up automatically or someone has to manually fix everything.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •