Results 1 to 4 of 4

Thread: Compiling ReadyMedia (MiniDLNA)

  1. #1

    Default Compiling ReadyMedia (MiniDLNA)

    Hello all,
    I am trying to compile ReadyMedia on a current OpenSUSE Leap 42.1 system.
    But ./configure cannot find libavutil:

    Code:
    checking libavutil/avutil.h usability... no checking libavutil/avutil.h presence... no
    checking for libavutil/avutil.h... no
    checking ffmpeg/libavutil/avutil.h usability... no
    checking ffmpeg/libavutil/avutil.h presence... no
    checking for ffmpeg/libavutil/avutil.h... no
    checking libav/libavutil/avutil.h usability... no
    checking libav/libavutil/avutil.h presence... no
    checking for libav/libavutil/avutil.h... no
    checking avutil.h usability... no
    checking avutil.h presence... no
    checking for avutil.h... no
    checking ffmpeg/avutil.h usability... no
    checking ffmpeg/avutil.h presence... no
    checking for ffmpeg/avutil.h... no
    checking libav/avutil.h usability... no
    checking libav/avutil.h presence... no
    checking for libav/avutil.h... no
    checking libavutil/avutil.h usability... no
    checking libavutil/avutil.h presence... no
    checking for libavutil/avutil.h... no
    checking ffmpeg/libavutil/avutil.h usability... no
    checking ffmpeg/libavutil/avutil.h presence... no
    checking for ffmpeg/libavutil/avutil.h... no
    checking libav/libavutil/avutil.h usability... no
    checking libav/libavutil/avutil.h presence... no
    checking for libav/libavutil/avutil.h... no
    checking avutil.h usability... no
    checking avutil.h presence... no
    checking for avutil.h... no
    checking ffmpeg/avutil.h usability... no
    checking ffmpeg/avutil.h presence... no
    checking for ffmpeg/avutil.h... no
    checking libav/avutil.h usability... no
    checking libav/avutil.h presence... no
    checking for libav/avutil.h... no
    configure: error: libavutil headers not found or not usable

    although this is installed and also present on the server in /usr/include/ffmpeg/libavutil/avutil.h
    Any hints where the problem could be? I tried to give ./configure the path explicitly but this didn't help.
    Best

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,110
    Blog Entries
    15

    Default Re: Compiling ReadyMedia (MiniDLNA)

    Hi
    I see someone has already built the 1.1.5 version on OBS;
    https://build.opensuse.org/package/s...ckage=minidlna

    I would guess it's missing libavutil-devel, have a look at the users spec file to see how they built it;
    https://build.opensuse.org/package/v....spec?expand=1

    If you want their build go to;
    http://download.opensuse.org/reposit...USE_42/x86_64/
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Compiling ReadyMedia (MiniDLNA)

    Hi,

    I would like to compile it myself.
    libavutil-devel is installed and also the other devel packages. The needed file is also on the hard disk and usable at that place. That is what I do not understand.

    I "solved" the issue by compiling ffmpeg by myself, but still do not know, what the problem was.

    Best

  4. #4

    Default AW: Compiling ReadyMedia (MiniDLNA)

    Workaorund, just for the record:

    Code:
    rpm -q libavutil-devel 
    libavutil-devel-3.0.1-62.1.i586
    (from Packman Repo)

    Code:
    pkg-config --cflags libavutil
    -I/usr/include/ffmpeg
    =>

    Code:
    CFLAGS+="-I/usr/include/ffmpeg" ./configure
    or

    Code:
    CFLAGS+="$(pkg-config --cflags libavutil)" ./configure

    Works for me™

    AK

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •