Results 1 to 4 of 4

Thread: Looking for help in installing Tixati torrent client

  1. #1

    Default Looking for help in installing Tixati torrent client

    I've tried the Torrent client that comes with Leap but I would prefer to use another torrent client called Tixati. I've been using it for quite a while and like it. I have the standard repositories installed along with packman. I tried searching for Tixati in Yast but there were no results. I went to the Tixati site and downloaded the 64bit and 32 bit rpm files. I first tried the 64 bit using the rpm-i method - Yast had a problem with the "packaging". The 64 bit client failed to install due to a missing dependency:
    [CODE][rpm -i tixati-2.38-1.x86_64.rpm
    error: Failed dependencies:
    libdbus-1.so.3(LIBDBUS_1_3)(64bit) is needed by tixati-2.38-1.x86_64
    /CODE]
    There is a version of libdbus installed with Leap - I tried finding a more compatible version but it rejected everything I downloaded saying what was already installed was newer.
    I then tried the 32 bit file and it also failed due to missing dependencies:
    Code:
    rpm -i tixati-2.38-1.i686.rpm
    error: Failed dependencies:
            libcairo.so.2 is needed by tixati-2.38-1.i686
            libdbus-1.so.3(LIBDBUS_1_3) is needed by tixati-2.38-1.i686
            libdbus-glib-1.so.2 is needed by tixati-2.38-1.i686
            libgdk-x11-2.0.so.0 is needed by tixati-2.38-1.i686
            libgdk_pixbuf-2.0.so.0 is needed by tixati-2.38-1.i686
            libgio-2.0.so.0 is needed by tixati-2.38-1.i686
            libglib-2.0.so.0 is needed by tixati-2.38-1.i686
            libgobject-2.0.so.0 is needed by tixati-2.38-1.i686
            libgthread-2.0.so.0 is needed by tixati-2.38-1.i686
            libgtk-x11-2.0.so.0 is needed by tixati-2.38-1.i686
            libpango-1.0.so.0 is needed by tixati-2.38-1.i686
            libpangocairo-1.0.so.0 is needed by tixati-2.38-1.i686
    Has anyone installed Tixati and can they tell me what version of libdbus I need to install - and where to find it. I've gone to a couple of site and on one of them there were over 160 versions of libdbus!
    Thanks for any suggestions and assistance!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: Looking for help in installing Tixati torrent client

    Hi
    Grab the manual install download 64Bit, extract and see the readme on where to place the files.. just tested here on Leap and it works fine.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Looking for help in installing Tixati torrent client

    Thank you Malcolmlewis for the reply and your assistance. I did as you suggested and was able to install Tixati. I followed the readme instructions but had to make one slight change - the bin file in the archive did not have the execute permission(rw-r--r--) so I had to change it to rwxr-xr-x) before the app would run.
    I'm still puzzled by why the nornal software management tools -Yast and rpm-i - would not work but I'm glad to get Tixati running and I thank you again for your help.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: Looking for help in installing Tixati torrent client

    Quote Originally Posted by horhota View Post
    Thank you Malcolmlewis for the reply and your assistance. I did as you suggested and was able to install Tixati. I followed the readme instructions but had to make one slight change - the bin file in the archive did not have the execute permission(rw-r--r--) so I had to change it to rwxr-xr-x) before the app would run.
    I'm still puzzled by why the nornal software management tools -Yast and rpm-i - would not work but I'm glad to get Tixati running and I thank you again for your help.
    Hi
    Looking at the rpm it's a Fedora rpm, so the naming is different hence the error it couldn't find the lib. You could have told it to ignore the dependency and all should have been good....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •