Results 1 to 2 of 2

Thread: Hibiscus could not fetch data due to wrong openJDK 8 security settings

  1. #1

    Default Hibiscus could not fetch data due to wrong openJDK 8 security settings

    Today I wasn't able to communicate with my bank account using Jameica/Hibiscus HBCI on openSUSE 42.1. The error message was something like:

    Code:
     javax.net.ssl.SSLException: java.lang.RuntimeException: java.security.NoSuchAlgorithmException: EC AlgorithmParameters not available
    I found this bugreport: https://bugzilla.redhat.com/show_bug.cgi?id=1167153 and accordingly changed this file:

    Code:
     /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/jre/lib/security/java.security
    I replaced the line

    Code:
     jdk.tls.disabledAlgorithms=SSLv3, RC4, MD5withRSA, DH keySize < 768
    with

    Code:
     jdk.tls.disabledAlgorithms=SSLv3, RC4, MD5withRSA, DH keySize < 768, EC,ECDHE,ECDH
    Then I restarted hibiscus and it worked again.

    I wonder if the new line could be included in openSUSE by default.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,823
    Blog Entries
    1

    Default Re: Hibiscus could not fetch data due to wrong openJDK 8 security settings

    You can report your finding by creating a bug at https:/bugzilla.opensuse.org.

    Be sure to include information about your java with something like the following(may need to name the exact packagename)
    Code:
    zypper info openjdk
    Along with where you found your solution and your actual fix.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •