Results 1 to 7 of 7

Thread: FileZilla problem after a libfilezilla update

  1. #1

    Default FileZilla problem after a libfilezilla update

    Recently I have received an automatic update to libfilezilla-0.5.0_6.1 (from openSUSE Leap 42.1 - Network repository); now FileZilla Client 3.16.1 displays an empty folder when I try to connect to certain FTP servers (while gFTP works perfectly).
    I have written to the FileZilla developers and they have told me that I need to update FileZilla too (to version 3.17).
    Currently, in the openSUSE Leap 42.1 repositories, the latest version of FileZilla is 3.16.1-81.1; FileZilla 3.17 is available in Factory or Tumbleweed, but it requires a lot of new libraries (libc, libdbus, etc).
    So, now I am looking for the previous version of libfilezilla, but I can't find it; it is no longer available in the Leap 42.1 repositories.
    I have found an old version (0.4.0.1) in an unofficial repository and now FileZilla is working again, but I think it is very dangerous to install packages from unofficial repositories.
    So, is there any way to obtain the previous version of libfilezilla from the Leap 42.1 Network repository?

    Thanks.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,882

    Default AW: FileZilla problem after a libfilezilla update


  3. #3

    Default Re: AW: FileZilla problem after a libfilezilla update

    Quote Originally Posted by Sauerland View Post
    Thank you so much Sauerland; it works!

    Strangely, in the openSUSE Build Service, filezilla 3.17 build (for Leap 42.1) fails because "nothing provides libnettle >= 3.1" (it is a cryptographic library).
    The ecsos repositoy, instead, provides libnettle 6.x.

  4. #4
    Join Date
    Sep 2010
    Location
    Germany
    Posts
    21

    Default AW: FileZilla problem after a libfilezilla update

    Hello,

    nice to hear that my package run. :-)

    so i make an request for libnettle to network repo.

    Regards
    Eric

  5. #5

    Default AW: FileZilla problem after a libfilezilla update

    Quote Originally Posted by ecsos View Post
    so i make an request for libnettle to network repo.
    Fun fact, at least until now, this is not really necessary.

    Setting
    Code:
    BuildRequires:  pkgconfig(nettle) >= 3.1
    makes sense at first glance, as it is set in the configure script, most likely the developer set this according to his build enviroment.

    However, setting

    Code:
    BuildRequires:  pkgconfig(nettle) >= 2.7
    and adding this little hack to the %prep section

    Code:
    ## hack: libnettle 2.7 seems to be good enough
    sed -i 's|nettle 3.1|nettle 2.7|g;s|nettle >= 3.1|nettle >= 2.7|g' configure.ac configure
    still works. This might change in the future but until now (3.17.0.1) nettle 2.7 is recent enough for running a successful build.

    AK

    P.S. When updating filezilla to 3.17.0.1 you will need the patch "filezilla-wxstring.patch" (at least if your build links dynamically against wxWidgets) which can be found here:

    http://pkgs.fedoraproject.org/cgit/r...illa.git/tree/

  6. #6

    Default Re: FileZilla problem after a libfilezilla update

    FileZilla Client 3.17 and libnettle 6.x have arrived in the Network repo (Leap 42.1).

  7. #7
    Join Date
    Sep 2010
    Location
    Germany
    Posts
    21

    Default AW: FileZilla problem after a libfilezilla update

    Quote Originally Posted by Akoellh View Post
    Fun fact, at least until now, this is not really necessary.

    Setting
    Code:
    BuildRequires:  pkgconfig(nettle) >= 3.1
    makes sense at first glance, as it is set in the configure script, most likely the developer set this according to his build enviroment.

    Only with BuildRequires the package will only build when nettle is aviable.
    Otherwise the old package version will stay an run.

    Code:
    BuildRequires:  pkgconfig(nettle) >= 2.7
    and adding this little hack to the %prep section

    Code:
    ## hack: libnettle 2.7 seems to be good enough
    sed -i 's|nettle 3.1|nettle 2.7|g;s|nettle >= 3.1|nettle >= 2.7|g' configure.ac configure
    still works. This might change in the future but until now (3.17.0.1) nettle 2.7 is recent enough for running a successful build.

    No it is.
    Look in Changelog:
    + Building FileZilla now depends on the Nettle library,
    version 3.1 or later.


    AK

    P.S. When updating filezilla to 3.17.0.1 you will need the patch "filezilla-wxstring.patch" (at least if your build links dynamically against wxWidgets) which can be found here:

    http://pkgs.fedoraproject.org/cgit/r...illa.git/tree/
    Okay. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •