Results 1 to 4 of 4

Thread: Lenovo S205 + openSUSE 42.1 Leap

  1. #1

    Default Lenovo S205 + openSUSE 42.1 Leap

    Hello. I have a trouble with Leap installation on Lenovo s205. I had a luck to install openSUSE on it few years before, but now I cannot repeat the success (either I cannot find the manual which helped me that time, or it doesn't work for Leap). Current partitions are: EFI Boot, root, home and swap. The first one has size 121 Mb, is formatted as FAT32 and is mounted at /boot/efi. After the system boot I get grub command line and nothing more. Also during installation there was a warning: "There is no partition of type bios_grub present", but the previous openSUSE worked successfully without any extra partitions (except EFI Boot).
    So what can I do to make openSUSE Leap to boot properly? I've tried to search but was unable to find a comprehensive instruction.

  2. #2
    Join Date
    Nov 2009
    West Virginia Sector 13

    Default Re: Lenovo S205 + openSUSE 42.1 Leap

    Are you booting installer in EFI mode? You may have to chose that in the EFI boot menu. Which key to press to get the menu is hardware dependent, but is sometime shown on the splash screen

  3. #3

    Default Re: Lenovo S205 + openSUSE 42.1 Leap

    How can I display UEFI Boot menu? I boot from live USB and then run Live Installer.

  4. #4
    Join Date
    Aug 2010
    Chicago suburbs
    Blog Entries

    Default Re: Lenovo S205 + openSUSE 42.1 Leap

    Quote Originally Posted by wimoza View Post
    How can I display UEFI Boot menu?
    On my Lenovo ThinkServer, if I hit F12 while the logo is showing, I get a boot menu (BIOS boot menu).

    I do have the BIOS set to prefer UEFI booting.
    opensuse Leap 15.0; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts