Results 1 to 5 of 5

Thread: Trackpoint Cursor Speed Too Slow

  1. #1

    Question Trackpoint Cursor Speed Too Slow

    I have a new install of OpenSUSE Tumbleweed XFCE. After trying a dozen different Linux distros, I think we have a winner. I'm working out the last bits.

    I have a TrackPoint keyboard. I need it because a mouse gives me carpal tunnel. But my Trackpoint cursor is too slow. I have to use a lot of pressure to move it around.

    I've tried to fix this myself and saw a bunch of posts talking about
    • xinput
    • xev
    • xorg
    • saz(?)
    • sysfs
    • evdev
    • /sys/devices/platform/i8042/serio1/serio2/speed
    • /sys/devices/platform/i8042/serio1/serio2/sensitivity

    But it seems there is some new system being used, and a lot of the above is out-of-date. And I don't even have some of those on my system.

    I *do* have:
    • /sys/devices/platform/i8042/serio0

    I tried setting the speed faster with the GUI in XFCE. I don't think it did anything, or it was barely noticeable.

    How I can speed up my Trackpoint? I'd like to to go double or triple the speed it's going now.

  2. #2

    Default Re: Trackpoint Cursor Speed Too Slow

    Can anybody at least get me started?

    What is used instead of xinput,
    or where the speed setting is stored?

  3. #3

    Default Re: Trackpoint Cursor Speed Too Slow

    Do these Arch Linux pages apply to OpenSUSE?
    and here:

    udev configuration rule

    This rule increases the trackpoint speed and enables tap to select (see above) on boot. Feel free to alter the values and add other modifications to files in /sys/devices/platform/i8042/serio1/serio2/. The rule also works for trackpoint-only devices.

    /etc/udev/rules.d/10-trackpoint.rules ACTION=="add", SUBSYSTEM=="input", ATTR{name}=="TPPS/2 IBM TrackPoint", ATTR{device/sensitivity}="240"
    These files don't exist. Should I create them?


  4. #4

    Default Re: Trackpoint Cursor Speed Too Slow


    How about even just a high level overview of how the input devices are currently managed in OpenSUSE?


    The BIOS presents <something> to the <subsystem>.
    Subsystem stores <details> to <filename>.
    OpenSUSE uses <process> now to manage this stuff.
    XFCE <does/doesn't> matter.

    You will need to run <some command> to list your devices,
    then open <this file> and look for the Trackpoint device,
    change the value from <default> to <2x>
    then reboot.

  5. #5

    Default Re: Trackpoint Cursor Speed Too Slow

    I had the same problem with my wife's Thinkpad x61. I am running tumbleweed.

    I found the following two sites helpful.

    This one helps get the xinput lines you need to run:

    and this one explains all the settings and what they do (including the different profile options):

    The following is the script I came up with, but you will have to make one for your own needs. This might be too loose a pointer for you. My wife has a condition that makes her need such a loose trackpoint. Also, your input device number may be different.

    ## Option "AccelerationProfile"  
    xinput set-prop "TPPS/2 IBM TrackPoint" 259 2
    ## Option "ConstantDeceleration"  
    xinput set-prop "TPPS/2 IBM TrackPoint"  260 0.1
    ## Option "AdaptiveDeceleration" 
    xinput set-prop "TPPS/2 IBM TrackPoint"  261 1.0
    ## Option "VelocityScale" 
    xinput set-prop "TPPS/2 IBM TrackPoint"  262 1
    ## Option "AccelerationThreshold"   "0" # this disables acceleration in profile 7
    ## Coordinate Transformation Matrix 
    xinput set-prop "TPPS/2 IBM TrackPoint" 137 10, 0, 0, 0, 10, 0, 0, 0, 10
    The only problem I've had is that I can't get my xorg config file to work on boot, so she has to run this script every time she logs in. That can be automated, of course.

    Hope that helps.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts