Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: For booting in "Text Mode" from ISO, offer resolutions

  1. #1

    Default For booting in "Text Mode" from ISO, offer resolutions

    Hello, I'm visually impaired, and I can not comfortable, nor easily read the text on the screen in this mode at 1920x1080. I think it's way too small. At the least, I'd like it to offer "Text Mode (1920x1080)" and "Text Mode (1280x720) so I can read it better. I'd guess it's 7 pt font or smaller, and it's very time consuming to read. I like to stay about 18 inches away from the screen, and half of that's not remotely possible in this mode.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    please explain more what you mean booting from ISO

    If this is a normal install you can set the text terminal resolution in yast - boot loader, but I don't truly understand what you are doing so please expand.

  3. #3

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    Quote Originally Posted by gogalthorp View Post
    please expand.
    Just like an ISO. It usually gets expanded for use as a boot medium. In this case I'm booting using a CD. I'm unable to get power to a flash drive in bios with this computer.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    Still don't know?? You use the ISO image to boot the installed system??? If so something is broken it should not be needed.. You can change the resolution from the boot menu by editing the grub boot code but that is a one time change and if you are using an install image to boot the machine then you would need to do so with each boot.

    You obviously are doing things differently then most others so you need to be clear on what and why you do things as you do.

  5. #5

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    You're making this complicated! I have an old hard drive in the system, with an NTFS partition, so far it doesn't look like I need to keep anything, but it's fun going through it. It also (had) a copy of Debian on it, but grub isn't there anymore, so I guess it's gone.

    I downloaded the Tumbleweed net installer for 32 bit. That download is an ISO file. With that ISO file, I burned it (expanded it) onto a CD, on windows, with CDBurner XP. Great program. With the CD, I put it into another machine (with the stuff written above on it). I booted with that CD. When I'm asked to "boot from hard disk", "upgrade", "installation" etc etc, I have several options to choose from at the bottom of the screen.

    If I push F3, that is for video modes. I can pick many resolutions, and two of them being widescreen, only one (1280x720) being usable for me, as I don't want to strain my eyes at close distances to the monitor.

    The graphical mode for whatever reason (any of those resolutions) is slower than frozen molasses, and I'm not going to wait a week for my actions to be displayed. So I choose "Text Mode". The problem is, it defaults to the highest native resolution, that being 1920x1080 of my monitor.

    I struggle heavily to read this, and it's not enjoyable. I like 720p. (or in Windows, I can scale up everything to that size and utilize 1080p. It's 150% larger...).

    I would like an option when choosing the video mode (by pushing F3 and picking from the list of options) to choose the resolution of the text mode, so I can enjoy installing OpenSUSE and not struggling to read it--this is extremely important when it comes to partitioning.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,846
    Blog Entries
    15

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    On Fri 29 Apr 2016 05:06:02 PM CDT, timpster wrote:

    You're making this complicated! I have an old hard drive in the system,
    with an NTFS partition, so far it doesn't look like I need to keep
    anything, but it's fun going through it. It also (had) a copy of Debian
    on it, but grub isn't there anymore, so I guess it's gone.

    I downloaded the Tumbleweed net installer for 32 bit. That download is
    an ISO file. With that ISO file, I burned it (expanded it) onto a CD,
    on windows, with CDBurner XP. Great program. With the CD, I put it
    into another machine (with the stuff written above on it). I booted
    with that CD. When I'm asked to "boot from hard disk", "upgrade",
    "installation" etc etc, I have several options to choose from at the
    bottom of the screen.

    If I push F3, that is for video modes. I can pick many resolutions, and
    two of them being widescreen, only one (1280x720) being usable for me,
    as I don't want to strain my eyes at close distances to the monitor.

    The graphical mode for whatever reason (any of those resolutions) is
    slower than frozen molasses, and I'm not going to wait a week for my
    actions to be displayed. So I choose "Text Mode". The problem is, it
    defaults to the highest native resolution, that being 1920x1080 of my
    monitor.

    I struggle heavily to read this, and it's not enjoyable. I like 720p.
    (or in Windows, I can scale up everything to that size and utilize
    1080p. It's 150% larger...).

    I would like an option when choosing the video mode (by pushing F3 and
    picking from the list of options) to choose the resolution of the text
    mode, so I can enjoy installing OpenSUSE and not struggling to read
    it--_this_is_extremely_important_when_it_comes_to_partitioning._


    Hi
    At the grub menu push the e key to edit and in the kernel options (the
    one with quiet in it) add your desired vga mode via vga= eg vga=264
    (80x60), when do, press F10 to boot.

    See more here: https://en.wikipedia.org/wiki/VESA_BIOS_Extensions


    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.1|GNOME 3.16.2|4.1.20-11-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    Well, I might be able to get somewhere with this. 1280x1024 is very close to 1920x1080 (the height controls size) but I chose the "No KMS" in the video options, and I just let it sit. For maybe an hour and a half. Then I think it really settled down, and I'm waiting to get into the partitioner. Linux finds a way! (Even if that way is really confusing and I don't understand any of it, at least it's an option!)

  8. #8

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    Well maybe Linux doesn't find a way today--still getting the error after all the repos load (it's right after the language / keyboard / license screen in the setup. Once I click next, the repos start loading--then I'm thrown to a blue background and a red box saying "An error has occurred" so I have no idea how to fix that. Now trying with a wireless PCI card that has a driver in linux, which is always nice. So for now, I'll go back to my other thread.

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    Is this a net install or are you using the full DVD?

    You must remember we can not see over your shoulder so you have to tell use what you are doing. So it appears you are installing. The full DVD does not require a working network.

    nokms forces use of fall back video drivers which generally do not support higher resolution.

  10. #10

    Default Re: For booting in "Text Mode" from ISO, offer resolutions

    Quote Originally Posted by gogalthorp View Post
    Is this a net install or are you using the full DVD?

    You must remember we can not see over your shoulder so you have to tell use what you are doing. So it appears you are installing. The full DVD does not require a working network.

    nokms forces use of fall back video drivers which generally do not support higher resolution.
    Net install, sorry! Let's take this to: https://forums.opensuse.org/showthre...-Can-t-proceed

    I made a new thread about it as this one was only related to resolution. Thank you for explaining nokms, that's good to know, and it seems the limit is 1024 height.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •