Results 1 to 10 of 10

Thread: The keyboard changes the layout often

Hybrid View

  1. #1
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Exclamation The keyboard changes the layout often

    Hi!

    For some reason, the keyboard of my laptop changes the layout often. Than, I need to restart the notebook to solve. Which information I need to give you to help me with this?

    I had tried choose the layout by yast or gnome, but didn't work yet.

    Many thanks.

  2. #2

    Default Re: The keyboard changes the layout often

    when you go to gnome control center in region & language, what input sources do you find there?

    I assume if you only leave portuguese (I'm assuming that's the one you want) it should not switch anymore.

  3. #3
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: The keyboard changes the layout often

    There is only "Portugues Brasil" in region & language. When the keyboard layout changes occurs, I check yast keyboard and gnome region & language also, but nothing change in this places - still in Portuguese Brazil. Then I need apply the already selected language again. Strange.

    I have tried add the layout manually in /etc/sysconfig/keyboard, but still the same.

  4. #4

    Default Re: The keyboard changes the layout often

    I believe yast only changes the console layout, and I assume it is working correctly. but we can test: Ctrl+Alt+F3 and verify if the layout is indeed portuguese brazilian.

    If so, that's probably a good sign, and it means gnome for some reason is not loading the correct settings, so nothing like trying to force it to:
    open dconf-editor (you might need to install this) and go to desktop > ibus > general - then find "use-system-keyboard-layout" and change "false" to "true" (move the little slider to the left and select "true").

  5. #5
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: The keyboard changes the layout often

    Hi!

    I tested in the console (Ctrl+Alt+F3) and the problem persisted. This mean that the problem is in yast?

    Anyway, I changed the "use-system-keyboard-layout" to "true".

    But look this:

    1. I applied the layout again, then the keyboard works great (at least for a while);
    2. With the correct layout I went to console and worked great;
    3. I backed to gnome and then I returned to console and: BANG! The layout is wrong again.

    Normally, the layout changes after minutes. With the changes to console, the layout changes in seconds. We can conclude that the problem is in yast, right? What we can do to test it?

    Many thanks.

  6. #6

    Default Re: The keyboard changes the layout often

    not quite, well what yast changes/configures is the /etc/sysconfig setting, which is the system keyboard and for the end user it affects the console. I had hoped that sysconfig was right to force it's layout in gnome, obviously that doesn't seem to be the case.

    now verify if your keyboard layout is "br-abnt2" 'cause I could be wrong about this, but I assume is the most common brazilian keyboard layout.

    then install nano and go to a terminal and type:

    Code:
    su
    HTML Code:
    gedit /etc/X11/xorg.conf.d/10-evdev.conf
    in this file add the following:

    Section “InputClass”
    Identifier “evdev keyboard catchall”
    MatchIsKeyboard “on”
    MatchDevicePath “/dev/input/event*”
    Driver “evdev”
    Option “XkbLayout” “br”
    Option “XkbVariant” “abnt2"
    EndSection
    and restart:

    Code:
    reboot
    and let's see if this works.

  7. #7
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: The keyboard changes the layout often

    Hi! For a while I thought that worked... but unfortunately not

    When I move to console, the problem returns.

  8. #8

    Default Re: The keyboard changes the layout often

    but if you don't go to the tty console, does it work?

    anyway, apparently we've at least got what keyboard layout you're using, so that's something.
    and that one is located in: /usr/share/kbd/keymaps/legacy/i386/qwerty/br-abnt2.map.gz

    then let's turn back to yast, and open "/etc/sysconfig editor" then navigate to /Hardware/Keyboard/ and check KEYTABLE, and point it to the previously mentioned layout, restart and see what happens. and since you're there you might also want to verify what's the value in YAST_KEYBOARD.

  9. #9
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: The keyboard changes the layout often

    Didn't work yet (in the console or not).

    My /etc/sysconfig/keyboard:

    KEYTABLE="/usr/share/kbd/keymaps/legacy/i386/qwerty/br-abnt2.map.gz" <- I tried here also with KEYTABLE="br-abnt2.map.gz" (without succsess too)

    YAST_KEYBOARD="portugese-br,pc104"

  10. #10
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: The keyboard changes the layout often

    I gave up! I removed Tumbleweed and installed Leap.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •