Results 1 to 10 of 10

Thread: Yast not working after System Upgrade

  1. #1

    Default Yast not working after System Upgrade

    I followed the instructions at https://en.opensuse.org/SDB:System_upgrade to upgrade from 13.2 to 42.1. I rebooted successfully into 42.1. When I tried to open Yast I was asked for the root password, which I gave, but then nothing happened. Yast did not show its screen and nothing appeared at all.

    How can I see why Yast is not showing anything ? Thoughts ? ideas ?

    I do have a backup of 13.2 I can restore to go back, but I would rather get 42.1 working correctly.

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Yast not working after System Upgrade

    Yast changed from GTK to QT UI interfaces between 13.2 and Leap; chances are that you are missing the following packages:
    yast2-control-center-qt
    yast2-qt-branding-openSUSE

    and possibly a few dependencies depending on the desktop you are using.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,492
    Blog Entries
    3

    Default Re: Yast not working after System Upgrade

    You can probably still run
    Code:
    # yast --ncurses
    in a terminal session.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,050

    Default Re: Yast not working after System Upgrade

    On Tue, 26 Apr 2016 21:56:02 +0000, eldiener wrote:

    > I followed the instructions at
    > https://en.opensuse.org/SDB:System_upgrade to upgrade from 13.2 to 42.1.
    > I rebooted successfully into 42.1. When I tried to open Yast I was asked
    > for the root password, which I gave, but then nothing happened. Yast did
    > not show its screen and nothing appeared at all.
    >
    > How can I see why Yast is not showing anything ? Thoughts ? ideas ?
    >
    > I do have a backup of 13.2 I can restore to go back, but I would rather
    > get 42.1 working correctly.


    Start a terminal window, run "gnomesu /sbin/yast2" or "kdesu /sbin/yast2"
    and put the output here in code tags (the # button in the advanced
    editor).

    Then nobody will have to guess at what the problem is.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: Yast not working after System Upgrade

    Quote Originally Posted by OrsoBruno View Post
    Yast changed from GTK to QT UI interfaces between 13.2 and Leap;
    Well, it hasn't "changed" from Gtk to Qt really, the Qt interface always existed.

    But the Gtk interface was dropped after 13.2 was released, yes, so now the only one is the Qt interface (and ncurses).

    chances are that you are missing the following packages:
    yast2-control-center-qt
    yast2-qt-branding-openSUSE

    and possibly a few dependencies depending on the desktop you are using.
    Additionally, make sure that those packages are installed:
    libyui7, libyui-qt7, libyui-qt-pkg7, libyui-qt-graph7

    I suppose one of the qt ones missing (or outdated, i.e. 6 instead of 7) is more likely the reason for the problem...

    Also, make sure you run YaST on the primary screen if you have multiple. There are problems currently (in Qt5) when it is being run on the secondary one.

  6. #6

    Default Re: Yast not working after System Upgrade

    Quote Originally Posted by hendersj View Post
    On Tue, 26 Apr 2016 21:56:02 +0000, eldiener wrote:

    > I followed the instructions at
    > https://en.opensuse.org/SDB:System_upgrade to upgrade from 13.2 to 42.1.
    > I rebooted successfully into 42.1. When I tried to open Yast I was asked
    > for the root password, which I gave, but then nothing happened. Yast did
    > not show its screen and nothing appeared at all.
    >
    > How can I see why Yast is not showing anything ? Thoughts ? ideas ?
    >
    > I do have a backup of 13.2 I can restore to go back, but I would rather
    > get 42.1 working correctly.


    Start a terminal window, run "gnomesu /sbin/yast2" or "kdesu /sbin/yast2"
    and put the output here in code tags (the # button in the advanced
    editor).

    Then nobody will have to guess at what the problem is.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C
    What happens when I type:

    Code:
    kdesu /sbin/yast2
    is that I dialog comes up asking me for the root password. I type in the root password and hit the OK button, and then nothing further happens at all. No screen shows and the console window just shows my command and is waiting on the next line of the console window for Yast to exit presumably. But if Yast exists anywhere it is not showing itself.

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,702

    Default Re: Yast not working after System Upgrade

    By chance do you have two monitors? Seems there is a problem opening Yast on the second screen

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,050

    Default Re: Yast not working after System Upgrade

    On Wed, 27 Apr 2016 17:16:02 +0000, eldiener wrote:

    > is that I dialog comes up asking me for the root password. I type in the
    > root password and hit the OK button, and then nothing further happens at
    > all. No screen shows and the console window just shows my command and is
    > waiting on the next line of the console window for Yast to exit
    > presumably. But if Yast exists anywhere it is not showing itself.


    My bad - I had the wrong path. Try "kdesu /usr/sbin/yast2" instead.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  9. #9

    Default Re: Yast not working after System Upgrade

    Quote Originally Posted by OrsoBruno View Post
    Yast changed from GTK to QT UI interfaces between 13.2 and Leap; chances are that you are missing the following packages:
    yast2-control-center-qt
    yast2-qt-branding-openSUSE

    and possibly a few dependencies depending on the desktop you are using.
    zypper shows that both are installed.

  10. #10

    Default Re: Yast not working after System Upgrade

    Quote Originally Posted by wolfi323 View Post
    Well, it hasn't "changed" from Gtk to Qt really, the Qt interface always existed.

    But the Gtk interface was dropped after 13.2 was released, yes, so now the only one is the Qt interface (and ncurses).



    Additionally, make sure that those packages are installed:
    libyui7, libyui-qt7, libyui-qt-pkg7, libyui-qt-graph7

    I suppose one of the qt ones missing (or outdated, i.e. 6 instead of 7) is more likely the reason for the problem...

    Also, make sure you run YaST on the primary screen if you have multiple. There are problems currently (in Qt5) when it is being run on the secondary one.
    It was the libyui-qt packages. After I used zypper to install them the Yast GUI showed itself. Thanks ver much !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •