Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How do I 'lock' my screen resolution

  1. #1

    Default How do I 'lock' my screen resolution

    KDE, FGLRX driver. My monitor is 1920x1080. One of the updates in the last several months changed my display by making the displayed screen (desktop area?) slightly larger than the screen physical size and changed the appearance of icon colors & text (a lot of fiddling with themes did not correct this).

    My solution was to change the display to 1680x1050 which is much easier on my eyes. Changing resolution in System Settings did not hold through a restart. But using 'AMD Control Center' works well and also changed the resolution in System Settings.

    After a recent update this approach is now failing, Leap frequently, but not always, starts in 1920x1680. I'd say that about 1 in 4 startups requires me to change the resolution. Now that I understand that the resolution needs to be changed it's simple enough to reset it (this requires me to move my mouse to the edge of the screen and hunt for the invisible application launcher), but this is very annoying.

    Is there a way to force Leap to maintain my preferred display setting? Perhaps by forcing a file to be read only?

  2. #2

    Default Re: How do I 'lock' my screen resolution

    Quote Originally Posted by 6520302 View Post
    Is there a way to force Leap to maintain my preferred display setting? Perhaps by forcing a file to be read only?
    Well, it should remember the settings.
    Try to remove ~/.local/share/kscreen/, maybe the files have gotten corrupted somehow and kscreen is confused.
    If you do make the files in this folder read-only, the settings should not (be possible to) change at all any more, yes.

    Or disable the "KScreen 2" background service (in "Configure Desktop"/systemsettings5->Startup and Shutdown->Background Services) to prevent KDE "messing" with your display settings at all, and configure your resolution directly in /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/ (never used fglrx, but I think the "Catalyst Control Center" should allow you to do that too).

  3. #3

    Default Re: How do I 'lock' my screen resolution

    Quote Originally Posted by wolfi323 View Post
    Well, it should remember the settings.
    Try to remove ~/.local/share/kscreen/, maybe the files have gotten corrupted somehow and kscreen is confused.
    If you do make the files in this folder read-only, the settings should not (be possible to) change at all any more, yes.

    Or disable the "KScreen 2" background service (in "Configure Desktop"/systemsettings5->Startup and Shutdown->Background Services) to prevent KDE "messing" with your display settings at all, and configure your resolution directly in /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/ (never used fglrx, but I think the "Catalyst Control Center" should allow you to do that too).
    Thank you for this info. Last night I spent a couple of hours researching resolution on the web and reading the xorg.conf manual.

    My Leap install was a fresh install. xorg.conf contains no specific mode statements in Section "Screen", Subsection "Display". By editing xorg.conf to add the optional modes entry to Subsection "Display" I believe I have solved my problem. According to the manual, "The first valid mode in this list will be the default display mode for startup". I need a few more startups to be sure. By placing Modes "1680x1050" in the file, even though my monitor is 1920x1080, when KDE starts it now goes to the lower resolution, giving me a much more readable screen.

    I agree that "Catalyst Control Center" should allow me to change the display. In fact, it does. The problem is that my system would boot to the selected resolution several times, but after awhile, it would start booting to the highest possible resolution. And when I checked Catalyst I found the resolution had changed.

    I'm hoping that by defining Modes in the file it will 'stick'. If I have further problems I will try your other suggestions.

    Thank you,
    jon

  4. #4

    Default Re: How do I 'lock' my screen resolution

    Quote Originally Posted by 6520302 View Post
    TI agree that "Catalyst Control Center" should allow me to change the display. In fact, it does. The problem is that my system would boot to the selected resolution several times, but after awhile, it would start booting to the highest possible resolution. And when I checked Catalyst I found the resolution had changed.
    I meant that CCC might be able to create a corrsponding xorg.conf file, like nvidia-settings does.
    I don't know though.

    I'm hoping that by defining Modes in the file it will 'stick'. If I have further problems I will try your other suggestions.
    If you disable the "KScreen 2" service, KDE should not touch the resolution at all.
    And actually KScreen might override the Xorg configuration, and it even ignores it on multi-monitor setups by default I believe.
    Last edited by wolfi323; 25-Apr-2016 at 13:18.

  5. #5

    Default Re: How do I 'lock' my screen resolution

    Just to update my progress here.

    Even though I changed xorg.conf to add modes my resolution still changes after a few startups.

    So I deleted .local/share/kscreen and reset my desired resolution. I verified that the contents of the file in kscreen provided the correct resolution. Then I did chmod 0444.

    This did not help, every boot went to the highest resolution. I presume that because kscreen was readonly that flgrx did not like that. I have returned to the original permissions on the kscreen file.

    I still need to try your suggestion on KScreen 2 service.

  6. #6

    Default Re: How do I 'lock' my screen resolution

    Quote Originally Posted by 6520302 View Post
    This did not help, every boot went to the highest resolution. I presume that because kscreen was readonly that flgrx did not like that.
    fglrx should not care about or use that at all.

    But of course kscreen does, it applies the settings from there at login, and writes changes back (not only if you change the resolution manually, but also when it gets notified of display changes that have happened, e.g. adding/removing a screen, or some other application changes the resolution via XRandr).
    No idea why it didn't work though, the 0444 permissions should be ok I think. I would only expect the bahaviour you describe if kscreen cannot *read* the file...

  7. #7

    Default Re: How do I 'lock' my screen resolution

    I am having the exact same problem. Was it possible to fix this? How?

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: How do I 'lock' my screen resolution

    Quote Originally Posted by LouBryan View Post
    I am having the exact same problem. Was it possible to fix this? How?
    You're best advised to start your own thread for this. Provide your graphics hardware details (including driver) and desktop environment please.

  9. #9

    Default Re: How do I 'lock' my screen resolution

    For anyone that is having this problem, and not getting helped, I found the solution.

    If you have made any changes to, or deleted, or disabled, any of these to try to fix this then put them back the way they were. No changes are needed to these
    Code:
    ~/.local/share/kscreen 
    /etc/X11/xorg.conf or xorg.conf.d files
    Configure Desktop > disabled kscreen2
    Follow these steps.

    1) Open a terminal (Konsole is good).

    2) Enter this to show what the settings are now. And the options available.

    Code:
    xrandr
    3) Pick the setting that you like and try it with this (I use 1280x720 for an example)

    Code:
    xrandr --size 1280x720
    4) If that works as you like it, then add that line to the bottom of the .profile in your home folder.

    Now each time there is a reboot, the .profile will reset the size as you log in.

    If you have multiple users, do this in the .profile for each one.

  10. #10
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,153

    Default Re: How do I 'lock' my screen resolution

    Forgive me if I have got this wrong, but it seems to me rhat this thread is not about the system using an incorrect resolution for the physical display. The user problem appears to be that that the graphical elements (including typefaces) appear too small for comfortable viewing. This is common with high resolution screens (e.g. modern laptops) or with older eyes. If so the solution is to use the native hardware display resolution and increase the scaling factor. For a HiDPI screen scaling at x2 or x2.5 is generally desirable.

    I only have a Leap-42.2 and Tumbleweed to hand:

    System Settings | Hardware |Display and Monitor | Displays | Scale Display
    (its right at the bottom -- you may need to scroll down) On my 3200x1800 laptop the scale is set at 2.4

    Some software may require tweaking -- this article was a useful starting point, but much of the need has been obsoleted in recent months.
    https://wiki.archlinux.org/index.php/HiDPI
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •