Results 1 to 8 of 8

Thread: **INSANELY** slow network install on Leap, tumbleweed

  1. #1

    Default **INSANELY** slow network install on Leap, tumbleweed

    I'm getting an AVERAGE of, right now it says 2.7 Kilobytes. Yeah, that's a lot of bytes, but WTF! I've disconnected the Ethernet cable, let it sit for about 10 seconds and reconnected. I saw it go "way up" to 44 Kilobytes/s. Then 33, then 21, then 20, then 14, then 8, then whatever else. Why is this so slow? Is something hammering the OpenSUSE servers?

    Edit: this is BEFORE the installation, but in the GUI where it's adding the repos. I'm finally at the install, and it's going at a very fast rate, in the 3+ MB/s.

  2. #2

    Default Re: **INSANELY** slow network install on Leap, tumbleweed

    To which server IP address are you connected, specifically?

    Ctrl+Alt+F2 to get to a TTY, then check with 'ss:

    Code:
    /usr/sbin/ss -planeto | grep ESTAB | grep -e ':80' -e ':443'

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,646
    Blog Entries
    3

    Default Re: **INSANELY** slow network install on Leap, tumbleweed

    I think it gets the repo information directly from the main download site. But the packages can be retrieved from mirrors.

    Once you get to the stage of using mirrors, it goes faster.

    I notice the same with updates. Getting the metadata is very slow, but it speed up once it begins to download RPMs.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: **INSANELY** slow network install on Leap, tumbleweed

    On a completely unrelated note, after finishing the KDE tumbleweed network install, I cannot 'startx' at all. It throws an error, and screws up the layout of the tty heavily, to the point where the next thing to type is below the screen, and when I clear it, it's not showing the text. I have to 'exit' to clear out everything the 'startx' error caused.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,399
    Blog Entries
    1

    Default Re: **INSANELY** slow network install on Leap, tumbleweed

    Quote Originally Posted by timpster View Post
    On a completely unrelated note, after finishing the KDE tumbleweed network install, I cannot 'startx' at all. It throws an error, and screws up the layout of the tty heavily, to the point where the next thing to type is below the screen, and when I clear it, it's not showing the text. I have to 'exit' to clear out everything the 'startx' error caused.
    You should start a new thread with a suitably descriptive title for assistance with that problem.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,888
    Blog Entries
    15

    Default Re: **INSANELY** slow network install on Leap, tumbleweed

    Quote Originally Posted by timpster View Post
    I'm getting an AVERAGE of, right now it says 2.7 Kilobytes. Yeah, that's a lot of bytes, but WTF! I've disconnected the Ethernet cable, let it sit for about 10 seconds and reconnected. I saw it go "way up" to 44 Kilobytes/s. Then 33, then 21, then 20, then 14, then 8, then whatever else. Why is this so slow? Is something hammering the OpenSUSE servers?

    Edit: this is BEFORE the installation, but in the GUI where it's adding the repos. I'm finally at the install, and it's going at a very fast rate, in the 3+ MB/s.
    Hi
    This is normal when a Tumbleweed release is propagating to the mirrors due to the repo data needing to be synced, then packages. You need to be patient, go outside find something to do that's no computer related.....

    If you keep an eye on the factory mailing list you will see an automated mail arrive, wait some hours then look at dupping;
    http://lists.opensuse.org/opensuse-f.../msg00374.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: **INSANELY** slow network install on Leap, tumbleweed

    Quote Originally Posted by nrickert View Post
    I think it gets the repo information directly from the main download site. But the packages can be retrieved from mirrors.

    Once you get to the stage of using mirrors, it goes faster.

    I notice the same with updates. Getting the metadata is very slow, but it speed up once it begins to download RPMs.
    Same here .
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,868
    Blog Entries
    14

    Default Re: **INSANELY** slow network install on Leap, tumbleweed

    @malcolmlewis is right. We "see" the updates as soon as the new TW gets released ( it's actually a release on every update ). So we start updating, but before the mirrors have been synced, so we're all pulling our updates from the same host.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •