Results 1 to 8 of 8

Thread: Konqueror displays older file version

  1. #1
    Join Date
    Dec 2015
    Posts
    47

    Default Konqueror displays older file version

    Hi,

    I noticed an annoying problem with konqueror:

    When I edit and save an image file like .png or .svg (maybe it's also other files), konqueror still displays the older image.

    So, if I click on the edited image - and it opens in konnqueror - the older (unedited) version of that image appears.
    If I open the same image in another program, the correct (edited) version appears.
    Also, if I change the name of the image and open it in konqueror the correct (edited) version appears. (If I change the name back again, the older (unedited) version appears again.

    Refreshing konqueror doesn't help, also restarting konqueror doesn't help.

    I thought there might be some kind of cache konqueror uses, but in properties I only found the web browser related cache.
    I turned it off anyway, just to try, but it didn't solve the problem.


    Best
    Marc

  2. #2

    Default Re: Konqueror displays older file version

    you're talking about konqueror not updating the thumbnails of the files, correct?

    if that is the case you need to rebuild the thumbnails, and for that you need to delete the thumbnails the program automatically caches, the directory should be: /home/*username*/.thumbnails - deleting its contents should make konqueror rebuild the previews hence displaying what you want.

  3. #3
    Join Date
    Dec 2015
    Posts
    47

    Default Re: Konqueror displays older file version

    Quote Originally Posted by salhelder View Post
    you're talking about konqueror not updating the thumbnails of the files, correct?

    if that is the case you need to rebuild the thumbnails, and for that you need to delete the thumbnails the program automatically caches, the directory should be: /home/*username*/.thumbnails - deleting its contents should make konqueror rebuild the previews hence displaying what you want.
    Nono, not the thumbnails.

    Some files are opened within Konqueror if I left click on them (archives, html files, most graphics).
    I think this is very convenient because it neither opens another window nor another program.

    I noticed this problem when Konqueror opens a png.
    I have to correct myself: With .svg Konqueror doesn't have this problem.

    Best
    Marc

  4. #4

    Default Re: Konqueror displays older file version

    the preview function, right?

    I tried replicating what you did, but in version 4.14.18 that comes with tumblweed it works as expected.

    however if I open the preview of a .png, keep that open while modifying and overwriting it, and then ask for another preview (without closing the first preview) it does show the old version of the file.

    just to try, does changing the minimization of memory usage in configure -> performance to "never" alter the behaviour?

  5. #5
    Join Date
    Dec 2015
    Posts
    47

    Default Re: Konqueror displays older file version

    Quote Originally Posted by salhelder View Post
    the preview function, right?

    I tried replicating what you did, but in version 4.14.18 that comes with tumblweed it works as expected.

    however if I open the preview of a .png, keep that open while modifying and overwriting it, and then ask for another preview (without closing the first preview) it does show the old version of the file.

    just to try, does changing the minimization of memory usage in configure -> performance to "never" alter the behaviour?


    No, same effect.
    Checked a few times.

  6. #6

    Default Re: Konqueror displays older file version

    I'm out of ideas. it would be nice if someone could replicate it, 'cause it seems we have a bug here. apart from filling a bug report, I guess you could try to use a previous version, if one is available.

  7. #7

    Default Re: Konqueror displays older file version

    Well, Konqueror doesn't display anything itself, it is just a shell for so-called "KParts".

    So I suppose the important question here is, which kpart is actually used...
    What is active in "View"->"View Mode" (in Konqueror's menu) when an image is displayed?

    You can change the preferred one in the "File Associations", on the "Embedded" tab. Another one might "work better" for you.

    PS: I can somehow reproduce what you report with the "gwenview part", i.e. if I open the same file again after changing it, the old version is displayed.
    Clicking on Konqueror's "Refresh" button or pressing F5 (while the image is displayed) fixes that though. So rather a cache thing (as suggested already) than a real bug.
    Last edited by wolfi323; 17-Apr-2016 at 12:06.

  8. #8
    Join Date
    Dec 2015
    Posts
    47

    Default Re: Konqueror displays older file version

    Quote Originally Posted by wolfi323 View Post
    Well, Konqueror doesn't display anything itself, it is just a shell for so-called "KParts".

    So I suppose the important question here is, which kpart is actually used...
    What is active in "View"->"View Mode" (in Konqueror's menu) when an image is displayed?

    You can change the preferred one in the "File Associations", on the "Embedded" tab. Another one might "work better" for you.

    PS: I can somehow reproduce what you report with the "gwenview part", i.e. if I open the same file again after changing it, the old version is displayed.
    Clicking on Konqueror's "Refresh" button or pressing F5 (while the image is displayed) fixes that though. So rather a cache thing (as suggested already) than a real bug.

    So the used View Mode was Gwenview. For me, refreshing doesn't help.

    However, khtmlimage shows the correct image.

    So, it seems to be a problem of that Gwenview (gvpart) part.
    By the way, my Konqueror version is 4.14.18.



    Thanks
    Marc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •