Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Some items failed to launch after the updates

  1. #1
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    199

    Default Some items failed to launch after the updates

    I ran a zypper up this morning and there were few updates from openSUSE, not remember it all but most of it were libreoffice and samba.

    My current repos during the updates:
    Code:
    linux-xocg:/home/yazid # zypper lr
    
    # | Alias               | Name                        | Enabled | GPG Check | Refresh
    --+---------------------+-----------------------------+---------+-----------+--------
    1 | google-chrome       | google-chrome               | Yes     | ( p) Yes  | Yes    
    2 | openSUSE-20160331-0 | openSUSE-20160331-0         | No      | ----      | Yes    
    3 | packman             | packman                     | Yes     | (r ) Yes  | Yes    
    4 | repo-debug          | openSUSE-Tumbleweed-Debug   | No      | ----      | Yes    
    5 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes    
    6 | repo-oss            | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes    
    7 | repo-source         | openSUSE-Tumbleweed-Source  | No      | ----      | Yes    
    8 | repo-update         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes
    I am not able to launch, for instance Gnome Settings, from terminal:-
    Code:
    yazid@linux-xocg:~> gnome-control-center
    gnome-control-center: relocation error: /usr/lib64/samba/libauthkrb5-samba4.so: symbol tevent_req_is_unix_error, version TEVENT_UTIL_0.0.1 not defined in file libtevent-util.so.0 with link time reference
    I am installed Kodi, but unable to run it as well:-
    Code:
    yazid@linux-xocg:~> kodi
    /usr/lib64/kodi/kodi.bin: relocation error: /usr/lib64/samba/libauthkrb5-samba4.so: symbol tevent_req_is_unix_error, version TEVENT_UTIL_0.0.1 not defined in file libtevent-util.so.0 with link time reference
    This is to confirmed that both of my PCs on TW, after the updates, having the same problem.

    Thanks.
    Intel i5 4590 (Haswell), MSI B85M-G43, MSI GTX750Ti, Leap 15.1, Gnome 3.26 on 120GB SSD

  2. #2

    Default Re: Some items failed to launch after the updates

    I see the same error when using mpv.

  3. #3

    Default Re: Some items failed to launch after the updates

    Apparently something went wrong with that Samba update...

    http://bugzilla.opensuse.org/show_bug.cgi?id=975862

  4. #4

    Default Re: Some items failed to launch after the updates

    Hi , the same situation here , the gnome-control-center does not launch... In terminal i have that output : gnome-control-center: relocation error: /usr/lib64/samba/libauthkrb5-samba4.so: symbol tevent_req_is_unix_error, version TEVENT_UTIL_0.0.1 not defined in file libtevent-util.so.0 with link time reference

    How could be fixed that ???

    Sorry for my English.

  5. #5

    Default Re: Some items failed to launch after the updates

    sudo zypper dup
    should upgrade the samba libs properly and fix the issues. If you have pkgs from other repos that you would prefer not to change repos make sure those repos are set to a higher priority (e.g. packman-essentials at 98 instead of 99, achieved by "sudo zypper mr -p 98 foo-repo")

  6. #6

    Default Re: Some items failed to launch after the updates

    I did that , did not worked , gnome-control-center , settings not launch.

  7. #7
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    199

    Default Re: Some items failed to launch after the updates

    zypper dup fixed it, I don't know if the next zypper up to update we'll getting the same error again.
    Intel i5 4590 (Haswell), MSI B85M-G43, MSI GTX750Ti, Leap 15.1, Gnome 3.26 on 120GB SSD

  8. #8

    Default Re: Some items failed to launch after the updates

    I have done zypper dup but it didn't worked , the settings won't lanch... Any help please

  9. #9

    Default Re: Some items failed to launch after the updates

    Quote Originally Posted by powerw00t View Post
    zypper dup fixed it, I don't know if the next zypper up to update we'll getting the same error again.
    Unlikely.
    This was a major upgrade for Samba, and apparently "zypper up" cannot properly deal with that i.e. it doesn't correctly upgrade all packages.

    Something like that doesn't happen on every update...

    Quote Originally Posted by korn84 View Post
    I have done zypper dup but it didn't worked , the settings won't lanch... Any help please
    Please post your repo list then.
    Code:
    zypper lr -d
    According to everything I read so far, "zypper dup" should work.

  10. #10
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    199

    Default Re: Some items failed to launch after the updates

    Quote Originally Posted by wolfi323 View Post
    Unlikely.
    This was a major upgrade for Samba, and apparently "zypper up" cannot properly deal with that i.e. it doesn't correctly upgrade all packages.

    Something like that doesn't happen on every update...
    In curiosity, I re-run zypper up if such error could happen again, returned me 'nothing to do'. At this point I believe we are save to run zypper up as usual
    Intel i5 4590 (Haswell), MSI B85M-G43, MSI GTX750Ti, Leap 15.1, Gnome 3.26 on 120GB SSD

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •