Results 1 to 8 of 8

Thread: KDE - Unable to disable screenlock

  1. #1
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,684
    Blog Entries
    2

    Default KDE - Unable to disable screenlock

    Newly installed LEAP 42.1, fully updated
    KDE 5
    VMware 11 Guest (although I doubt makes a diff)

    Problem:
    Unable to disable screenlock

    Attempt:
    Settings > Configure Desktop > Hardware > Power Management > Uncheck all the "Energy Savings" boxes and Apply
    Have also rebooted for good measure.

    Result:
    Screenlock still locking after waiting a few minutes.

    Anyone else seeing same?

    BTW - I'm really impressed how fast LEAP installs as a VMware Guest. Takes only about 10 minutes while for comparison any other openSUSE (13.2, TW) takes about 45 minutes (local DVD install source, no updates applied).

    TSU

  2. #2
    Join Date
    Nov 2010
    Location
    Texas, USA
    Posts
    97

    Default Re: KDE - Unable to disable screenlock

    On 13.2 this is under Configure Desktop / Display and Monitor - not under Power Management.

  3. #3

    Default Re: KDE - Unable to disable screenlock

    Hi, I am also not able to disable screenlock in 42.1 KDE.

    In System Settings/Screen Locker I uncheck 'Start automatically ...', but it seems to have no effect

  4. #4
    Join Date
    Sep 2008
    Location
    London
    Posts
    47

    Default Re: KDE - Unable to disable screenlock

    In System Settings you need to go to Workspace/Desktop Behavior/Screen Locking and disable Lock Screen Automatically. If you cannot access this, it may be because you use systemsettings for kde4 and not the one for kde5. Check this by displaying Help/System Settings About from the menu. If it is the old one then edit the application menu and change the call for systemsettings into systemsettings5. They are both in /usr/bin.

  5. #5

    Default Re: KDE - Unable to disable screenlock

    Good catch

    I was using the old system setting, ... It a bit weird that it was not uninstalled during the upgrade from 13.2

    Thanks

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: KDE - Unable to disable screenlock

    Quote Originally Posted by stickydeveloper View Post
    Good catch

    I was using the old system setting, ... It a bit weird that it was not uninstalled during the upgrade from 13.2

    Thanks
    Actually, there are now TWO menu entries, differently named, for these settings. One is the KDE4 configurations, still needed for some KDE4 apps that are still in the system, and the other for Plasma 5. Just use the correct menu entry for the correct version.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,684
    Blog Entries
    2

    Default Re: KDE - Unable to disable screenlock

    Quote Originally Posted by bzidler View Post
    In System Settings you need to go to Workspace/Desktop Behavior/Screen Locking and disable Lock Screen Automatically. If you cannot access this, it may be because you use systemsettings for kde4 and not the one for kde5. Check this by displaying Help/System Settings About from the menu. If it is the old one then edit the application menu and change the call for systemsettings into systemsettings5. They are both in /usr/bin.
    Thx.
    Interesting that I found all sorts of references to Hardware > Display and Monitor and of course no setting exists there with most recent KDE... But nowhere could I find a specific new location for this setting.

    TSU

  8. #8
    Join Date
    Dec 2011
    Location
    Chicago, IL
    Posts
    7

    Default Re: KDE - Unable to disable screenlock

    Quote Originally Posted by bzidler View Post
    In System Settings you need to go to Workspace/Desktop Behavior/Screen Locking and disable Lock Screen Automatically. If you cannot access this, it may be because you use systemsettings for kde4 and not the one for kde5. Check this by displaying Help/System Settings About from the menu. If it is the old one then edit the application menu and change the call for systemsettings into systemsettings5. They are both in /usr/bin.
    I know the post is old but I wanted to say thank you. When I installed leap I set it to login automatically, yet the lock screen kept asking for a password and my spouse was getting ticked off because he couldn't log in because I don't want him to have the password. (He doesn't want me messing with his mac and I don't want him messing with linux.). Seriously that setting is in the weirdest hard to find spot. When I install it to login without a password it shouldn't automatically have a lock screen set up to begin with, all anyone would have to do is just hold down the power button to turn it off and then turn the computer back on. It's not security it's annoying.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •