Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Some items failed to launch after the updates

  1. #21
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default Re: Some items failed to launch after the updates

    Quote Originally Posted by palswim View Post
    Code:
    zypper up samba
    This required a deinstallation (removal) of four packages for me: libgensec0 libregistry0 libsmbclient-raw0 samba-32bit

    But, my system (including Samba) seemed to work properly after this.

    I think zypper up has an aversion to deinstallation like this, so opted not to install the new package, rather than uninstall a few old packages.
    What I ended up doing was to force remove all the smb and related packages and mplayer, I changed repo priority to favour Tumbleweed Updates, then VLC, then packman, and reinstalled mplayer

    Code:
    # rpm --erase --nodeps libgensec0 libregistry0 libsmbclient-raw0 samba-client samba samba-winbind libdcerpc0-4.2.4-15.1 samba-libs libsamba-credentials0-4
    .2.4-15.1.x86_64 libsmbconf0-4.2.4-15.1.x86_64 libsamba-passdb0-4.2.4-15.1.x86_64 libsmbldap0-4.2.4-15.1.x86_64 libsmbclient0-4.2.4-15.1.x86_64
    # rpm --erase gmplayer MPlayer
    # zypper install mplayer
    


    and after zypper did its thing, I had a working mplayer again

    --
    Cambridge geek, will code for gadgets

  2. #22

    Default Re: Some items failed to launch after the updates

    Quote Originally Posted by speculatrix View Post
    then VLC, then packman
    You should NOT use VLC and Packman together!

    It won't give you any advantages whatsoever (everything that's in the VLC repo is on Packman as well), and can only cause problems...

    And preferring VLC over Packman will break much other stuff from Packman anyway.
    So, just don't do it, and don't advise it here!
    Remove the VLC repo, and only use Packman.
    Last edited by wolfi323; 26-Apr-2016 at 14:15.

  3. #23

    Default Re: Some items failed to launch after the updates

    If you want to try to roll back to an earlier version of Samba, you will probably need to roll back the following packages:
    • libdcerpc0
    • libdcerpc0-32bit
    • libdcerpc-binding0
    • libdcerpc-binding0-32bit
    • libevent-2_0-5
    • libgensec0
    • libgensec0-32bit
    • libndr0
    • libndr0-32bit
    • libndr-krb5pac0
    • libndr-krb5pac0
    • libndr-krb5pac0-32bit
    • libndr-nbt0
    • libndr-nbt0-32bit
    • libndr-standard0
    • libndr-standard0-32bit
    • libnetapi0
    • libnetapi0-32bit
    • libregistry0
    • libsamba-credentials0
    • libsamba-credentials0-32bit
    • libsamba-hostconfig0
    • libsamba-hostconfig0-32bit
    • libsamba-passdb0
    • libsamba-passdb0-32bit
    • libsamba-util0
    • libsamba-util0-32bit
    • libsamdb0
    • libsamdb0-32bit
    • libsmbclient0
    • libsmbclient-raw0
    • libsmbclient-raw0-32bit
    • libsmbconf0
    • libsmbconf0-32bit
    • libsmbldap0
    • libsmbldap0-32bit
    • libtevent-util0
    • libtevent-util0-32bit
    • libwbclient0
    • libwbclient0-32bit
    • samba
    • samba-client
    • samba-client-32bit
    • samba-libs
    • samba-libs-32bit
    • samba-winbind
    • samba-winbind-32bit

    You may not need some of these, but I don't know which rollbacks did the magic trick(s) for me. I finished with the libevent-util0 downgrades, so I know you definitely need those.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •