Results 1 to 3 of 3

Thread: Gnome disable natural scrolling

  1. #1

    Question Gnome disable natural scrolling

    I have natural scrolling disabled from the gnome settings, but still everything is scrolling the opposite way. How do I fix this?

    Code:
    jayaura@aura-envy:~> /usr/sbin/hwinfo --mouse
    39: PS/2 00.0: 10500 PS/2 Mouse                                 
      [Created at input.249]
      Unique ID: AH6Q.Y_f5kDtfqz2
      Hardware Class: mouse
      Model: "SynPS/2 Synaptics TouchPad"
      Vendor: 0x0002 
      Device: 0x0007 "SynPS/2 Synaptics TouchPad"
      Compatible to: int 0x0210 0x0001
      Device File: /dev/input/mice (/dev/input/mouse0)
      Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1, /dev/input/by-path/platform-i8042-serio-1-event-mouse, /dev/input/by-path/platform-i8042-serio-1-mouse
      Device Number: char 13:63 (char 13:32)
      Driver Info #0:
        Buttons: 1
        Wheels: 0
        XFree86 Protocol: explorerps/2
        GPM Protocol: exps2
      Config Status: cfg=new, avail=yes, need=no, active=unknown

    Thanks in Advance!

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Gnome disable natural scrolling

    In the new Gnome 3.20 currently on Tumbleweed there are actually TWO "natural scrolling" settings switches, one for the mouse and the other for the touchpad.
    Please be sure to switch off both, or at least the one applying to the pointer device you are actually using.

    If that fails, try one of the following:
    Code:
    gsettings get org.gnome.desktop.peripherals.mouse natural-scroll
    gsettings get org.gnome.desktop.peripherals.touchpad natural-scroll
    
    gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false
    gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll false
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3

    Thumbs up Re: Gnome disable natural scrolling

    I just started having this problem recently (inverted mouse scrolling - so scrolling down scrolled up, and up scrolled down). Strangely, I'm sure it was days or weeks(?) after Tumbleweed updated to 3.20, so I don't know what changed.

    I tried an Xmodmap setting to swap horizontal and vertical scroll, but that only worked in Firefox and Thunderbird, not in Nautilus and my Twitter client.

    I eventually found this thread and found that org.gnome.desktop.peripherals.mouse natural-scroll was false but org.gnome.desktop.peripherals.touchpad natural-scroll was true. Setting them as detailed fixed the issue.

    The odd thing is that I've got a PS/2 mouse on a desktop machine, not a touchpad! For some reason (possibly the Belkin KVM switch I use?) it seems that Tumbleweed thinks it is a touchpad:

    Code:
    $ /usr/sbin/hwinfo --mouse 
    31: PS/2 00.0: 10500 PS/2 Mouse 
      [Created at input.249] 
      Unique ID: … 
      Hardware Class: mouse 
      Model: "ImPS/2 BYD TouchPad" 
      Vendor: 0x0002 
      Device: 0x0005 "ImPS/2 BYD TouchPad" 
      Compatible to: int 0x0210 0x0013 
      Device File: /dev/input/mice (/dev/input/mouse0) 
      Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1,  /dev/input/by-path/platform-i8042-serio-1-event-mouse,  /dev/input/by-path/platform-i8042-serio-1-mouse 
      Device Number: char 13:63 (char 13:32) 
      Driver Info #0: 
        Buttons: 3 
        Wheels: 1 
        XFree86 Protocol: explorerps/2 
        GPM Protocol: exps2 
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    Hopefully this helps other people (including those searching for Tumbleweed inverting mouse scroll).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •