Hi,

I noticed today when attempting to open one of my activities with Meta+Q that nothing happened. I'm sure it worked a few days ago. Here's what happened next:


  • I tried the widget to see if that would work. Still nothing.
  • From there I found a reference to kactivitymanagerd on some Arch forum. After confirming the process is running, I tried a 'systemctl status kactivitymanagerd' only to find a file 'not found error' for kactivitymanagerd.service.
  • mlocate could only find a kactivitymanagerd.desktop file.
  • I searched for the package on openSUSE's site and installed it directly from there, which added the OSS repository for Tumbleweed (probably already had it, YAST is weird).
  • I tried copying the file to various locations: /etc/systemd/system/ (as .service), and /usr/share/kde4/services/ (with and without renaming to .service), as well as a renaming in the original location.
  • Then I tried installing kactivities5, which broke my activities.
  • Finally I tried installing kactivities4 as well (and also kactivities5-imports, which I can't remove with Zypper without removing a bunch of patterns and stuff), which also broke stuff, so I just reverted back to kactivitymanagerd again (which unbroke my activities).


Right now I'm back to square one. Activity manager doesn't work, and I'm not able to start up my other activities. I can still switch between the two I have open right now though.