Results 1 to 6 of 6

Thread: Phonon'svlc backend failed to start

  1. #1

    Default Phonon'svlc backend failed to start

    Running Suse 13.2, Firefox 45.0, can't install Adobe flash player11.2. Get error message "Phonon's vlc backend failed to start" I need some advice

  2. #2

    Default Re: Phonon'svlc backend failed to start

    Quote Originally Posted by mmcaelth View Post
    Running Suse 13.2, Firefox 45.0, can't install Adobe flash player11.2. Get error message "Phonon's vlc backend failed to start" I need some advice
    Can you be a bit more specific please?

    Where do you get that error message, and how do you try to install Flash Player?

    Flash Player does not use Phonon, so should have no need for Phonon's vlc backend, and it would be even less needed just for installing Flash Player.

    Also, phonon-backend-vlc is not even installed by default, normally phonon-backend-gstreamer is used in openSUSE.
    To get rid of this error message, try to install it (from Packman, which also has flash-player...), or (probably better) switch to gstreamer in KDE's multimedia settings.

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Phonon'svlc backend failed to start

    phonon-backend-vlc from OSS is incomparable with vlc 2.2 you need to get it from packman
    what's your repo list
    Code:
    zypper lr -d

  4. #4

    Default Re: Phonon'svlc backend failed to start

    linux-bolh:/home/matt # zypper lr -d
    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+------------------------------------+------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1 | AMD/ATI-FGLRX | AMD/ATI-FGLRX | Yes | (r ) Yes | Yes | 99 | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2/ |
    2 | adobe-flash-plugin | adobe-flash-plugin | Yes | ( p) Yes | Yes | 99 | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/ |
    3 | download.opensuse.org-13.2-non-oss | Update Repository (Non-Oss) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |
    4 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    5 | download.opensuse.org-oss | Main Repository (DEBUG) | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/d...13.2/repo/oss/ |
    6 | download.opensuse.org-oss_1 | Main Repository (OSS) | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.2/repo/oss/ |
    7 | download.opensuse.org-oss_2 | Main Repository (Sources) | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/...13.2/repo/oss/ |
    8 | download.opensuse.org-update | Update Repository (DEBUG) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/13.2/ |
    9 | download.opensuse.org-update_1 | Main Update Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
    10 | dvd | dvd | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/ |
    11 | home_DarkPlayer_Pipelight | Pipelight (openSUSE_13.2) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    12 | nVidia Graphics Drivers | nVidia Graphics Drivers | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/13.2/ |
    13 | nvidia | nvidia | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/leap/42.1 |
    14 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | ( p) Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_DVD+_-RW_SH-216DB_S10Q68EF4006D3 |
    15 | packman | packman | Yes | (r ) Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.1/ |
    16 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |
    linux-bolh:/home/matt #

  5. #5

    Default Re: Phonon'svlc backend failed to start

    Quote Originally Posted by mmcaelth View Post
    linux-bolh:/home/matt # zypper lr -d
    You added the Packman, libdvdcss, and nvidia repos for Leap 42.1, no wonder that you are having problems...

    Remove them:
    Code:
    sudo zypper rr 10 13 15
    You can remove the Adobe repo too, flash-player is available in Packman anyway.
    Code:
    sudo zypper rr 2
    Then add libdvdcss and Packman for 13.2:
    Code:
    sudo zypper ar -f  http://packman.inode.at/suse/openSUSE_13.2/ packman
    sudo zypper ar -f  http://opensuse-guide.org/repo/openSUSE_13.2 dvd
    Do a full switch to them, and everything should work:
    Code:
    sudo zypper dup --from packman --from dvd
    To install flash-player, run:
    Code:
    sudo zypper in flash-player

  6. #6

    Smile Re: Phonon'svlc backend failed to start

    At my local Linux users group, MOG, the leader said he perfectly understood his home owner's policy when he read it. I am a 75 year old retired lawyer familiar with insurance law and I know there is NO WAY! He can't understand why I can't just follow the directions and do anything I want to in Linux!!! i DON'T SPEAK THE LANGUAGE!! you are both an absolute genius and a lifesaver. THANK YOU !!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •