Results 1 to 9 of 9

Thread: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

  1. #1

    Default Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    Hi,
    I have installed the latest version of Eclipse IDE (4.5.2 / Mars) on the latest OpenSuse Tumbleweed but I'm experiencing several issues since on KDE Plasma 5 dialog boxes and all the tooltip are not working since an hourglass is displayed and the IDE freeze completely till you restart it.

    Basically to reproduce this issue it is enough to open a Java file on Eclipse and then and then press CTRL+T on the class name to show the class hierarchy on a toolbox, and you will get a never ending hourglass.

    Changing desktop environment from Plasma 5 to GNOME things are improving since I don't have the previously described issue, but I'm experiencing some issues on the preference pane, since trying to click on the findbugs preference pane cause a NullPointerException...

    On latest release of Ubuntu or Linux Mint I can't reproduce the same issues. Are you testing the Eclipse IDE with OpenQA too ?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,823
    Blog Entries
    1

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    You need to describe
    - Where you downloaded your Eclipse from.
    Although Eclipse has been available in OSS for many versions, the general advice has always been to download and install your choice of Eclipse from the Eclipse site.

    - You may need to specify which Java you're using... openjdk or Oracle Java SE JDK.
    And, if you're using openjdk and coding Java, you'll have to install openjdk-devel.
    Depending on your coding language, you may also need to install other dependencies.

    - If you downloaded from Eclipse, then you <may> need to describe where you decided to place your Eclipse.

    - If you've downloaded Eclipse add-ons, you will need to describe that, too.

    You may also have varying opinions about trying to set up a Dev environment on TW.
    Building a Dev environment already introduces a number of possible instability issues, installing on an unstable and constantly changing platform like TW is not for the faint of heart, you can <expect> periodic breakage and unless you can wait you may need to figure things out for yourself.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    I have installed Eclipse from the official website(www.eclipse.org), and placed it inside : /opt/eclipse/ .
    I'm using the openjdk version of Java 8 installed from Yast.

    It seems that the issues is graphics related, since all the issues are graphics related. For example another issue is that on Plasma 5 I can't see the preferences pane, since only the default is displayed and when I try to switch page it doesn't switch. As already said on GNOME desktop environment the situation is slightly better ...





  4. #4

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    Quote Originally Posted by aleroot View Post
    I have installed Eclipse from the official website(www.eclipse.org), and placed it inside : /opt/eclipse/ .
    I'm using the openjdk version of Java 8 installed from Yast.

    It seems that the issues is graphics related, since all the issues are graphics related. For example another issue is that on Plasma 5 I can't see the preferences pane, since only the default is displayed and when I try to switch page it doesn't switch. As already said on GNOME desktop environment the situation is slightly better ...





    Seems like that adding :

    --launcher.GTK_version
    2

    to the ecipse.ini file Fixed the issue,
    Thanks.


  5. #5

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    Quote Originally Posted by aleroot View Post
    Seems like that adding :

    --launcher.GTK_version
    2

    to the ecipse.ini file Fixed the issue,
    Thanks.

    I have the same issue on my end which is also fixed by the solution above.

  6. #6

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    Hi!
    I have the same issue, but configuring eclipse.ini doesn't help, instead causes JVM terminated code=1 crash on startup. I've tried writing it in various lines, because I'm not an experienced user, but it crashed no matter where I'd written that line.

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,823
    Blog Entries
    1

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    Quote Originally Posted by kiskompi View Post
    Hi!
    I have the same issue, but configuring eclipse.ini doesn't help, instead causes JVM terminated code=1 crash on startup. I've tried writing it in various lines, because I'm not an experienced user, but it crashed no matter where I'd written that line.
    I don't know if there is any concrete reason why specifying GTK should affect Java support, there is only an outside possibility that something in the GTK codebase that supports or connects to Java libraries might be different which would be an Eclipse architectural design issue.

    Eventually someone may identify exactly what the problem might be.

    In the meantime, it's not sufficient to post a "me, too" -- If you believe your situation is similar you will have to at least re-describe your setup noting the requirements posted before, ie. Your Eclipse was installed from the Eclipse website and not from openSUSE repos, which Java you're using and how it was installed.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    You're right. I have openjdk1.8 and 1.9 (with the openjdk-devel packages) installed from official openSUSE repositories and I've downloaded Eclipse from the official webpage (tar.gz) and placed it in /home/bin.

  9. #9
    Join Date
    May 2011
    Location
    Germany
    Posts
    28

    Default Re: Issues with Eclipse IDE on latest OpenSUSE Tumbleweed

    Please note that there are known problems with Gtk 3.20 on Tumbleweed and Eclipse 4.5.2 https://bugs.eclipse.org/bugs/show_bug.cgi?id=491384

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •