Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: edge scrolling

  1. #11

    Default Re: edge scrolling

    Quote Originally Posted by jansteen View Post
    Hi, I had the same problem and I registered just to tell you about a workaround I learned from Fedora.

    Follow these steps and you can get your edge-scrolling to work:

    1) Install " xinput "
    2) logout and login to Gnome 3.20 again.
    3) open a terminal and run: xinput list
    - look for your touchpad and remember the ID. On my laptop with an Elantech touchpad the ID is 14.

    4) create a file called edge-scroll-workaround.desktop in /usr/share/applications/ for every user or for just 1 user in ~/.local/share/applications/
    5) with your favorite texteditor place the following in that file:

    [Desktop Entry]
    Name=Edge scroll workaround
    Exec=/usr/bin/xinput set-prop 14 "libinput Scroll Method Enabled" 0, 1, 0
    // Replace 14 with the ID of your touchpad!
    Type=Application
    Name[en_US]=edge-scroll-workaround.desktop

    6) If you don't have gnome-tweak-tool installed, do so and run it.
    7) In Gnome-tweak-tool go to: Startup Applications
    8) press + and search for edge-scroll-workaround and add it.
    9) logout and log in again.
    10) pro-tip: you might want to disable Natural Scrolling for the Touchpad in 'Settings' - 'Mouse and Touchpad'

    Happy scrolling!

    (Most of these steps are straight from the Fedora forum, I adopted it a slight bit for OpenSuSE Thumbleweed, the original post can be found here:
    https://ask.fedoraproject.org/en/que...dge-scrolling/ )
    Last edited by Wilbert; 24-Jul-2016 at 12:44. Reason: layout fix

  2. #12

    Default Re: edge scrolling

    FYI, the last line in the .desktop file (name en_us) can safely be omitted.

  3. #13

    Default Re: edge scrolling

    Thanks for this info.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •