Results 1 to 6 of 6

Thread: KWallet Trouble

  1. #1

    Default KWallet Trouble

    I recently upgraded 12.1 to leap 41.2. I never used KWallet in 12.1 and never gave it a password and therein lies the problem. leap can't do anything without KWallet including connect to my android hotspot.
    I wouldn't mind so much if i had a password for it. KWalletManager just freezes when I open it.

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,608
    Blog Entries
    3

    Default Re: KWallet Trouble

    Leap 42.1 has both the kwallet from KDE4 and the new kwallet for plasma 5. The KDE4 wallet will be what you inherited from opensuse 12.1.

    My suggestions:
    1. Make sure that your system is fully up-to-date. Also, make sure that you don't have any old 12.1 repos configured.
    2. Install "kwalletmanager5" for managing the plasma 5 kwallet.
    3. Delete your old wallets (details below).


    Connecting to a hotspot should be using the plasma5 wallet.

    To delete your old wallets:

    I recommend that you first logout from KDE. Maybe login to "Icewm" instead.

    Code:
    #### first remove the KDE4 wallet and settings
    cd $HOME/.kde4/share/config
    rm kwallet*
    cd ../apps
    rm -rf kwallet
    #### next remove the Plasma 5 wallet and settings
    cd $HOME/.config
    rm kwallet*
    cd $HOME/.local/share
    rm -rf kwalletd
    Now logout from Icewm, and login again to KDE Plasma workspace. Your wallets should be recreated. You should be prompted to set a password on the first use (probably when setting up the hotspot connection).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: KWallet Trouble

    How do i log into "Icewm"

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,608
    Blog Entries
    3

    Default Re: KWallet Trouble

    Quote Originally Posted by coasterad View Post
    How do i log into "Icewm"
    After you logout from KDE, you should have a login screen. On that screen, there is a small menu where you can select which desktop you want to use.

    Your login screen is probably from "sddm". The desktops available should include "Icewm" as one of the choice. The selection menu is toward the left of the login screen. You might see "Plasma 5" or "KDE Plasma Desktop" showing, but you can change that to another desktop, depending on what was installed. A standard opensuse install always includes Icewm (a simple bare-bones desktop). Once in Icewm, there's an icon for opening a text command line window.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Default Re: KWallet Trouble

    my installation has none of that - once i log out of kde thats it, i can either log back into kde or not there is no other choice

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,608
    Blog Entries
    3

    Default Re: KWallet Trouble

    Since you upgraded 12.1, maybe you are using "kdm" to login. With "kdm" there is a small tool (wrench) icon. Click on that to select a different desktop.

    If you still cannot find it, then there's another alternative. While logged out, use CTRL-ALT-F2 . That should give you a command line where you can login and delete the wallets as suggested. When done, logout. Then use CTRL-ALT-F7 to get back to the graphic login screen.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •