Results 1 to 3 of 3

Thread: Where can I find openJDK 1.6 for LEAP?

  1. #1

    Default Where can I find openJDK 1.6 for LEAP?

    In the repos, I see openJDK 1.7 and 1.8 but for a project I'm working on, I need 1.6. I looked on software.opensuse.org but couldn't find it there for LEAP. Where can i find this for install?

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Where can I find openJDK 1.6 for LEAP?

    That's extremely old, imo there are 2 posibilities
    #1 build openjdk yourself from source
    get the source here
    https://java.net/projects/openjdk6/downloads/
    and compile
    #2 use a binary for an older opensuse build, the latest I could find was for opensuse 12.1
    http://ftp5.gwdg.de/pub/opensuse/dis...1.2.x86_64.rpm
    http://ftp5.gwdg.de/pub/opensuse/dis...1.2.x86_64.rpm

    or try the source rpm from 12.1
    http://ftp5.gwdg.de/pub/opensuse/dis....4-1.2.src.rpm

    see this link about how to build openjdk under opensuse
    https://github.com/hgomez/obuildfact...opensuse--sles
    that link is for 1.7 but with a little tweaking it can be used for 1.6

    if it was me I'd try building from the source rpm as it has a ready to use spec file, just install the needed dependencies and use rpmbuild

  3. #3

    Default Re: Where can I find openJDK 1.6 for LEAP?

    Quote Originally Posted by I_A View Post
    That's extremely old, imo there are 2 posibilities
    #1 build openjdk yourself from source
    get the source here
    https://java.net/projects/openjdk6/downloads/
    and compile
    #2 use a binary for an older opensuse build, the latest I could find was for opensuse 12.1
    http://ftp5.gwdg.de/pub/opensuse/dis...1.2.x86_64.rpm
    http://ftp5.gwdg.de/pub/opensuse/dis...1.2.x86_64.rpm

    or try the source rpm from 12.1
    http://ftp5.gwdg.de/pub/opensuse/dis....4-1.2.src.rpm

    see this link about how to build openjdk under opensuse
    https://github.com/hgomez/obuildfact...opensuse--sles
    that link is for 1.7 but with a little tweaking it can be used for 1.6

    if it was me I'd try building from the source rpm as it has a ready to use spec file, just install the needed dependencies and use rpmbuild
    Thank you, there is a repo I found: http://download.opensuse.org/reposit...E_42.1/x86_64/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •