Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Birdfont on 13.1, 64

  1. #1
    wally345 NNTP User

    Default Birdfont on 13.1, 64

    Hello,

    How to install "birdfont" Fonteditor on OpenSuse 13.1 64bit.

    After several error messages the most recent is:
    > birdfont
    birdfont: symbol lookup error: /usr/lib64/libwebkitgtk-3.0.so.0: undefined symbol: _ZN3JSC8Debugger6detachEPNS_14JSGlobalObjectENS0_15ReasonForDetachE
    ~>

    any idea highly welcome, thanks
    wally

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,884

    Default Re: Birdfont on 13.1, 64

    It looks as if you already tried to install it in some way or another. Please tell what you did. We can not guess that.
    Henk van Velden

  3. #3
    wally345 NNTP User

    Default Re: Birdfont on 13.1, 64

    first type of error messages was something about "oxygen-gtk" undefined symbols etc.
    So, i reinstalled oxygen gtk packages, even 32 bit versions additinally.
    Also tried to set alternatives in KDE settings for GTK.
    The message in my primary post is emitted now.
    I also can remove all and install again, if I know which repo will do the job.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,884

    Default Re: Birdfont on 13.1, 64

    You ask "how to install Birdfont".

    Then you tell us an error message (well, not realy): ".. something about "oxygen-gtk" undefined symbols etc...)

    When you do not even know how to install it, how can you get an error message?

    Please tell precise what you did and what was the result of that.

    Did you find that product somewhere?
    In what form?
    Did you download something?
    When yes, what did you do with it?
    Etc., etc.

    BTW the most direct answer to you question "how to iinstall Bordfont" I would give:
    search at https://software.opensuse.org/search
    Henk van Velden

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Birdfont on 13.1, 64

    I'm thinking maybe a package mixup
    what are your repo's
    Code:
    zypper lr -d
    and where did birdfont come from?
    Code:
    zypper se -si -r birdfont

  6. #6
    wally345 NNTP User

    Default Re: Birdfont on 13.1, 64

    Henk,

    Yes, I ask "how to install" and I meant how to install it correctly so it might work.
    I did not mention this explicitly, sorry.

    I do not have a log, maybe Yast log it somewhere but I do not know and I do not have a photographical memory, sorry.

    I installed using Yast and expected as usual, that Yast check dependencies etc.

    My work is using the PC as a tool and I do not have experience repairing tools.

    I just expected, that this birdfont problem occurs not only on my 13.1 which is already pretty old.

    So, I think I should remove it and wait for ... ?

    Doesn't the last error message give any hints ?



  7. #7
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,044

    Default Re: Birdfont on 13.1, 64

    On Mon, 28 Mar 2016 17:36:01 +0000, wally345 wrote:

    > Yes, I ask "how to install" and I meant how to install it correctly so
    > it might work.
    > I did not mention this explicitly, sorry.


    What you're not telling us is the steps you took to install it.

    Are you trying to build it from source? Did you install it from a
    repository (and if so, which one)?

    Details are important here.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Birdfont on 13.1, 64

    The first error makes me think you installed a build for a different opensuse version and so the question again, what are your repo's and where did the installed version come from, you might have mistakenly installed a 13.2 or a leap build and those are compiled with different libwebkitgtk packages so post
    Code:
    zypper lr -d
    zypper se -si -r birdfont

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,884

    Default Re: Birdfont on 13.1, 64

    Quote Originally Posted by wally345 View Post
    I installed using Yast
    From where? What repository.

    You may not have a photographic memory, but we are not clairvoyant. We depend completely on the words you type down in your posts. Many here are willing to help, but they can only do so on the base of hard facts.

    I checked and it is not in the 13.1 OSS repo. Thus you found it elsewhere. How do you think we can even try to recreate your problem on our systems when you give no information at all?
    Henk van Velden

  10. #10
    wally345 NNTP User

    Default Re: Birdfont on 13.1, 64

    yes, you are right, sure you need more info:

    First installed it from Yast repos, birdfont was available from a repo not
    "home:johanmattssonm / openSUSE_13.1"
    I did not check which.

    After this does not work I checked the birdfont homepage and found another repo.
    After adding the "home:johanmattssonm / openSUSE_13.1" I reinstalled birdfont from this repo and got the result message posted on my very first post.

    http://birdfont.org/purchase.php
    https://build.opensuse.org/package/s...ssonm/birdfont



    Code:
    zypper se -si -r birdfont
    
    Repository 'birdfont' not found by its alias, number, or URI.
    Use 'zypper repos' to get the list of defined repositories.
    I copied the following from Yast - Technical Data - installed version
    Code:
    2.15.3-2.1
    
    
    Sat 19 Dec 2015 06:16:20 PM CET
    Mon 28 Mar 2016 07:59:45 PM CEST
    Multimedia/Graphics/Vector Editors
    GPLv3+
    13.6 MiB
    0 B
    home:johanmattssonm / openSUSE_13.1
    obs://build.opensuse.org/home:johanmattssonm
    x86_64
    http://birdfont.org/
    birdfont-2.15.3-2.1

    Sending another post with repo listing because:
    The text that you have entered is too long (15265 characters). Please shorten it to 15000 characters long.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •