Results 1 to 5 of 5

Thread: Unable to access phpMyAdmin from my browser? Root user denied and regular user as well?

  1. #1

    Default Unable to access phpMyAdmin from my browser? Root user denied and regular user as well?

    Hello World,

    I have been trying to figure this for one whole week. I can't seem to figure this out. I am unable to access my MariaDB 10.1 database from http://localhost/phpMyAdmin . When I enter username root and then enter my database root password. I am unable to access. The same database root and passwords works via the command line using Linux shell prompt. I created a brand new user and still unable to access it. I am able to access the new user via Linux shell prompt.

    I even un-installed and installed phpMyAdmin again. And I changed the root login without password. That did not work either. At this point I am completely lost. Any advice is greatly appreciated. It was working fine before. Only change I did was upgraded my MariaDB from 5.5 to 10.1. I don't see why that could matter???

    Thanks

    OpenSUSE 13.1
    MariaDB 10.1

  2. #2

    Default Re: Unable to access phpMyAdmin from my browser? Root user denied and regular user as well?

    Quote Originally Posted by cyberdome View Post
    Hello World,

    I have been trying to figure this for one whole week. I can't seem to figure this out. I am unable to access my MariaDB 10.1 database from http://localhost/phpMyAdmin . When I enter username root and then enter my database root password. I am unable to access. The same database root and passwords works via the command line using Linux shell prompt. I created a brand new user and still unable to access it. I am able to access the new user via Linux shell prompt.

    I even un-installed and installed phpMyAdmin again. And I changed the root login without password. That did not work either. At this point I am completely lost. Any advice is greatly appreciated. It was working fine before. Only change I did was upgraded my MariaDB from 5.5 to 10.1. I don't see why that could matter???

    Thanks

    OpenSUSE 13.1
    MariaDB 10.1
    Any help is appreciated.

  3. #3

    Default Re: Unable to access phpMyAdmin from my browser? Root user denied and regular user as well?

    This is just me and a few others and an opinion
    -- then on to phpmyadmin and the database and apache


    i normally recommend that for the first 6 to 12 installs ( you WILL!!! mess things up a few times )
    that you install from source and DO NOT use the package manager

    this way one LEARNS how to set up and CONFIGURE things
    the apache/php/mariabd/phpmyadmin software is COMPLEX

    it is not hard or confusing but it is rather complex and it is VERY easy to mess things up and or run a VERY insecure install


    so i am assuming you used yast and installed everything

    php
    Apache
    Mariadb
    phpmyadmin

    did you set up Apache ?
    did you set up it's "httpd.conf" ( suse uses 3 files for that one file )

    do you see the "congratulations you installed apache " page on
    http://localhost:80

    is php working ?

    run the "php info" script
    Code:
    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>
    place that in the doc root of apache and run it
    you should see the info page
    http://php.net/manual/en/function.phpinfo.php
    -- random image garbed from google
    https://netbeans.org/images_www/arti...pp-phpinfo.png

    if all that is working
    then on to the database

    and phpmyadmin
    first read the instructions
    https://www.phpmyadmin.net/docs/



  4. #4

    Default Re: Unable to access phpMyAdmin from my browser? Root user denied and regular user as well?

    Quote Originally Posted by JohnVV View Post
    This is just me and a few others and an opinion
    -- then on to phpmyadmin and the database and apache


    i normally recommend that for the first 6 to 12 installs ( you WILL!!! mess things up a few times )
    that you install from source and DO NOT use the package manager

    this way one LEARNS how to set up and CONFIGURE things
    the apache/php/mariabd/phpmyadmin software is COMPLEX

    it is not hard or confusing but it is rather complex and it is VERY easy to mess things up and or run a VERY insecure install


    so i am assuming you used yast and installed everything

    php
    Apache
    Mariadb
    phpmyadmin

    did you set up Apache ?
    did you set up it's "httpd.conf" ( suse uses 3 files for that one file )

    do you see the "congratulations you installed apache " page on
    http://localhost:80

    is php working ?

    run the "php info" script
    Code:
    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>
    place that in the doc root of apache and run it
    you should see the info page
    http://php.net/manual/en/function.phpinfo.php
    -- random image garbed from google
    https://netbeans.org/images_www/arti...pp-phpinfo.png

    if all that is working
    then on to the database

    and phpmyadmin
    first read the instructions
    https://www.phpmyadmin.net/docs/


    Yes, Apache works fine. PHP is working fine too. I setup web server and yes it is working fine. The only change I did was upgraded MariaDB from 5.5 to 10.1 . Otherwise, everything is working fine. I know for fact on my Ubuntu server and my Fedora Server, the same configuration works fine. Its just this OpenSuSE is not able to log in. It was working before. All of the sudden it broke.

    thanks for replying. Any suggestions ????

  5. #5

    Default Re: Unable to access phpMyAdmin from my browser? Root user denied and regular user as well?

    Anyone have a idea how I can proceed with this issue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •