Results 1 to 3 of 3

Thread: Updating gnutls on Leap

  1. #1
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    249

    Default Updating gnutls on Leap

    Hi

    I play Warcraft on Linux with wine. And last week Blizzard changed the encryption settings in the game. SSL3 connections aren't possible. Unfortunately gnutls 3.2 that comes with Leap wants to connect with SSL3. Gnutls 3.3 doesn't do this and installing this should work.

    In the Ubuntu community I see people switching to the latest Ubuntu, which has gnutls 3.3 OR I see people installing the gnutls 3.3 file manually and then they rename the old gnutls 3.2 files and then creat links with the old name to the new 3.3 version.

    When I try the same on Leap it doesn't work. I downloaded the latest gnutls packages from Tumbleweed (gnutls 3.4) and then renamed the old gnutls 3.2 files and replaced them with links to gnutls 3.4

    Wine will give an error that files are not found and secure connections aren't possible.

    How can I upgrade gnutls 3.2 to something higher on Leap? Do I need to compile gnutls or?

    Please advise

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    249

    Default Re: Updating gnutls on Leap

    BTW, I also tried this with LD_PRELOAD but that doesn't work. I get (wrong ELF class: ELFCLASS64). Also with using the 32bit libs.

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    249

    Default Re: Updating gnutls on Leap

    Never mind, solved it in an other way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •