Results 1 to 4 of 4

Thread: invalid protocol finding in dolphin5

  1. #1

    Default invalid protocol finding in dolphin5

    on my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz
    upgraded 13.2 to leap 42.1,
    using wolfi repos I'm running KDE 4.14.17 and plasma 5.6.0, KDE frameworks 5.20.0, KDE applications 15.12.3

    findings files in dolphin [ctrl f or find button] gives me a red bar with written "invalid protocol"
    in [systemsettings>search>file search] enable file search is selected
    is there any way to find files in dolphin5??
    manythanks, ciao, :-) pier

  2. #2

    Default Re: invalid protocol finding in dolphin5

    Quote Originally Posted by pier_andreit View Post
    is there any way to find files in dolphin5??
    Disable file indexing in systemsettings5.
    Then the standard search is used, which should work.

    To use the indexed search, baloo5-kioslaves needs to be installed, so verify that.

    Also, try to logout/login or better reboot.
    There were major updates recently. If you were using Plasma5/KF5 applications before/while installing the updates, things might not fully work afterwards.

    But just to be sure, I tried myself now. Indexed search in dolphin5 does work without a problem, there's not a general problem regarding this.
    I'm on 13.2, but that shouldn't matter.

    And check that you are really using dolphin5 ("Help"->"About"->Version). dolphin4 will require baloo-kioslaves instead.

  3. #3

    Default Re: invalid protocol finding in dolphin5

    Quote Originally Posted by wolfi323 View Post
    Disable file indexing in systemsettings5.
    Then the standard search is used, which should work.
    Manythanks, it works well now

    Quote Originally Posted by wolfi323 View Post
    To use the indexed search, baloo5-kioslaves needs to be installed, so verify that.

    Also, try to logout/login or better reboot.
    There were major updates recently. If you were using Plasma5/KF5 applications before/while installing the updates, things might not fully work afterwards.

    But just to be sure, I tried myself now. Indexed search in dolphin5 does work without a problem, there's not a general problem regarding this.
    I'm on 13.2, but that shouldn't matter.

    And check that you are really using dolphin5 ("Help"->"About"->Version). dolphin4 will require baloo-kioslaves instead.
    it seems that dolphin4 doesn't works with your repos if dolphin5 is installed, so it should be dolphin5
    checked dolphin and it result
    version 15.12.3
    Using:
    KDE Frameworks 5.20.0

    • Qt 5.6.0 (built against 5.6.0)
    • The xcb windowing system

    installing baloo5-kioslaves and all the boloo5 (also baloo-kioslaves and all the baloo software are installed if it matter) the "invalid protocol" error disappeared, but it seems it doesn'e find anything, and also if I set a place ehere do not search in [system settings>search>file search>do not search in this location] it doesn't remember the setting.
    hi, and happy easter :-)

  4. #4

    Default Re: invalid protocol finding in dolphin5

    Quote Originally Posted by pier_andreit View Post
    it seems that dolphin4 doesn't works with your repos if dolphin5 is installed, so it should be dolphin5
    Yeah, in my repo, dolphin4 is still called dolphin (there's no need to rename it).
    But /opt/kf5/bin/ comes first in the path (to prevent problems), so running "dolphin" will start the KF5 version.

    You could start dolphin4 via /usr/bin/dolphin though, or install the dolphin4 package from the standard repos and run dolphin4.
    But ok, you do use the KF5 version.

    installing baloo5-kioslaves and all the boloo5 (also baloo-kioslaves and all the baloo software are installed if it matter) the "invalid protocol" error disappeared, but it seems it doesn'e find anything
    This only finds stuff in files that are indexed.

    But if you search in a folder that has indexing disabled (or indexing is disabled completely), dolphin's search falls back to a normal "grep" and does not use baloo. That's slower though, of course.

    and also if I set a place ehere do not search in [system settings>search>file search>do not search in this location] it doesn't remember the setting.
    Hm?
    Sure you are using systemsettings5?
    Is ~/.config/baloofilerc writeable?
    Last edited by wolfi323; 31-Mar-2016 at 06:51.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •