Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: start kgpg from command-line does not work at all

  1. #1

    Default start kgpg from command-line does not work at all

    dear opensuse-expert

    want to start kgpg from command-line


    Code:
    linux-70ce:/home/martin # kgpg -k
    unnamed app(3820): KUniqueApplication: Cannot find the D-Bus session server:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
    
    unnamed app(3819): KUniqueApplication: Pipe closed unexpectedly. 
    
    linux-70ce:/home/martin #
    btw - i run openSuse 13
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: start kgpg from command-line does not work at all

    I would not say "It does not work at all". It works and shows error messages. Which is what it should do if it encounters problems.

    Apperently you want help with interpreting these messages.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,143
    Blog Entries
    2

    Default Re: start kgpg from command-line does not work at all

    In general you won't be able to run any KDE app (usually starts with a k) directly from a console or terminal and will result in a dbus error.

    Use "kdesu" instead, eg
    Code:
    kdesu kgpg
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: start kgpg from command-line does not work at all

    Quote Originally Posted by tsu2 View Post
    In general you won't be able to run any KDE app (usually starts with a k) directly from a console or terminal and will result in a dbus error.
    I don't think that's right. I often start applications from the command line.

    Use "kdesu" instead, eg
    Code:
    kdesu kgpg
    And that's certainly wrong. You only need "kdesu" for applications that need root privileges. And "kgpg" does not require root privileges.

    I just started "kgpg" at the command line, without a problem. However, this is 42.1. So I'll boot up a 13.2 system soon, and try it again there.

    The OP has a different problem, though I'm not sure what it is. Maybe try rebooting. Perhaps "systemd" has been updated since the last boot, and maybe that broke a comminication link.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: start kgpg from command-line does not work at all

    I've now started "kgpg" at the command line in 13.2. Again, no problem.

    With both 13.2 and 42.1, there was a message "QFSFileEngine:pen: No file name specified" but "kgpg" started up just fine. I'm ignoring the message.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: start kgpg from command-line does not work at all

    Quote Originally Posted by dilbertone View Post
    Code:
    linux-70ce:/home/martin # kgpg -k
    The command line prompt (the '#' in particular) would indicate that you switched to root via su.
    Don't do that, it won't work that way, as kgpg doesn't find the user's dbus session (and that's what the error message tells you).

    "su -" should work, but as mentioned you shouldn't run kgpg as root anyway.
    Last edited by wolfi323; 26-Mar-2016 at 11:21.

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,143
    Blog Entries
    2

    Default Re: start kgpg from command-line does not work at all

    My apologies,
    Yes, my previous post should be disregarded.

    BTW - I just checked on my 13.2/KDE (fully updated),
    I don't have a problem launching kgpg from the command line.

    So, maybe you need to update your system?
    Code:
    zypper up
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8

    Default Re: start kgpg from command-line does not work at all

    hello - many many thanks

    i will try out - all the tipp

    see below

    linux-70ce:/home/martin # zypper up
    Datei '/repodata/repomd.xml' nicht auf dem Medium 'http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_13.1/' gefunden.

    Abbrechen, wiederholen, ignorieren? [a/w/i/? zeigt alle Optionen] (a):
    which mean -

    abbrechen - do not continue
    wiederhlen - repeat
    ignorieen - ignore

    hmmm - what should i do now... no zypper up work - at least it seems so....

    and now see this -- regarding the kgpg-start

    Code:
    linux-70ce:/home/martin # kgpg -k
    unnamed app(2737): KUniqueApplication: Cannot find the D-Bus session server:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
    
    unnamed app(2736): KUniqueApplication: Pipe closed unexpectedly. 
    
    linux-70ce:/home/martin #
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: start kgpg from command-line does not work at all

    Quote Originally Posted by dilbertone View Post
    Datei '/repodata/repomd.xml' nicht auf dem Medium 'http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_13.1/' gefunden.
    That's a 13.1 repo. Since 13.1 is past its support period, maybe that repo doesn't exist. The standard repos are still there for evergreen support, but extra repos may have been removed.

    Code:
    linux-70ce:/home/martin # kgpg -k
    unnamed app(2737): KUniqueApplication: Cannot find the D-Bus session server:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
    
    unnamed app(2736): KUniqueApplication: Pipe closed unexpectedly. 
    
    linux-70ce:/home/martin #
    Why are you trying that as root? Start "kgpg" as an ordinary user.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10

    Default Re: start kgpg from command-line does not work at all

    hello dear nrickert

    many many thanks for the quick reply.


    Quote Originally Posted by nrickert View Post
    That's a 13.1 repo. Since 13.1 is past its support period, maybe that repo doesn't exist. The standard repos are still there for evergreen support, but extra repos may have been removed.

    Why are you trying that as root? Start "kgpg" as an ordinary user.

    i will try this out later the day... i come back and report all the findings.

    btw: you start kgpg on command line just with this little command kgpg - without any additional things - or commands!?
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •