Results 1 to 2 of 2

Thread: Deja Dub: Database corrupted?

  1. #1
    Join Date
    Jun 2014
    Bonn, Germany

    Default Deja Dub: Database corrupted?

    Hi everyone!

    I've been using dejadub for years and never had a problem with it. Today, the weekly update started, and I must admit I was a bit incautious: About half an hour after it started, I unmounted the USB-drive I save to. Only than I got to know the backup hadn't been completed. This in itself is a bit weird, since I haven't used my PC a lot the last week, so the backup should never have taken so long – iirc, in case it does one of the "full backups" from time to time, it informs me via a pop-up window, which it didn't this time.
    So, I mounted the drive again, re-started dejadub, provided my password, it started running (the first step as usual being "reading" the files). About 10 minutes later, it halted, asking me for my PW again. It repeated to do so… It reads all files up to ~/public (which is an empty folder), than asks me for my password, reads up to this and so forth. It even does so, if I click on "remember my password".

    Does anyone know what happened here? Any chance for me to get my old backups back…?

  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Deja Dub: Database corrupted?

    I'm going to guess that only the latest backup you tried to create is lost, but it may also affect all other backups up to your last full backup.

    Apparently deja-dub (aka deja dup) is a frontend for dup, so you can explore how dup creates backups with the features deja-dub enables by default... But I suspect that if your machine is running fine and you don't actually need your old backups it'd be easier to just discard them and begin anew.

    It's more likely that backups are corrupted and not some database of metadata.

    And of course, lesson learned... which goes for <everything>, don't remove removable storage when there is active file activity. To be perfectly safe, get in the habit to never just pull storage, always use the Desktop tools to disconnect or disable the device first, only then remove.

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts