Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Kwrite automatic spell checker not highlighting

  1. #1

    Default Kwrite automatic spell checker not highlighting

    I have installed 42.1, and everything is looking great except for a few minor issues.

    In Kwrite Settings > Editing > Spell Check, I have checked Automatic spell checking enabled by default.

    It is not underling misspelled words like it did in 12.2. I press ctrl - shift - o and still no underlines.

    How can I get this to work like it did in 12.2?

  2. #2

    Default Re: Kwrite automatic spell checker not highlighting

    When I installed 42.1 I created "joe" as the user. Then I downloaded the whole /home/jane user folder from 12.2 for user "jane", created user "jane", and used the downloaded home folder as hers.

    Jane does not get spell checker underlines, while Joe does.

    It seems like a configuration file has changed format for the spell checking.

    But when I search for a kwrite configuration file, I can not find anything in either /home/joe or /home/jane.

    Does anyone have any idea how to fix this?

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,267

    Default Re: Kwrite automatic spell checker not highlighting

    Quote Originally Posted by LouBryan View Post
    But when I search for a kwrite configuration file, I can not find anything in either /home/joe or /home/jane
    On KF5/Plasma5 the configuration files are in a different location to that of KDE4

    Try looking in ~/.config and ~/.local/share/kwrite ( as opposed to the old KDE4 location of ~/.kde4/share/* )
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,267

    Default Re: Kwrite automatic spell checker not highlighting

    Additionally...

    Quote Originally Posted by LouBryan View Post
    ... Then I downloaded the whole /home/jane user folder from 12.2 for user "jane", created user "jane", and used the downloaded home folder as hers.
    Depending upon how you did that... check that user "jane" has the correct ownership and file permissions.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: Kwrite automatic spell checker not highlighting

    Note that a user is based on the UID (user ID) not the name so ownership is based on UID so the files copied must now have the same UID as the new user Jane

  6. #6

    Default Re: Kwrite automatic spell checker not highlighting

    Quote Originally Posted by tannington View Post
    Additionally...



    Depending upon how you did that... check that user "jane" has the correct ownership and file permissions.
    Ok, joe has 1000 and jane has 1001. I ran the following

    Code:
    find -L /home/jane -uid 1000
    And it found nothing. Just to check, I changed it to -uid 1001 and it found all of Jane's files.

    I used --preserve-permissions when I extracted the /home/jane tarball so that's not it.

    I'm still digging around trying to find out what's different.

  7. #7
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,267

    Default Re: Kwrite automatic spell checker not highlighting

    Quote Originally Posted by LouBryan View Post
    I'm still digging around trying to find out what's different.
    OK... I don't know if this will help or hinder...

    I normally use kate rather than kwrite but testing with kwrite:

    kwrite Version 15.12.2
    KDE Frameworks 5.19.0

    ( btw, kwrite's config file is ~/.config/kwriterc )

    Spell checking does not work on either of my existing users, furthermore, the setting "Tools -> Spelling -> Automatic spellchecking" does not survive across (kwrite) restarts.

    Searching on the KDE bugzilla:

    https://bugs.kde.org/buglist.cgi?bug...ormat=advanced

    Finds a couple of reports relating to the spellchecker:
    https://bugs.kde.org/show_bug.cgi?id=353543
    https://bugs.kde.org/show_bug.cgi?id=359682
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,267

    Default Re: Kwrite automatic spell checker not highlighting

    OK... you're one up on me. Been messing around for the last 20 minutes or so and I can't get spellchecking to work in kwrite for any user...

    In the process...

    You might want to compare (joe/jane) the settings of:

    System Settings -> Regional Settings -> Spell Check

    Also found this (kubuntu) bug report that may have some useful information? (Although the fact you have it working for one user would perhaps rule that out).

    https://bugs.launchpad.net/ubuntu/+s...a/+bug/1478405
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  9. #9
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: Kwrite automatic spell checker not highlighting

    hi,

    same here, in fact spell checking is not working at all,
    when starting kwrite from a termin the following output is given,
    (more or less depending on the file being loaded)
    Code:
    hp-17-p105ng<2016Mär14><19:02><~/Updates/42.1/network>kwrite
    No language dictionaries for the language: "en-GB"
    No language dictionaries for the language: "en"
    hp-17-p105ng<2016Mär14><19:02><~/Updates/42.1/network>
    although the dictionary packages installed appears to be an overkill,
    and are as follows,
    Code:
    aspell-0.60.6.1-18.4.x86_64
    aspell-en-2015.04.24-2.6.x86_64
    aspell-ispell-0.60.6.1-18.4.x86_64
    aspell-spell-0.60.6.1-18.4.x86_64
    hunspell-1.3.2-3.3.x86_64
    hunspell-tools-1.3.2-3.3.x86_64
    ispell-british-3.3.02-110.1.x86_64
    myspell-dictionaries-20150827-1.1.x86_64
    myspell-en-20150827-1.1.noarch
    myspell-en_GB-20150827-1.1.noarch
    myspell-en_US-20150827-1.1.noarch
    myspell-lightproof-en-20150827-1.1.x86_64
    in addition the following are also installed,
    Code:
    kde-l10n-en_GB-15.12.2-10.2.noarch
    kde-l10n-en_GB-data-15.12.2-10.2.noarch
    kde-l10n-en_GB-doc-15.12.2-10.2.noarch
    translation-update-12.3-13.1.noarch
    translation-update-en_GB-12.3-13.1.noarch
    translation-update-en_US-12.3-13.1.noarch
    cheers
    ======

    NB. No problems with spell checking in LibreOffice

  10. #10

    Default Re: Kwrite automatic spell checker not highlighting

    Actually it should work, more or less.

    But highlighting of errors in the text did (does?) not work with certain fonts, Liberation Mono in particular:
    https://bugzilla.opensuse.org/show_b...?id=941887#c10
    So try with a different font.

    Also, try to switch to a different language, e.g. "English" instead of "English - British" or vice-versa, both in the "global" settings in systemsettings5 and the specific settings in kwrite.
    At least there always was a problem with this in KDE4, e.g. here "German" didn't work but "German (Austria)" did (or the other way round).

    And some fixes to the spell checker ("sonnet") have been done in KDE Frameworks 5.20, maybe this will improve the situation...
    https://www.kde.org/announcements/kde-frameworks-5.20.0.php

    PS: Also note that automatic spell checking is disabled by default in kwrite, but I suppose that's not the problem here (or is it?)...
    Last edited by wolfi323; 14-Mar-2016 at 12:07.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •