Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: libqt5-qtct is not working

  1. #1

    Default libqt5-qtct is not working

    Changing the theme setting via QT Configuration tool after installing libqt5-qtct package doesn't work and changes are not reflected in the cinnamon DE (for using KDE apps in cinnamon). The plugin is not working/getting started for some reason. Using Leap with Unstable KDE repos(KUA KUF KUE QT56).

  2. #2

    Default Re: libqt5-qtct is not working

    Well, I suppose it is to be expected that libqt5-qtct 5.5.1 won't work with Qt 5.6.
    For some reason it is missing from KDE:Qt56.

    You could try the KDE:Qt5 repo instead, this contains the latest stable Qt5 release and does have libqt5-qtct 5.6.0.

    I'm not completely sure this will work with KDE:Unstable:XXX though, as those repos are built against KDE:Qt56.
    But I think it should.
    Last edited by wolfi323; 22-Mar-2016 at 13:12.

  3. #3

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by wolfi323 View Post
    Well, I suppose it is to be expected that libqt5-qtct 5.5.1 won't work with Qt 5.6.
    For some reason it is missing from KDE:Qt56.

    You could try the KDE:Qt5 repo instead, this contains the latest stable Qt5 release and does have libqt5-qtct 5.6.0.

    I'm not completely sure this will work with KDE:Unstable:XXX though, as those repos are built against KDE:Qt56.
    But I think it should.
    Can you please link me the KDE:Qt5 repo you mentioned for Leap ?

  4. #4

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by hethkar View Post
    Can you please link me the KDE:Qt5 repo you mentioned for Leap ?
    Just replace Qt56 with Qt5 in your URL.
    I.e. for Leap 42.1:
    http://download.opensuse.org/reposit...USE_Leap_42.1/

    But I just noticed it's not in there either. Well, it is (because that's the devel repo), but the package is disabled for some reason.
    So that won't help you either unfortunately.

  5. #5

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by wolfi323 View Post
    Just replace Qt56 with Qt5 in your URL.
    I.e. for Leap 42.1:
    http://download.opensuse.org/reposit...USE_Leap_42.1/

    But I just noticed it's not in there either. Well, it is (because that's the devel repo), but the package is disabled for some reason.
    So that won't help you either unfortunately.
    oh Compiling it myself should work then i guess ?

  6. #6

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by hethkar View Post
    oh Compiling it myself should work then i guess ?
    Yes.

    Actually you could just branch it (i.e. the package from KDE:Qt5) on OBS and enable the build/publishing.

    https://build.opensuse.org/package/s...t5/libqt5-qtct
    Just login (same username/password) and click on "Branch package", then click on "Repositories" to enable building/publishing for the openSUSE versions you need.

    You could of course also contact the maintainer and ask for it being enabled in KDE:Qt5 itself.
    Last edited by wolfi323; 23-Mar-2016 at 09:04.

  7. #7

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by wolfi323 View Post
    Yes.

    Actually you could just branch it (i.e. the package from KDE:Qt5) on OBS and enable the build/publishing.

    https://build.opensuse.org/package/s...t5/libqt5-qtct
    Just login (same username/password) and click on "Branch package", then click on "Repositories" to enable building/publishing for the openSUSE versions you need.

    You could of course also contact the maintainer and ask for it being enabled in KDE:Qt5 itself.
    thanks will try to contact the maintainer too I tried to install after branching that package, but during installation i get
    Code:
    Problem: libqt5-qtct-0.22-24.1.x86_64 requires libQt5Gui.so.5(Qt_5.6.0_PRIVATE_API)(64bit), but this requirement cannot be provided
      uninstallable providers: libQt5Gui5-5.6.0-253.1.x86_64[http-download.opensuse.org-ca7f9233]
     Solution 1: Following actions will be done:
      downgrade of libQt5Gui5-5.6.1-6.1.x86_64 to libQt5Gui5-5.6.0-253.1.x86_64
      deinstallation of plasma5-integration-plugin-5.6.90git~20160312T120026~ad2a2bc-5.2.x86_64
      downgrade of libQt5Location5-5.6.1-1.1.x86_64 to libQt5Location5-5.5.1-3.2.x86_64
      install libQt5Location5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5OpenGL5-5.6.1-6.1.x86_64 to libQt5OpenGL5-5.6.0-253.1.x86_64
      downgrade of libQt5PrintSupport5-5.6.1-6.1.x86_64 to libQt5PrintSupport5-5.6.0-253.1.x86_64
      downgrade of libQt5Svg5-5.6.1-1.1.x86_64 to libQt5Svg5-5.5.1-3.1.x86_64
      install libQt5Svg5-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5WebKit5-5.6.1-1.1.x86_64 to libQt5WebKit5-5.5.1-3.2.x86_64
      install libQt5WebKit5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Widgets5-5.6.1-6.1.x86_64 to libQt5Widgets5-5.6.0-253.1.x86_64
      downgrade of libQtQuick5-5.6.1-2.1.x86_64 to libQtQuick5-5.5.1-6.1.x86_64
      install libQtQuick5-5.5.1-6.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libqt5-qtquickcontrols-5.6.1-1.1.x86_64 to libqt5-qtquickcontrols-5.5.1-3.1.x86_64
      install libqt5-qtquickcontrols-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libqt5-qttools-5.6.1-1.1.x86_64 to libqt5-qttools-5.5.1-3.2.x86_64
      install libqt5-qttools-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libqt5-qtimageformats-5.6.1-1.1.x86_64 to libqt5-qtimageformats-5.5.1-3.1.x86_64
      install libqt5-qtimageformats-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5X11Extras5-5.6.1-6.1.x86_64 to libQt5X11Extras5-5.5.1-3.1.x86_64
      install libQt5X11Extras5-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      deinstallation of frameworkintegration-plugin-5.21.0git.20160313T150100~ad9e347-2.2.x86_64
      downgrade of kimageformats-5.21.0git.20160304T221755~d400949-1.2.x86_64 to kimageformats-5.19.0-6.3.x86_64
      install kimageformats-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      deinstallation of kwin5-5.6.90git~20160321T165539~d491892-49.1.x86_64
      downgrade of libKF5ConfigGui5-5.21.0git.20160313T151835~43f8c11-2.2.x86_64 to libKF5ConfigGui5-5.19.0-6.3.x86_64
      install libKF5ConfigGui5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5GuiAddons5-5.21.0git.20160313T152255~d1ae24e-1.2.x86_64 to libKF5GuiAddons5-5.19.0-6.3.x86_64
      install libKF5GuiAddons5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5SonnetUi5-5.21.0git.20160314T070207~60d077f-1.2.x86_64 to libKF5SonnetUi5-5.19.0-6.7.x86_64
      install libKF5SonnetUi5-5.19.0-6.7.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      deinstallation of kwayland-5.6.90git~20160321T155923~c734cd5-19.1.x86_64
      downgrade of libQt5Gui-devel-5.6.1-6.1.x86_64 to libQt5Gui-devel-5.6.0-253.1.x86_64
      downgrade of libQt5Designer5-5.6.1-1.1.x86_64 to libQt5Designer5-5.5.1-3.2.x86_64
      install libQt5Designer5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Declarative5-5.6.1-1.1.x86_64 to libQt5Declarative5-5.5.1-3.2.x86_64
      install libQt5Declarative5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Core5-5.6.1-6.1.x86_64 to libQt5Core5-5.6.0-253.1.x86_64
      downgrade of libQt5DBus5-5.6.1-6.1.x86_64 to libQt5DBus5-5.6.0-253.1.x86_64
      downgrade of libKF5IdleTime5-5.21.0git.20160313T152401~1e0e5d0-1.3.x86_64 to libKF5IdleTime5-5.19.0-6.3.x86_64
      install libKF5IdleTime5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5ItemViews5-5.21.0git.20160313T152512~7588608-1.2.x86_64 to libKF5ItemViews5-5.19.0-6.3.x86_64
      install libKF5ItemViews5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5Solid5-5.21.0git.20160314T064619~922ab4b-1.2.x86_64 to libKF5Solid5-5.19.0-6.3.x86_64
      install libKF5Solid5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5WidgetsAddons5-5.21.0git.20160313T153037~ba2c91a-1.2.x86_64 to libKF5WidgetsAddons5-5.19.0-6.3.x86_64
      install libKF5WidgetsAddons5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5WindowSystem5-5.21.0git.20160314T064413~64ba2a6-1.3.x86_64 to libKF5WindowSystem5-5.19.0-6.3.x86_64
      install libKF5WindowSystem5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libQt5Help5-5.6.1-1.1.x86_64 to libQt5Help5-5.5.1-3.2.x86_64
      install libQt5Help5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Script5-5.6.1-1.1.x86_64 to libQt5Script5-5.5.1-3.2.x86_64
      install libQt5Script5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5WebKitWidgets5-5.6.1-1.1.x86_64 to libQt5WebKitWidgets5-5.5.1-3.2.x86_64
      install libQt5WebKitWidgets5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Widgets-devel-5.6.1-6.1.x86_64 to libQt5Widgets-devel-5.6.0-253.1.x86_64
      downgrade of libQt5Positioning5-5.6.1-1.1.x86_64 to libQt5Positioning5-5.5.1-3.2.x86_64
      install libQt5Positioning5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libqt5-linguist-5.6.1-1.1.x86_64 to libqt5-linguist-5.5.1-3.2.x86_64
      install libqt5-linguist-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libqt5-qtwebengine-5.6.1-12.1.x86_64 to libqt5-qtwebengine-5.5.1-4.3.x86_64
      install libqt5-qtwebengine-5.5.1-4.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libqt5-qtgraphicaleffects-5.6.1-1.1.x86_64 to libqt5-qtgraphicaleffects-5.5.1-3.1.x86_64
      install libqt5-qtgraphicaleffects-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libqt5-creator-3.6.99-7.2.x86_64 to libqt5-creator-3.5.1-6.6.x86_64
      install libqt5-creator-3.5.1-6.6.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of powerdevil5-5.6.90git~20160317T141152~ab31821-10.3.x86_64 to powerdevil5-5.4.3-3.1.x86_64
      install powerdevil5-5.4.3-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      deinstallation of plasma5-workspace-5.6.90git~20160322T130711~bf02678-119.1.x86_64
      deinstallation of kscreenlocker-5.6.90git~20160310T205230~fcfeae0-21.2.x86_64
      deinstallation of kinfocenter5-5.6.90git~20160315T115341~ab07a8b-6.2.x86_64
      deinstallation of libKScreenLocker5-5.6.90git~20160310T205230~fcfeae0-21.2.x86_64
      downgrade of libkscreen2-plugin-5.6.90git~20160322T011523~36fe3f8-13.1.x86_64 to libkscreen2-plugin-5.5.5-9.1.x86_64
      install libkscreen2-plugin-5.5.5-9.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      deinstallation of plasma5-session-5.6.90-1.1.noarch
      deinstallation of patterns-openSUSE-kde_plasma-20150918-12.1.x86_64
      downgrade of libQt5PlatformHeaders-devel-5.6.1-6.1.x86_64 to libQt5PlatformHeaders-devel-5.6.0-253.1.x86_64
      downgrade of libQt5Multimedia5-5.6.1-1.1.x86_64 to libQt5Multimedia5-5.5.1-3.3.x86_64
      install libQt5Multimedia5-5.5.1-3.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Network5-5.6.1-6.1.x86_64 to libQt5Network5-5.6.0-253.1.x86_64
      downgrade of libQt5Sensors5-5.6.1-1.1.x86_64 to libQt5Sensors5-5.5.1-3.1.x86_64
      install libQt5Sensors5-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Sql5-5.6.1-6.1.x86_64 to libQt5Sql5-5.6.0-253.1.x86_64
      downgrade of libQt5Sql5-mysql-5.6.1-6.1.x86_64 to libQt5Sql5-mysql-5.6.0-253.1.x86_64
      downgrade of libQt5Sql5-sqlite-5.6.1-6.1.x86_64 to libQt5Sql5-sqlite-5.6.0-253.1.x86_64
      downgrade of libQt5WebChannel5-5.6.1-1.1.x86_64 to libQt5WebChannel5-5.5.1-3.1.x86_64
      install libQt5WebChannel5-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Xml5-5.6.1-6.1.x86_64 to libQt5Xml5-5.6.0-253.1.x86_64
      downgrade of libQt5XmlPatterns5-5.6.1-1.1.x86_64 to libQt5XmlPatterns5-5.5.1-3.1.x86_64
      install libQt5XmlPatterns5-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libKF5Archive5-5.21.0git.20160313T150150~0c371e3-2.2.x86_64 to libKF5Archive5-5.19.0-6.3.x86_64
      install libKF5Archive5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5Codecs5-5.21.0git.20160314T064217~dc11383-2.2.x86_64 to libKF5Codecs5-5.19.0-6.3.x86_64
      install libKF5Codecs5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5ConfigCore5-5.21.0git.20160313T151835~43f8c11-2.2.x86_64 to libKF5ConfigCore5-5.19.0-6.3.x86_64
      install libKF5ConfigCore5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5CoreAddons5-5.21.0git.20160322T034123~9ae6d76-4.1.x86_64 to libKF5CoreAddons5-5.19.0-6.3.x86_64
      install libKF5CoreAddons5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5Declarative5-5.21.0git.20160313T151957~848e46c-3.1.x86_64 to libKF5Declarative5-5.19.0-6.2.x86_64
      install libKF5Declarative5-5.19.0-6.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5I18n5-5.21.0git.20160313T152329~73967bf-1.2.x86_64 to libKF5I18n5-5.19.0-6.3.x86_64
      install libKF5I18n5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5ItemModels5-5.21.0git.20160313T152456~404c7cd-1.2.x86_64 to libKF5ItemModels5-5.19.0-6.3.x86_64
      install libKF5ItemModels5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5SonnetCore5-5.21.0git.20160314T070207~60d077f-1.2.x86_64 to libKF5SonnetCore5-5.19.0-6.7.x86_64
      install libKF5SonnetCore5-5.19.0-6.7.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5ThreadWeaver5-5.21.0git.20160314T070225~c84452a-1.2.x86_64 to libKF5ThreadWeaver5-5.19.0-6.3.x86_64
      install libKF5ThreadWeaver5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libKF5Attica5-5.21.0git.20160313T145944~2d654a0-2.2.x86_64 to libKF5Attica5-5.19.0-6.3.x86_64
      install libKF5Attica5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libQt5CLucene5-5.6.1-1.1.x86_64 to libQt5CLucene5-5.5.1-3.2.x86_64
      install libQt5CLucene5-5.5.1-3.2.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of libQt5Concurrent5-5.6.1-6.1.x86_64 to libQt5Concurrent5-5.6.0-253.1.x86_64
      downgrade of libQt5Core-devel-5.6.1-6.1.x86_64 to libQt5Core-devel-5.6.0-253.1.x86_64
      deinstallation of akonadi-16.07.70git.20160322T002302~7428b23-88.1.x86_64
      downgrade of libKF5DNSSD5-5.21.0git.20160313T152134~1c65cb3-1.2.x86_64 to libKF5DNSSD5-5.19.0-6.3.x86_64
      install libKF5DNSSD5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      downgrade of libQt5DBus-devel-5.6.1-6.1.x86_64 to libQt5DBus-devel-5.6.0-253.1.x86_64
      deinstallation of plasma5-workspace-branding-openSUSE-13.3-56.2.x86_64
      deinstallation of plasma5-desktop-5.6.90git~20160320T182224~cad0705-110.1.x86_64
      downgrade of kscreen5-5.6.90git~20160303T095737~327d481-3.3.x86_64 to kscreen5-5.5.5-10.1.x86_64
      install kscreen5-5.5.5-10.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      deinstallation of patterns-openSUSE-kde_imaging-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-kde-20150918-12.1.x86_64
      downgrade of libQt5WebChannel5-imports-5.6.1-1.1.x86_64 to libQt5WebChannel5-imports-5.5.1-3.1.x86_64
      install libQt5WebChannel5-imports-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
      downgrade of kconf_update5-5.21.0git.20160313T151835~43f8c11-2.2.x86_64 to kconf_update5-5.19.0-6.3.x86_64
      install kconf_update5-5.19.0-6.3.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE:Unstable  -->  openSUSE
      deinstallation of plasma5-desktop-branding-openSUSE-13.3-56.2.x86_64
      downgrade of libqt5-qtbase-common-devel-5.6.1-6.1.x86_64 to libqt5-qtbase-common-devel-5.6.0-253.1.x86_64
      downgrade of libQt5Sensors5-imports-5.6.1-1.1.x86_64 to libQt5Sensors5-imports-5.5.1-3.1.x86_64
      install libQt5Sensors5-imports-5.5.1-3.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
     Solution 2: do not install libqt5-qtct-0.22-24.1.x86_64
     Solution 3: break libqt5-qtct-0.22-24.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c):
    And btw whats the difference between that KDE:QT5 repo and the QT56 repo (http://download.opensuse.org/reposit...USE_Leap_42.1/) ?

  8. #8

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by hethkar View Post
    thanks will try to contact the maintainer too I tried to install after branching that package, but during installation i get
    You need KDE:Qt5 as well, to get the other Qt5.6 packages from there. As your libqt5-qtctl is built against them.

    Do you still have/use KDE:Qt56?
    I'm not sure if the packages are compatible enough.

    And btw whats the difference between that KDE:QT5 repo and the QT56 repo (http://download.opensuse.org/reposit...USE_Leap_42.1/) ?
    The main difference is that KDE:Qt5 contains the latest stable Qt5 release (5.6.0 at the moment), while KDE:Qt56 contains the latest git snapshot from the 5.6 branch.
    There shouldn't be much difference at the moment though, as 5.6.0 has just been released.

    If it doesn't work out for some reason (i.e. you need KDE:Qt56 for the unstable KF5/Plasma5 packages, but your new libqt5-qtct needs KDE:Qt5), you can also build your libqt5-qtct (that's branched from KDE:Qt5) against KDE:Qt56.
    To do this, click on "Advanced", and then on "Meta", and modify the line for your repo to say "Qt56" instead of "Qt5".

    If you're not sure, please post the content you see there, and I'll tell you what to change exactly.
    But it should actually be rather straight forward I think...
    Last edited by wolfi323; 23-Mar-2016 at 13:37.

  9. #9

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by wolfi323 View Post
    You need KDE:Qt5 as well, to get the other Qt5.6 packages from there. As your libqt5-qtctl is built against them.

    Do you still have/use KDE:Qt56?
    I'm not sure if the packages are compatible enough.
    Yes i have KDE:Qt56, and also had KDE:Qt5 enabled when go those huge list of problem messages while installing.

    Quote Originally Posted by wolfi323 View Post
    The main difference is that KDE:Qt5 contains the latest stable Qt5 release (5.6.0 at the moment), while KDE:Qt56 contains the latest git snapshot from the 5.6 branch.
    There shouldn't be much difference at the moment though, as 5.6.0 has just been released.

    If it doesn't work out for some reason (i.e. you need KDE:Qt56 for the unstable KF5/Plasma5 packages, but your new libqt5-qtct needs KDE:Qt5), you can also build your libqt5-qtct (that's branched from KDE:Qt5) against KDE:Qt56.
    To do this, click on "Advanced", and then on "Meta", and modify the line for your repo to say "Qt56" instead of "Qt5".

    If you're not sure, please post the content you see there, and I'll tell you what to change exactly.
    But it should actually be rather straight forward I think...
    This one right - https://build.opensuse.org/project/m...anches:KDE:Qt5 ? All "Qt5" to "Qt56" ?
    Code:
    <project name="home:hethkar:branches:KDE:Qt5">
      <title>Branch project for package libqt5-qtct</title>
      <description>This project was created for package libqt5-qtct via attribute OBS:Maintained</description>
      <person userid="hethkar" role="maintainer"/>
      <publish>
        <disable/>
      </publish>
      <debuginfo>
        <enable/>
      </debuginfo>
      <repository name="openSUSE_Leap_42.1">
        <path project="KDE:Qt5" repository="openSUSE_Leap_42.1"/>
        <arch>i586</arch>
        <arch>x86_64</arch>
      </repository>
      <repository name="openSUSE_Factory">
        <path project="KDE:Qt5" repository="openSUSE_Factory"/>
        <arch>i586</arch>
        <arch>x86_64</arch>
      </repository>
      <repository name="openSUSE_13.2">
        <path project="KDE:Qt5" repository="openSUSE_13.2"/>
        <arch>x86_64</arch>
        <arch>i586</arch>
      </repository>
      <repository name="openSUSE_13.1">
        <path project="KDE:Qt5" repository="openSUSE_13.1"/>
        <arch>x86_64</arch>
        <arch>i586</arch>
      </repository>
      <repository name="SLE_12">
        <path project="KDE:Qt5" repository="SLE_12"/>
        <arch>x86_64</arch>
      </repository>
    </project>
    Found this Meta too inside the package https://build.opensuse.org/package/m...t5/libqt5-qtct .
    Code:
    <package name="libqt5-qtct" project="home:hethkar:branches:KDE:Qt5">
      <title>Qt5 Configuration Tool</title>
      <description>This application allows users to configure Qt5 settings (theme, font, icons, etc.) under a DE/WM without Qt integration.</description>
      <publish>
        <enable repository="openSUSE_Leap_42.1"/>
        <enable repository="openSUSE_Factory"/>
      </publish>
    </package>

  10. #10

    Default Re: libqt5-qtct is not working

    Quote Originally Posted by wolfi323 View Post
    You need KDE:Qt5 as well, to get the other Qt5.6 packages from there. As your libqt5-qtctl is built against them.

    Do you still have/use KDE:Qt56?
    I'm not sure if the packages are compatible enough.
    oh btw forgot to mention that these three repos were enabled by default while installing it via one click install


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •