Results 1 to 8 of 8

Thread: ASUS K555L no sound

  1. #1

    Default ASUS K555L no sound

    Hi,

    I've just bought a new laptop, and the sound does not work at all. According to this page https://en.opensuse.org/SDB:Intel-HDA_sound_problems YaST can't configure it properly, but I can't do it manually either.

    rcalsasound command does not exist at all. I have no idea how to access that, I installed alsa-firmware already.

    When I give the command "head -n 1 /proc/asound/card0/codec*" I get "head: cannot open ‘/proc/asound/card0/codec*’ for reading: No such file or directory" and cannot countinue from there.

    "If for some reason you don't have a /proc/asound directory, then you are either not using ALSA, or your ALSA config is corrupt. "

    Yeah, but I don't know how to fix that. :S

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,782

    Default Re: ASUS K555L no sound

    Hi, too little information to be able to help...
    Your notebook seems nothing special compared to other ASUS that work OK (including mine...).
    Which desktop are you using? XFCE seems to have severe sound problems in Leap.
    It seems that you have an HDMI port: maybe sound is directed to that port by default instead of the internal speakers?

    Maybe you have to install alsa-utils (to have the "alsamixer" command for instance) and / or pavucontrol to be able to check the available outputs and being able to steer sound to your liking.
    Leap 15.1 Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.2Alpha

  3. #3

    Default Re: ASUS K555L no sound

    I use LXDE.

    ****, in the volume control it says HDMI (unplugged). How to I change that to internal speakers?

    Actually no, Built-in Audio Analog Stereo shows some sound going out, but still nothing to hear.

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,782

    Default Re: ASUS K555L no sound

    I seldom used LXDE, so I'm not the best person to help you, sorry. Unless you get better suggestions, you might still try the following (at your own risk...)
    I understand that a pure LXDE install might lack some sound configurations, unless some other packages brought them in.
    Please check that you have installed at least:
    alsa
    alsa-plugins
    alsa-utils

    alsa-oss might also help.

    LXDE by default comes with no pulseaudio AFAIK; unless you have a reason not to use it, I would recommend installing:
    pulseaudio
    pulseaudio-module-x11
    pulseaudio-utils
    alsa-plugins-pulse
    pavucontrol

    Make sure to have "Install Recommended packages" set in Yast2-Software before installing any of those, just to avoid missing something essential.
    At that point you should be able to check with "alsamixer" that your sound channel(s) are not muted and to steer them to your liking with "pavucontrol".
    If still no joy, you might have to tweak the snd_hda_intel kernel module options, but that should not be needed with a mainstream ASUS laptop IMHO.
    Leap 15.1 Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.2Alpha

  5. #5

    Default Re: ASUS K555L no sound

    Still no success.

    I've also tried to add the "model" parameters to the 50-sound.conf, but so success. It gives

    kry@suse-mekw:~> head -n 1 /proc/asound/card0/codec*
    head: cannot open ‘/proc/asound/card0/codec*’ for reading: No such file or directory

    at the moment, but before it was Realtek ACL3236.

    Okay, I restarted the computer, now it says

    kry@suse-mekw:~> head -n 1 /proc/asound/card0/codec*
    Codec: Intel Broadwell HDMI
    kry@suse-mekw:~> head -n 1 /proc/asound/card1/codec*
    Codec: Realtek ALC3236

    and shows there is sound everywhere, but it's completly silent!

  6. #6
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,782

    Default Re: ASUS K555L no sound

    Quote Originally Posted by Kry View Post
    Okay, I restarted the computer, now it says

    kry@suse-mekw:~> head -n 1 /proc/asound/card0/codec*
    Codec: Intel Broadwell HDMI
    kry@suse-mekw:~> head -n 1 /proc/asound/card1/codec*
    Codec: Realtek ALC3236

    and shows there is sound everywhere, but it's completly silent!
    Does it output something to the headphone jack? Apparently your PC has an output amplifier for internal speakers that might not be enabled by default; headphones usually work with no amplifier.
    If that is the case, maybe installing and playing with hdajackretask you can check and connect the correct codec output to the speakers.

    But first if you installed alsa-utils you might try:
    Code:
    speaker-test -Dfront:PCH -c 2
    or try adjusting according to what
    Code:
    aplay -L
    shows (see also "man speaker-test" for other options).
    Please make sure that no output (including Master, Speakers, PCM) is muted in alsamixer.

    Other things that you might try:
    - try to make "card1" the default one (the analog ALC3236 codec) in yast sound;
    - try to connect a TV or monitor with speakers to the HDMI port and see if sound is going there
    - try to select "internal speakers" (or everything else that might be connected and shown) in pavucontrol
    - try a different Desktop, with a LiveCD e.g. (Gnome worked out of the box with a similar laptop)
    or... hope that a sound specialist is reading this and offers to help!
    Leap 15.1 Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.2Alpha

  7. #7

    Default Re: ASUS K555L no sound

    I tried some of those already, speaker-test did not give any sound. I have tried other operating systems, and none of them had the sound working. Windows didn't even noticed there are either sound card or network cards (at least on oSUSE the internet worked...). I called the shop, and told me to bring back with the warranty, apparently the sound cards do not work at all.

    Sorry for wasting your precious time.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,593
    Blog Entries
    38

    Default Re: ASUS K555L no sound

    Sorry to read it could be a hardware problem.

    Best of luck with what ever replacement you end up with.
    .

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •