Results 1 to 3 of 3

Thread: Global preferences in Firefox 3

  1. #1
    arizonagroovejet NNTP User

    Default Global preferences in Firefox 3


    Can anyone explain to me how to specify global preferences for Firefox 3
    in openSUSE 11.1?

    For Firefox 2 I was putting stuff in to /usr/lib/firefox/mozilla.cfg.
    Stuff like

    lockPref("browser.cache.disk.capacity",10000);
    pref("browser.startup.homepage", "http://whatever.com");

    and in /usr/lib/firefox/greprefs/all.js I put a line to reference the
    mozilla.cfg and set general.config.obscure_value to 0 because I just
    can't be bothered with the byte shift 13 stuff.

    But with openSUSE 11.1 there is no /usr/lib/firefox/greprefs
    directory. The greprefs directory is there in the download of Firefox 3
    from mozilla.com but in Firefox 3 as provided in openSUSE 11.1 it's not
    there.

    I've found /usr/lib/firefox/defaults/preferences/ and by looking at the
    output of strace worked out that the contents of that directory is read
    in reverse alphabetical order. If I create a file in there called a.js
    and specify a few settings in there then some take effect, e.g. disk
    cache, and some are ignored, e.g. homepage.

    So where am I supposed to put settings such that they take effect for
    all users and lock the settings that I want to prevent users changing?


    --
    arizonagroovejet
    ------------------------------------------------------------------------
    arizonagroovejet's Profile: http://forums.opensuse.org/member.php?userid=19832
    View this thread: http://forums.opensuse.org/showthread.php?t=407797


  2. #2
    Malcolm NNTP User

    Default Re: Global preferences in Firefox 3

    Quote Originally Posted by arizonagroovejet
    Can anyone explain to me how to specify global preferences for Firefox 3
    in openSUSE 11.1?

    For Firefox 2 I was putting stuff in to /usr/lib/firefox/mozilla.cfg.
    Stuff like

    lockPref("browser.cache.disk.capacity",10000);
    pref("browser.startup.homepage", "http://whatever.com");

    and in /usr/lib/firefox/greprefs/all.js I put a line to reference the
    mozilla.cfg and set general.config.obscure_value to 0 because I just
    can't be bothered with the byte shift 13 stuff.

    But with openSUSE 11.1 there is no /usr/lib/firefox/greprefs
    directory. The greprefs directory is there in the download of Firefox 3
    from mozilla.com but in Firefox 3 as provided in openSUSE 11.1 it's not
    there.

    I've found /usr/lib/firefox/defaults/preferences/ and by looking at the
    output of strace worked out that the contents of that directory is read
    in reverse alphabetical order. If I create a file in there called a.js
    and specify a few settings in there then some take effect, e.g. disk
    cache, and some are ignored, e.g. homepage.

    So where am I supposed to put settings such that they take effect for
    all users and lock the settings that I want to prevent users changing?
    Hi
    Use fgrep in the preferences directory and you will see that if your
    file is read before firefox-branding then it will be over ridden.
    Create your file with the first character a number and it should be
    read last....

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 1 day 21:24, 4 users, load average: 0.14, 0.43, 0.42
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.29


  3. #3
    arizonagroovejet NNTP User

    Default Re: Global preferences in Firefox 3


    malcolmlewis;1944153 Wrote:
    > Hi
    > Use fgrep in the preferences directory and you will see that if your
    > file is read before firefox-branding then it will be over ridden.
    > Create your file with the first character a number and it should be
    > read last....
    >


    I know what fgrep is but I don't understand what you mean when you say
    use it. What am I looking for?

    The output of strace 'here' (http://pastebin.com/f25c5964b) indicates
    that calling the file a.js causes it to be read after all the other
    files in the preferences directory. For some reason all the files are
    being read more than once, but a.js is still the last one to be read.
    Changing the name to 1.js makes no difference.

    Also I forget to mention that locking preferences with lockPref in a.js
    doesn't work. E.g. if I specify a value for browser.cache.disk.capacity
    with pref then that is taken notice of but trying to lock it with
    lockPref it gets ignore. browser.cache.disk.capacity is the only setting
    I've tried so far that any notice is taken of at all actually.


    --
    arizonagroovejet
    ------------------------------------------------------------------------
    arizonagroovejet's Profile: http://forums.opensuse.org/member.php?userid=19832
    View this thread: http://forums.opensuse.org/showthread.php?t=407797


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •