Results 1 to 6 of 6

Thread: kdm not working

  1. #1
    dusinm NNTP User

    Default kdm not working


    hi, when I want to start kdm, nothing happens and in /var/log/kdm.log is


    Fatal server error:
    Caught signal 11. Server aborting

    Xorg died, signal 6
    /usr/share/kde4/apps/kdm/read_sysconfig.sh: line 75: pam-config:
    command not found

    but pam-config is installed.
    gdm works well, but I can't turn off computer from KDE, it always
    switches back to gdm


    --
    dusinm
    ------------------------------------------------------------------------
    dusinm's Profile: http://forums.opensuse.org/member.php?userid=10677
    View this thread: http://forums.opensuse.org/showthread.php?t=407688


  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: kdm not working

    On 02/12/2009 dusinm wrote:
    > /usr/share/kde4/apps/kdm/read_sysconfig.sh: line 75: pam-config:


    You can edit that line, insert /usr/sbin/ right in front of the $. It is a workaround, though.

    I wonder if that's all, because I still have the greeter crash after the latest kde42 update :-(

    Uwe


  3. #3
    dusinm NNTP User

    Default Re: kdm not working


    in read_sysconfig.sh is this


    if [ "$(/usr/sbin/pam-config -q --fp)" = "auth:" ]; then
    echo "PluginsLogin=generic"
    fi



    so this shouldn't be problem


    --
    dusinm
    ------------------------------------------------------------------------
    dusinm's Profile: http://forums.opensuse.org/member.php?userid=10677
    View this thread: http://forums.opensuse.org/showthread.php?t=407688


  4. #4
    Uwe Buckesfeld NNTP User

    Default Re: kdm not working

    * dusinm,

    interesting, because there was no full path in mine.
    What's the version of kdm you have installed?

    Uwe

  5. #5
    dusinm NNTP User

    Default Re: kdm not working


    i've got 4.1.3-170.2


    --
    dusinm
    ------------------------------------------------------------------------
    dusinm's Profile: http://forums.opensuse.org/member.php?userid=10677
    View this thread: http://forums.opensuse.org/showthread.php?t=407688


  6. #6
    Uwe Buckesfeld NNTP User

    Default Re: kdm not working

    * dusinm wrote, On 02/12/2009 08:36 PM:
    > i've got 4.1.3-170.2



    Try a "zypper up" and see if kde related stuff gets updated. Also try and simply reinstall that single kdm package.

    Me, I'm using the kde3 kdm now :-(

    Uwe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •