Results 1 to 6 of 6

Thread: weird phantom application running

  1. #1
    draconar NNTP User

    Default weird phantom application running


    hello, all!

    does anybody knows which application runs as process called
    -engine_ser-? I was working on some math simulations and thought my
    computer was running low because of it (too many data files being dumped
    on every iteration), but there was this process -engine_ser- that was
    sucking 50% of my CPU's processing power!


    --
    draconar
    ------------------------------------------------------------------------
    draconar's Profile: http://forums.opensuse.org/member.php?userid=22203
    View this thread: http://forums.opensuse.org/showthread.php?t=407672


  2. #2
    smpoole7 NNTP User

    Default Re: weird phantom application running


    draconar;1943435 Wrote:
    > hello, all!
    >
    > does anybody knows which application runs as process called
    > -engine_ser-? I was working on some math simulations and thought my
    > computer was running low because of it (too many data files being dumped
    > on every iteration), but there was this process -engine_ser- that was
    > sucking 50% of my CPU's processing power!


    Sounds like something is running valgrind!


    --
    smpoole7
    ------------------------------------------------------------------------
    smpoole7's Profile: http://forums.opensuse.org/member.php?userid=13513
    View this thread: http://forums.opensuse.org/showthread.php?t=407672


  3. #3
    draconar NNTP User

    Default Re: weird phantom application running


    smpoole7;1943437 Wrote:
    > Sounds like something is running valgrind!


    how can I tell which program is running it? I'm using a C++ library
    which uses HDF5 and MPI. Could it be? how can I be sure?


    thanks!


    --
    draconar
    ------------------------------------------------------------------------
    draconar's Profile: http://forums.opensuse.org/member.php?userid=22203
    View this thread: http://forums.opensuse.org/showthread.php?t=407672


  4. #4
    smpoole7 NNTP User

    Default Re: weird phantom application running


    draconar;1943460 Wrote:
    > how can I tell which program is running it? I'm using a C++ library
    > which uses HDF5 and MPI. Could it be? how can I be sure?
    >
    >
    > thanks!


    Which library is it? Is it a debug build, or a release build?

    Do you only get the CPU loading when running stuff that uses this
    library, or does it happen all the time? If the former, then yep, that
    library is probably the issue.


    --
    smpoole7
    ------------------------------------------------------------------------
    smpoole7's Profile: http://forums.opensuse.org/member.php?userid=13513
    View this thread: http://forums.opensuse.org/showthread.php?t=407672


  5. #5
    draconar NNTP User

    Default Re: weird phantom application running


    smpoole7;1943470 Wrote:
    > Which library is it? Is it a debug build, or a release build?
    >
    > Do you only get the CPU loading when running stuff that uses this
    > library, or does it happen all the time? If the former, then yep, that
    > library is probably the issue.


    It's called SAMRAI, from LLNL. It's a release version.

    After I killed -engine_ser-, it didn't came back to life again. I have
    rebuilt my software but no signs of -engine_ser-. Weeeeeeeeird.


    --
    draconar
    ------------------------------------------------------------------------
    draconar's Profile: http://forums.opensuse.org/member.php?userid=22203
    View this thread: http://forums.opensuse.org/showthread.php?t=407672


  6. #6
    smpoole7 NNTP User

    Default Re: weird phantom application running


    draconar;1943475 Wrote:
    > Weeeeeeeeird.


    You got that right.

    Maybe you should run a cron job every 5 minutes that pgreps for
    "engine_ser" and automatically kills it.





    (Or not.)

    (Seriously, something or someone installed Valgrind on that computer --
    maybe it came as part of the development package ...?)


    --
    smpoole7
    ------------------------------------------------------------------------
    smpoole7's Profile: http://forums.opensuse.org/member.php?userid=13513
    View this thread: http://forums.opensuse.org/showthread.php?t=407672


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •