Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Unable to view flash after most recent software repository u

  1. #1
    ntcrawler NNTP User

    Default Unable to view flash after most recent software repository u


    I'm running OpenSUSE 10.3 (kernel version 2.6.22.19-0.2 64-bit) with KDE
    3.5.7 release 72.11. The other day I let the system update itself,
    download the latest patches, etc after not having done so for about 4-5
    months. Needless to say there were quite a few patches! Everything
    seemed to go fine except now I can no longer view flash content in my
    web browsers, either Firefox 2.0.0.19 or Konqueror. Initially I just had
    a white blank field where the video used to be, but after rebooting I
    just get the generic message "Hello, you either have JavaScript turned
    off or an old version of Adobe's Flash Player." Needless to say
    JavaScript is turned on and I do have the latest version of Flash Player
    installed, at least according to YaST I do.

    I tried reinstalling it both through the online software repository and
    by downloading an rpm for version 10.0.15.3-release-i386 directly from
    Adobe's site. I even tried removing both Firefox and Flash, then
    reinstalling after restarting my system. Each time the installation
    seemed to go fine but websites with flash content keep insisting I do
    not have flash installed. Could someone help me with this please?


    --
    ntcrawler
    ------------------------------------------------------------------------
    ntcrawler's Profile: http://forums.opensuse.org/member.php?userid=22340
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  2. #2
    caf4926 NNTP User

    Default Re: Unable to view flash after most recent software repository u


    In a terminal

    rpm -qi flash-player


    --
    Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)"93" | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  3. #3
    ntcrawler NNTP User

    Default Re: Unable to view flash after most recent software repository u


    Results of rpm -qi flash-player:

    stardrive:~ # rpm -qi flash-player
    Name : flash-player Relocations: (not
    relocatable)
    Version : 9.0.152.0 Vendor: SUSE LINUX
    Products GmbH, Nuernberg, Germany
    Release : 0.1 Build Date: Thu Dec 18
    11:01:21 2008
    Install Date: Wed Feb 11 21:43:34 2009 Build Host:
    emerson.suse.de
    Group : Productivity/Networking/Web/Browsers Source RPM:
    flash-player-9.0.152.0-0.1.src.rpm
    Size : 16154624 License: Any commercial
    Signature : DSA/SHA1, Thu Dec 18 11:57:46 2008, Key ID
    a84edae89c800aca
    Packager : 'Submitting Bug Reports - openSUSE'
    (http://bugs.opensuse.org)
    Summary : Macromedia Flash Plug-In
    Description :
    This package contains Macromedia's Flash plug-in for the supported Web
    browsers. This includes Netscape6, Mozilla (all Gecko browsers), and
    Konqueror.



    Authors:
    --------
    Adobe Systems Incorporated
    Distribution: openSUSE 10.3 (i586)


    Results of trying to view flash content:

    [image: http://img443.imageshack.us/my.php?i...esktopmc4.jpg]




    --
    ntcrawler
    ------------------------------------------------------------------------
    ntcrawler's Profile: http://forums.opensuse.org/member.php?userid=22340
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  4. #4
    caf4926 NNTP User

    Default Re: Unable to view flash after most recent software repository u


    I suspect then that you will need to un-install that flash player via
    Yast software management

    download the latest flash .rpm from adobe
    'Adobe - Adobe Flash Player'
    (http://get.adobe.com/flashplayer/otherversions/)

    open a terminal in the dir you saved the file, then go su and do

    rpm -ihv *Packagename*

    *If you type the first letter of the Package name and hit tab it will
    auto complete


    --
    Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)"93" | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  5. #5
    consused NNTP User

    Default Re: Unable to view flash after most recent software repository u


    Hi caf4926

    I have exactly all the same releases mentioned by the OP but my fully
    updated 10.3 is 32bit and it works perfectly well. Could this just be a
    problem with flash on openSUSE 64bit?

    Also, from the Adobe site would he get Flash 10? If so and it worked,
    that would be interesting to know and compare with the problems some are
    getting with Flash 10 and openSUSE 11.1.


    --
    consused
    ------------------------------------------------------------------------
    consused's Profile: http://forums.opensuse.org/member.php?userid=1890
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  6. #6
    ntcrawler NNTP User

    Default Re: Unable to view flash after most recent software repository u


    I havee uninstalled the flash player and flash-plugin via YaST and
    verified that they have been removed from the system:

    stardrive:~ # rpm -qi flash-player
    package flash-player is not installed

    I then proceeded to download the latest available version of flash for
    Linux from Adobe's website (which is the same website provided in the
    link you game me). File downloaded:
    flash-plugin-10.0.15.3-release.i386.rpm

    I then proceeded to install it manually from a command line as
    recommended:

    stardrive:~/Downloads # rpm -ihv
    flash-plugin-10.0.15.3-release.i386.rpm
    Preparing... ###########################################
    [100%]
    1:flash-plugin ###########################################
    [100%]

    To me that means the installation was successful. Restarted the web
    browser, and once again get: "Hello, you either have JavaScript turned
    off or an old version of Adobe's Flash Player. Get the latest Flash
    player." if I try to view anything with flash content.

    Also, now the system claims:

    stardrive:~/Downloads # rpm -qi flash-player
    package flash-player is not installed

    I thought I just installed it? Now I'm really confused.

    I've had this system since December 2007. It's always been 64-bit
    and with 1-2 little quirks it's worked perfectly fine with Flash 32-bit
    (is there a 64-bit version?) up until that latest online patch update 2
    days ago. argh!


    --
    ntcrawler
    ------------------------------------------------------------------------
    ntcrawler's Profile: http://forums.opensuse.org/member.php?userid=22340
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  7. #7
    caf4926 NNTP User

    Default Re: Unable to view flash after most recent software repository u


    _64 needs nspluginwrapper

    when you removed Flash earlier - you will not have removed this
    so go check if it's installed - if not - install it

    If Flash still does not work
    uninstall the .rpm (it may be possible from Yast)

    but to delete from terminal

    rpm -e *package name

    Then install the repo flash and try again.


    --
    Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)"93" | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  8. #8
    consused NNTP User

    Default Re: Unable to view flash after most recent software repository u


    > Also, now the system claims:
    >
    > stardrive:~/Downloads # rpm -qi flash-player
    > package flash-player is not installed
    >
    > I thought I just installed it? Now I'm really confused.


    The rpm you downloaded was not called *flash-player*, according to your
    post it was called *flash-plugin-10.0.15.3-release.i386.rpm*.


    --
    consused
    ------------------------------------------------------------------------
    consused's Profile: http://forums.opensuse.org/member.php?userid=1890
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  9. #9
    consused NNTP User

    Default Re: Unable to view flash after most recent software repository u


    Just came across this: 'Install the latest Adobe flash player, the rpm
    way' (http://tinyurl.com/dkdkca) in the unreviewed Howto forum. Haven't
    used it myself yet, but after downloading and installing with Yast, it
    includes a final copy step not mentioned earlier.


    --
    consused
    ------------------------------------------------------------------------
    consused's Profile: http://forums.opensuse.org/member.php?userid=1890
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


  10. #10
    ntcrawler NNTP User

    Default Re: Unable to view flash after most recent software repository u


    OK this is starting to become complicated so please bear with me (and
    thanks for everyone's help so far!!). I have nspluginwrapper installed.
    But just to be sure I tried updating it via YaST and then reinstalled it
    anyways.

    Current status of nspluginwrapper:

    STARDRIVE:/ # RPM -QI NSPLUGINWRAPPER
    NAME : NSPLUGINWRAPPER RELOCATIONS: (NOT
    RELOCATABLE)
    VERSION : 0.9.91.4 VENDOR: SUSE LINUX
    PRODUCTS GMBH, NUERNBERG, GERMANY
    RELEASE : 58.1 BUILD DATE: MON JUN 23
    16:25:14 2008
    INSTALL DATE: FRI FEB 13 00:35:57 2009 BUILD HOST: AGUIRRE.SUSE.DE
    GROUP : PRODUCTIVITY/NETWORKING/WEB/UTILITIES SOURCE RPM:
    NSPLUGINWRAPPER-0.9.91.4-58.1.SRC.RPM
    SIZE : 269956 LICENSE: GPL V2 OR LATER
    SIGNATURE : DSA/SHA1, MON JUN 23 16:35:47 2008, KEY ID
    A84EDAE89C800ACA
    PACKAGER : 'SUBMITTING BUG REPORTS - OPENSUSE'
    (HTTP://BUGS.OPENSUSE.ORG)
    URL : 'NSPLUGINWRAPPER [WEB > GWENOLE BEAUCHESNE]'
    (HTTP://GWENOLE.BEAUCHESNE.INFO/PROJE...PLUGINWRAPPER/)
    SUMMARY : COMPATIBILITY LAYER FOR NETSCAPE 4 PLUG-INS
    DESCRIPTION :
    NSPLUGINWRAPPER IS AN OPEN SOURCE COMPATIBILITY PLUGIN FOR NETSCAPE 4
    (NPAPI) PLUGINS. IT ENABLES YOU TO USE PLUGINS ON PLATFORMS THEY WERE
    NOT BUILT FOR. FOR EXAMPLE, YOU CAN USE THE PLUGINS COMPILED FOR I386
    IN MOZILLA ON LINUX/X86_64 OR OTHER ARCHITECTURES. THIS PACKAGE
    CONSISTS OF:

    * NPVIEWER: THE PLUG-IN VIEWER

    * NPWRAPPER.SO: THE BROWSER-SIDE PLUG-IN

    * NSPLUGINWRAPPER: A TOOL TO MANAGE PLUG-INS INSTALLATION AND UPDATE



    AUTHORS:
    --------
    GWENOLE BEAUCHESNE <GB.PUBLIC@FREE.FR>
    DISTRIBUTION: OPENSUSE 10.3 (X86-64)

    So that must be my system's fancy way of saying it's installed.

    Next I noticed under YaST that there are 2 entries that come up (well
    actually more than that) when doing a repository search for "flash":

    FLASH-PLUGIN - ADOBE FLASH PLAYER 10.0

    ADOBE FLASH PLUGIN 10.0.15.3 FULLY SUPPORTED: MOZILLA SEAMONKEY 1.0+,
    FIREFOX 1.5+, MOZILLA 1.7.13+
    'ADOBE - DOWNLOADS' (HTTP://WWW.ADOBE.COM/DOWNLOADS/)

    FLASH-PLAYER - MACROMEDIA FLASH PLUG-IN

    THIS PACKAGE CONTAINS MACROMEDIA'S FLASH PLUG-IN FOR THE SUPPORTED WEB
    BROWSERS. THIS INCLUDES NETSCAPE6, MOZILLA (ALL GECKO BROWSERS), AND
    KONQUEROR. VERSION 9.0.152.0-0.1

    This must be the confusion for flash-player vs flash-plugin. When I
    started trying to fix this problem I originally had them both installed.
    I'm assuming the one we want here is flash-plug because 1) that has the
    latest version, and 2) the website matches the one in one of your
    replies and threads above, and the file I end up downloading from
    Adobe's website is called "flash-plugin-10.0.15.3-release.i386.rpm".

    So here's what I did:

    1. closed all browser windows
    2. uninstalled both flash-player and flash-plugin
    3. uninstalled and reinstalled nspluginwrapper
    4. installed flash-plugin-10.0.15.3-release.i386.rpm by right-clicking
    and selecting "open with install software"
    5. Went to command prompt, did the "sudo cp
    /usr/lib/flash-plugin/libflashplayer.so /usr/lib/browser-plugins/"
    6. Checked both folders. Made sure that the files in both folders are
    there. Here they are:

    *stardrive:/usr/lib/flash-plugin # ls -l
    total 9852
    -rw-r--r-- 1 root root 34516 Nov 18 17:52 LICENSE
    -rw-r--r-- 1 root root 3180 Nov 18 17:52 README
    -rwxr--r-- 1 root root 1367 Nov 18 17:52 homecleanup
    -rwxr-xr-x 1 root root 10022452 Nov 18 17:53 libflashplayer.so
    -rwxr--r-- 1 root root 3116 Nov 18 17:52 setup


    stardrive:/usr/lib/browser-plugins # ls -l
    total 9804
    lrwxrwxrwx 1 root root 28 Nov 11 2007 javaplugin.so ->
    /etc/alternatives/javaplugin
    -rwxr-xr-x 1 root root 10022452 Feb 13 00:37 libflashplayer.so
    *
    6. As one final sanity check did a:

    *stardrive:/usr/lib/browser-plugins # rpm -qi flash-plugin
    Name : flash-plugin Relocations: (not
    relocatable)
    Version : 10.0.15.3 Vendor: Adobe Systems
    Inc.
    Release : release Build Date: Tue Nov 18
    17:54:02 2008
    Install Date: Fri Feb 13 00:34:07 2009 Build Host:
    fplayerbuild4-lnx.labs.corp.adobe.com
    Group : Applications/Internet Source RPM:
    flash-plugin-10.0.15.3-release.src.rpm
    Size : 10067811 License: Commercial
    Signature : (none)
    Packager : Adobe Systems Inc.
    URL : 'Adobe - Downloads' (http://www.adobe.com/downloads/)
    Summary : Adobe Flash Player 10.0
    Description :
    Adobe Flash Plugin 10.0.15.3
    Fully Supported: Mozilla SeaMonkey 1.0+, Firefox 1.5+, Mozilla 1.7.13+
    Distribution: (none)
    *
    Looks good?

    Opened up a firefox window, went to youtube, made sure java and
    javascript are both turned on, and got a:

    "Hello, you either have JavaScript turned off or an old version of
    Adobe's Flash Player. Get the latest Flash player."

    AAARRRGGGHHH!!!

    fyi nspluginwrapper -l is supposed to list all the plugins currently
    installed. The command returns empty. Should there be anything?


    --
    ntcrawler
    ------------------------------------------------------------------------
    ntcrawler's Profile: http://forums.opensuse.org/member.php?userid=22340
    View this thread: http://forums.opensuse.org/showthread.php?t=407641


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •