Results 1 to 6 of 6

Thread: pure-ftpd - PassivePortRange setting ignored

  1. #1
    Hefto99 NNTP User

    Default pure-ftpd - PassivePortRange setting ignored


    Hi all,

    I'm trying to use ftp in passive mode. Authentication is OK over
    TLS/SSL, but command LIST ends with timeout.

    I have checked firewall log on server and it seems that pure-ftpd
    doesn't obey defined PassivePortRange 35000 36000.

    Configuration seems correct (checked both in
    /etc/pure-ftpd/pure-ftpd.conf and yast).

    I'm using OpenSUSE 11.1 64 bit, pure-ftpd is 1.0.21

    How to persuade pure-ftpd to use defined port range?

    Thank you for support,
    H99


    --
    Hefto99
    ------------------------------------------------------------------------
    Hefto99's Profile: http://forums.opensuse.org/member.php?userid=1445
    View this thread: http://forums.opensuse.org/showthread.php?t=407569


  2. #2
    ken yap NNTP User

    Default Re: pure-ftpd - PassivePortRange setting ignored


    Looks like this bug has been reported already:

    https://bugzilla.novell.com/show_bug.cgi?id=465954

    and the patch is already in the update repo.

    > # zypper se pure-ftpd
    > Loading repository data...
    > Reading installed packages...
    >
    > S | Name | Summary
    > | Type
    > --+-----------+-----------------------------------------------------------------+-----------
    > | pure-ftpd | A Lightweight, Fast, and Secure FTP Server
    > | package
    > | pure-ftpd | A Lightweight, Fast, and Secure FTP Server
    > | srcpackage
    > | pure-ftpd | pure-ftpd: fix to honor PassivePortRange in
    > /etc/pure-ftpd.conf | patch



    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=407569


  3. #3
    superdude00 NNTP User

    Default Re: pure-ftpd - PassivePortRange setting ignored


    Hi, I had the same problem. As a first you've got to set the portrange
    in the pure-ftpd.conf file like you already did. Next to that you've got
    to open those ports in your computers firewall as well. In your case
    35000 to 36000.

    Greetsz, Superdude


    --
    superdude00
    ------------------------------------------------------------------------
    superdude00's Profile: http://forums.opensuse.org/member.php?userid=16381
    View this thread: http://forums.opensuse.org/showthread.php?t=407569


  4. #4
    Hefto99 NNTP User

    Default Re: pure-ftpd - PassivePortRange setting ignored


    Hi,

    thanks a lot for info.
    I think I'm already using the latest version - both installed and
    available versions are 1.0.21-182.32.1 (repo for updates is
    http://download.opensuse.org/update/11.1/, using yast)... nothing newer
    appears in my Online updates...

    Ports are opened on the firewall


    --
    Hefto99
    ------------------------------------------------------------------------
    Hefto99's Profile: http://forums.opensuse.org/member.php?userid=1445
    View this thread: http://forums.opensuse.org/showthread.php?t=407569


  5. #5
    ken yap NNTP User

    Default Re: pure-ftpd - PassivePortRange setting ignored


    Check whether the generation of the running config file puts
    -p35000:36000 in the pure-ftpd command line as explained in the bug
    report. If not you may have to rerun the config, or something. Also
    check for silly spelling errors. I see that according to the bug report
    the required syntax is 35000:36000 but you seem to have used a space.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=407569


  6. #6
    Hefto99 NNTP User

    Default Re: pure-ftpd - PassivePortRange setting ignored


    You are right, my syntax is wrong.... I have overlooked it in the patch
    description.

    Everything works fine now.

    Thanks!


    --
    Hefto99
    ------------------------------------------------------------------------
    Hefto99's Profile: http://forums.opensuse.org/member.php?userid=1445
    View this thread: http://forums.opensuse.org/showthread.php?t=407569


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •