Results 1 to 8 of 8

Thread: Firefox 3.0.6 broken after "security update" or?

  1. #1
    FlameBait NNTP User

    Default Firefox 3.0.6 broken after "security update" or?


    I installed the Mozilla Firefox Security update via the "Updater Applet"
    today. Now I can't access my preferences or save links/files. Trying to
    launch "preferences" open a blank box in firefox.

    I also installed KDE4 yesterday and that may have done it too. I am
    running KDE 3.5 and don't recall if I saved any files with Mozilla after
    I added KDE4 but it did wipe out some icons in KDE 3.5 and I have to fix
    that after I decided KDE4 was not for me and booted back to KDE 3.5


    --
    FlameBait
    ------------------------------------------------------------------------
    FlameBait's Profile: http://forums.opensuse.org/member.php?userid=21323
    View this thread: http://forums.opensuse.org/showthread.php?t=407545


  2. #2
    jaybott NNTP User

    Default Re: Firefox 3.0.6 broken after "security update" or?


    Try going into yast and check update on the firefox package. It will
    reinstall it. Not sure why this happened but I updated mine and its
    fine.


    --
    jaybott
    ------------------------------------------------------------------------
    jaybott's Profile: http://forums.opensuse.org/member.php?userid=263
    View this thread: http://forums.opensuse.org/showthread.php?t=407545


  3. #3
    FlameBait NNTP User

    Default Re: Firefox 3.0.6 broken after "security update" or?


    I did as you recommended but it is still broken. Don't know how to deal
    with this. Anyone else have an Idea or have this problem?


    --
    FlameBait
    ------------------------------------------------------------------------
    FlameBait's Profile: http://forums.opensuse.org/member.php?userid=21323
    View this thread: http://forums.opensuse.org/showthread.php?t=407545


  4. #4
    FlameBait NNTP User

    Default Re: Firefox 3.0.6 broken after "security update" or?


    Trying to access "downthem all" as I was trying open any thing. I got
    this in a popup,


    XML Parsing Error:uindefined entity
    Location:chrome://dta/content/dta/select.xul
    Line Number 65, Colimn 3:
    ------------------------------^
    <toolbar class="finddiles" chromdir=&local.dir;">

    What am I supposed to do for a real browser as it seems Mozilla is not
    ever going to work again.

    This stuff is beyond me I am just a desktop user and stuff is supposed
    to just work with easily found fixes.


    --
    FlameBait
    ------------------------------------------------------------------------
    FlameBait's Profile: http://forums.opensuse.org/member.php?userid=21323
    View this thread: http://forums.opensuse.org/showthread.php?t=407545


  5. #5
    FlameBait NNTP User

    Default Re: Firefox 3.0.6 broken after "security update" or?


    Now it will not even launch
    when I attempt it I get this popup. [JavaScript Application] Error
    launching browser window. no XBL binding for browser

    A "security update" should not do this. This is WHY many people ignore
    security updates. Konqueror is NOT my idea of browser. I installed Opera
    too but I don't like the interface.

    Looks like all my preferences,cookies and bookmarks are useless now.


    --
    FlameBait
    ------------------------------------------------------------------------
    FlameBait's Profile: http://forums.opensuse.org/member.php?userid=21323
    View this thread: http://forums.opensuse.org/showthread.php?t=407545


  6. #6
    Malcolm NNTP User

    Default Re: Firefox 3.0.6 broken after "security update" or?

    Quote Originally Posted by FlameBait
    Now it will not even launch
    when I attempt it I get this popup. [JavaScript Application] Error
    launching browser window. no XBL binding for browser

    A "security update" should not do this. This is WHY many people ignore
    security updates. Konqueror is NOT my idea of browser. I installed Opera
    too but I don't like the interface.

    Looks like all my preferences,cookies and bookmarks are useless now.
    Hi
    Your bookmarks live down in ~/.mozilla directory so you can always
    recover a copy from here. Have you tried starting in safe-mode
    Code:
    firefox -safe-mode
    BTW I have three machines here that updated firefox, all are working
    fine. Maybe it was a combination of your other updates.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 1 day 16:04, 3 users, load average: 0.37, 0.17, 0.11
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.29


  7. #7
    FlameBait NNTP User

    Default Re: Firefox 3.0.6 broken after "security update" or?


    malcolmlewis;1942689 Wrote:
    > Hi
    > Your bookmarks live down in ~/.mozilla directory so you can always
    > recover a copy from here. Have you tried starting in safe-mode
    > >

    Code:
    --------------------
    > >

    > firefox -safe-mode
    >

    --------------------
    > >

    > BTW I have three machines here that updated firefox, all are working
    > fine. Maybe it was a combination of your other updates.
    >
    > --
    > Cheers Malcolm (Linux Counter #276890)
    > openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    > up 1 day 16:04, 3 users, load average: 0.37, 0.17, 0.11
    > GPU GeForce 6600 TE/6200 TE - Driver Version: 180.29


    I am aware of that hidden directory but If I can not even launch the
    browser now that does me no good really. As it stands now I can't even
    get it to run due to that JAVA error. After a bit I am going to restart
    my KDE session and see if that changes things at all.


    --
    FlameBait
    ------------------------------------------------------------------------
    FlameBait's Profile: http://forums.opensuse.org/member.php?userid=21323
    View this thread: http://forums.opensuse.org/showthread.php?t=407545


  8. #8
    FlameBait NNTP User

    Default Re: Firefox 3.0.6 broken after "security update" or?


    Indeed there was a "lock" of some type from the KDE session. Restarting
    the KDE session allowed the update to process and firefox launched
    normally with all features.


    --
    FlameBait
    ------------------------------------------------------------------------
    FlameBait's Profile: http://forums.opensuse.org/member.php?userid=21323
    View this thread: http://forums.opensuse.org/showthread.php?t=407545


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •