Hi there,

I got a new workstation and after working a long time with OpenSuse
10.2 on the old one I decided to install OpenSuse11.1 on the new one.
Since then I'm not able to connect to our local jabber server with the
new machine. I tried with Pidgin 2.5.1, Kopete 0.60.3 and PSI 0.12.

Kopete doesn't give any error message, PSI tells me "There was an error
communicating with the jabber server: Details: Authentication error: Not
authorized". It doesn't matter wether I enable SSL/TLS connection or
not, the only difference is that PSI tells me, that the certificate was
self-signed before displaying the message mentioned above.

When running Pidgin it shows me the error message "Error while
reading", when running it with -d Parameter it shows the following error
on the console:


Code:
--------------------

(09:43:51) gnutls: receive failed: A TLS packet with unexpected length was received.
(09:43:51) jabber: Disconnected: I/O error
(09:43:51) gnutls: receive failed: The specified session has been invalidated for some reason
(09:43:51) jabber: Disconnected: I/O error
(09:43:51) account: Disconnecting account xyz
(09:43:51) connection: Disconnecting connection abc
(09:43:51) connection: Destroying connection def

--------------------


The strange thing is that Pidgin 2.4.3 under OpenSuse 10.2 works
perfectly but Pidgin 2.5.1 with exactly the same settings failes.

Has anyone an idea what could cause this error?


--
Workstation85
------------------------------------------------------------------------
Workstation85's Profile: http://forums.opensuse.org/member.php?userid=22181
View this thread: http://forums.opensuse.org/showthread.php?t=407464